Answered

Trouble reconnecting surround rears

  • 10 August 2019
  • 4 replies
  • 60 views

I wonder if anyone can help.
My set up is Sonos Beam plus 2 x sonos 1 as rear surrounds.
All working fine until I just changed router.
Once I realised that the system wasnt on the network anymore, I went through the guided process of re connecting to the network, which was successful.

Sonos app showing room as "sonos beam +? +?
I've removed the 2 ones, and went through the process of adding surrounds again.

I have powered down the speakers for 10 seconds.
As I wasn't getting green lights, I was getting white, the app told me to press the connect button.
I get a message saying speaker added, light is flashing red then changes to solid white.
Once this is done on both speakers, I strangely get a message to say that the whole room has been removed, but it still appears in app.

System then tries to connect all the speakers up but continually fails.

I've run out of ideas!
icon

Best answer by Airgetlam 10 August 2019, 20:07

I would hazard a guess that there's something going on with your new router that's blocking the ability for the surrounds to get IP addresses (usually what causes the +? +?)

You may want to check that your router has enough IP addresses that there's some available for the surrounds to get. Some routers don't allow a full set of IP addresses, and limit them to a rather small number.

You haven't told us what router you're now using, but there's some routers that don't appear to "play nice" with Sonos, there's a list around here somewhere, do a search for "supported devices" and you should find the FAQ. Which includes, in many cases, things to do in the settings of the router to allow the appropriate systems that Sonos uses to work properly.

At the end of the day, you may want to contact Sonos Support to discuss it.

I suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.
View original

4 replies

I would hazard a guess that there's something going on with your new router that's blocking the ability for the surrounds to get IP addresses (usually what causes the +? +?)

You may want to check that your router has enough IP addresses that there's some available for the surrounds to get. Some routers don't allow a full set of IP addresses, and limit them to a rather small number.

You haven't told us what router you're now using, but there's some routers that don't appear to "play nice" with Sonos, there's a list around here somewhere, do a search for "supported devices" and you should find the FAQ. Which includes, in many cases, things to do in the settings of the router to allow the appropriate systems that Sonos uses to work properly.

At the end of the day, you may want to contact Sonos Support to discuss it.

I suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.
Thanks Bruce
It's a BT super hub 6, so I'll check it out. Talking to the FB messenger guys now. 👍
In the earliest days of the BT Hub6 there were problems with surrounds/sub when the system was in WiFi/'wireless' mode. The satellites weren't being assigned unique IP addresses.

This issue has long since been fixed. Is this a brand new Hub6?
It is a brand new hub.
Seems that one of the satellites wouldn't "forget" the old router, and a factory reset was in order.
After that the 2 rears are working fine😁

Reply