The Computer "..."Cannot be Found

  • 25 November 2011
  • 75 replies
  • 45537 views

Userlevel 2
Hello. I'm new to Sonos. Just bought a Bridge and Sonos 5 system. I'm using it with a Linksys router.
I am having problem importing music into my library from my computer. I keep getting the "computer cannot be found" message. I have turned off the firewall, so I know that's not the issue. Any suggestions would be appreciated. Thanks in advance.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

75 replies

I do hope you didn't wait for 4 years from the last post to sort this!

Nope it was the first Google result so thought I'd update it so someone else could find it if they had the same issue 😃
Userlevel 7
Badge +21
I do hope you didn't wait for 4 years from the last post to sort this!
I managed to solve my issue by enabling Netbios on my network adapter.

Same problem. Diagnostic number 3244015.

The Sonos will stop playing in the middle of a song.

These are user-to-user forums. Sonos staff may not spot your report.

To file a support request, complete an official ticket including your diagnostic number.
Userlevel 2
Same problem. Diagnostic number 3244015.

The Sonos will stop playing in the middle of a song.
Userlevel 2
I solved this by using the IP address instead of the name of the machine. There seems to be an issue with the name resolution over wireless but the IP address worked fine.
here is the diagnostics number:

Your confirmation number is: 3025987.

These are user-to-user forums. To ensure that Sonos register your support request I suggest you complete a ticket, together with a problem description and your diagnostic number.
Userlevel 2
here is the diagnostics number:

Your confirmation number is: 3025987.
You should be able to set the router up to either a) give an indefinite lease time to the IP..
Infinite leases are not recommended. Devices effectively 'steal' the IP and never give it up.
Userlevel 2
Now I' m only hoping that the router won't frequently assign a different IP address to the machine
You should be able to set the router up to either a) give an indefinite lease time to the IP or better b) associate a single IP address with the machine via the MAC address of the network card
Userlevel 1
I was having the same problem as the other people in this thread on a mac with OSX 10.6.8. I tried changing the computer name, the WINS network name, changing the wifi channel both for router and Sonos, tried to access the share via \\machinename\Music share, etc.etc. Nothing helped.

Then I thought using the IP address, and I tried to enter \\192.168.1.65\Music as a NAS shared folder, and this worked. Note also that even though my system is in Italian, and therefore the music folder is shown as "Musica" I had to use the english name (which is probably the real name of the system folder).

Overall, a pretty awful user experience, but at least I'm happy I had it working. Now I' m only hoping that the router won't frequently assign a different IP address to the machine.

I just thought I would report that here for other people to try the same workaround.
I've tried connecting the Sonos:5 player to the second port of the bridge as you suggest, but that didn't make a difference. Having said that, I couldn't seem to remove the room it was in before from the Desktop Controller, so I don't know if it's still trying to communicate wirelessly.
This is peculiar and suggests some network problems. Did you simply plug the P:5 into the Bridge, or did you add it again by pressing Mute/Vol+?

But, in my opinion, this seems to be unrelated to the problem, which is the Bridge being unable to see my computer.

There are two sorts of network communication between your computer and Sonos: from the Desktop Controller to the player(s), and from the player(s) to the shared folders containing your music. They are entirely independent of one another and I'm trying to see which exactly is failing. The picture I have thus far is that it's a bit of both.

1/ Is File and Printer Sharing ticked in the Windows Firewall exceptions list?

2/ Sonos doesn't get on terribly well with VPN software. If it's not in use try removing it entirely. Simply disabling it usually leaves the driver loaded.

3/ Give your network a full restart. Power everything off, start the router then work outwards. Wait for each device to boot fully before moving on to the next.

If this still brings no joy, submit a new diagnostic after another failure and file a support request quoting the confirmation number.
Userlevel 2
Internet Connection Sharing has no place here, so disable it.

A bit of background please: what firewall do you have, and are you using any kind of VPN software?

I take it that you've downloaded the installer for the Desktop Controller and have installed it afresh. Is the problem that you can't see the Play:5 in the controller, or are you having difficulty with adding a shared folder to the library containing your local music?

Eliminate the Sonos wireless temporarily by wiring your Play:5 to the Bridge's second port, and then please report back.


Hi ratty

I am using Windows firewall, and I have checked that Sonos is selected in the application exceptions list. I have also tried disabling Windows firewall altogether.

I do have VPN software installed, but I'm not currently running it.

My problem is that I cannot add any of my music folders to the music library, either on the local C: drive or on an external USB hard drive. In all cases, I get the error mentioned earlier in this thread, that my computer cannot be found. The folders seem to be shared correctly as fas as I can tell.

I've tried connecting the Sonos:5 player to the second port of the bridge as you suggest, but that didn't make a difference. Having said that, I couldn't seem to remove the room it was in before from the Desktop Controller, so I don't know if it's still trying to communicate wirelessly. But, in my opinion, this seems to be unrelated to the problem, which is the Bridge being unable to see my computer.

Kind regards
Angus
My PC is connected via WIFI so I wonder is that a factor?
It certainly could be, and in fact Sonos won't officially support a WiFi-connected music library owing to WiFi's variable streaming performance. Despite this many use such an arrangement successfully. Improve your chances by noting the recommendations about keeping WiFi and SonosNet apart in this earlier post.
Hi.
I have the same problem as the rest of you guys.
Have tried removing special characters from my computer name, turning off firewall, sharing the D:drive where my music is, moving a copy of my music to my c:drive and trying to Add the music from there... nothing worked.
My PC is connected via WIFI so I wonder is that a factor?
Please help!
Userlevel 2
Internet Connection Sharing has no place here, so disable it.

A bit of background please: what firewall do you have, and are you using any kind of VPN software?

I take it that you've downloaded the installer for the Desktop Controller and have installed it afresh. Is the problem that you can't see the Play:5 in the controller, or are you having difficulty with adding a shared folder to the library containing your local music?

Eliminate the Sonos wireless temporarily by wiring your Play:5 to the Bridge's second port, and then please report back.


Hi ratty

Thanks for your help. I will try again to resolve this issue when I return from holiday. (I tried to send you a private message to this effect but my Post Count didn't qualify me.)

Thanks anyway
Angus
Internet Connection Sharing has no place here, so disable it.

A bit of background please: what firewall do you have, and are you using any kind of VPN software?

I take it that you've downloaded the installer for the Desktop Controller and have installed it afresh. Is the problem that you can't see the Play:5 in the controller, or are you having difficulty with adding a shared folder to the library containing your local music?

Eliminate the Sonos wireless temporarily by wiring your Play:5 to the Bridge's second port, and then please report back.
Userlevel 2
Welcome to the forums.

Sonos doesn't appear in MS Network Places. Please describe your network for us. Include everything, and say how it connects (wired, wireless, etc).


Hi ratty, thanks for you reply.

I'm on Virgin Media cable which enters via the WiFi cable router they supplied. Both my PC and the Sonos ZoneBridge are plugged into the router with ethernet cables. A Sonos:5 speaker is attached as a wireless component.

Thanks
Angus
Welcome to the forums.

Sonos doesn't appear in MS Network Places. Please describe your network for us. Include everything, and say how it connects (wired, wireless, etc).
Userlevel 2
Hi

I'm getting the same problem as everyone else. I did submit a support request but got a reply asking me to phone a number in Germany, so I thought I'd try here.

My computer name only has alphanumerics, I've tried uninstalling and reinstalling the software, enabling Internet sharing, switching off the firewall, without success. In My Network Places I don't see the Sonos Bridge, though I'm not sure whether I should. I'm on Windows XP.

I submitted a diagnostic with confirmation number 2067714.

Any help gratefully appreciated.

Kind regards
Angus
A few users have stumbled over this type of issue. It's usually pretty obvious because the ISP has laid down the rule that "you shall only be able to attach X devices" (X being a very small number).

Fortunately you have an ISP which offers an option to allow the router to behave as a regular gateway router. Some don't, and in such circumstances one needs to add one's own router.
Userlevel 2
Finally solved my issues! Turned out that DHCP was TURNED OFF on my router! Its a ISP router(Stofa Denmark), so I had to do it from their corporate website from "my settings page" and then reboot all my systems including the router... Now all my units have a IP within the same range, before they were all actually given a public IP address! Weird - that was the default setting. Well anyway, after rebooting, it works now!

So my tip is, check the IP of your PC and compare it to the one on the sonos - if they are not something like 192.168.x.x. or 10.x.x.x and they are not given an IP from the router! They should. Hope it helps someone out there 🙂
Userlevel 2
I was having the stated "Computer Not Found" problem on Windows 7 and finally figured out how to fix it. Note that this has nothing to do with Firewall settings or rebooting all the devices. I tried all of that prior to figuring out the solution and it didn't work.

Here is my setup:

1) My PC is connected to a Verizon 4G wireless hotspot for Internet access. The hotspot acts as a mini router but does not have any ethernet ports (so I couldn't plug Sonos boxes into it).

2) I connected my PC's ethernet cable directly to the Sonos box. According to the docs (and past experience - I've had my Sonos system since 2004 or so). This direct connection used to work. It doesn't seem to work anymore though despite what the docs say.

What I discovered is that the PC connected directly to the Sonos box was obtaining an Auto-IP address as was the Sonos box. The PC could find the Sonos box but anytime I tried to add music to the library, the Sonos desktop controller would complain that my PC could not be found. My firewall was configured properly and the PC's name was correct despite what the error message said. I believe that this type of setup where the PC and the Sonos boxes are both obtaining Auto-IP addresses DOES NOT WORK! I think it used to but doesn't any more!

Here is how I fixed it:

I enabled Internet connection sharing on the local area network adapter on my PC. This assigned an IP address of 192.168.137.1 to my PC. Then, my Sonos boxes started being assigned IP addresses in the 192.168.137.xxx range.

Now everything works. My PC can see the Sonos boxes, my Sonos boxes can find my music libraries on my PC.

I hope this solved the issue for a lot of people...
Userlevel 2
Thanks, I will do so 🙂
kimschurmann,

Welcome to the forums.

Note that these are user forums and although Sonos staff do frequent them you'll be more assured of an official response if you file a support request quoting your diagnostic number.