Question

The all new BT Smart Hub (HH 6) - issues


Userlevel 1
Badge
I took delivery of the new BT Smart Hub today (ie the next one after the BT HH 5 - so effectively a HH6) - all good. I have separated the channels so that I have a 2.5ghz and a 5ghz network. I have followed the steps to put the Play 1 on the 2.5ghz network - but it keeps telling me to use 'use a 2.5ghz router' (or words to that effect) even though I am trying to connect to the 2.5ghz network.

I know this is new hardware - but if anyone else has managed to get this to work please let me know.

SONOS: can you get a BT Smart Hub for testing?

Regards

Steve

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

46 replies

Do you have different ssids and passwords for the two bands? Have you gone through the process to get the new Wi-Fi details into Sonos?
https://sonos.custhelp.com/app/answers/detail/a_id/3144/~/switching-sonos-to-a-new-wifi-network
I am assuming you're running in standard I.e. wireless mode
Userlevel 1
Badge
Do you have different ssids and passwords for the two bands?

Yes - 2 seperate networks, different names.

Have you gone through the process to get the new Wi-Fi details into Sonos?

Yes - works on the old hh5 router. Not on the new hh6


https://sonos.custhelp.com/app/answers/detail/a_id/3144/~/switching-sonos-to-a-new-wifi-network
I am assuming you're running in standard I.e. wireless mode


Yes I am
Userlevel 7
Badge +20
Do you have different ssids and passwords for the two bands?

Yes - 2 seperate networks, different names.

Have you gone through the process to get the new Wi-Fi details into Sonos?

Yes - works on the old hh5 router. Not on the new hh6


https://sonos.custhelp.com/app/answers/detail/a_id/3144/~/switching-sonos-to-a-new-wifi-network
I am assuming you're running in standard I.e. wireless mode


Yes I am


Hi Sharan,

Please check the encryption type for your new router and make sure that the 2.4 Ghz signal is using WEP, WPA, or WPA2. Other encryption types are not supported.

If that doesn't work, please temporarily wire a Sonos unit in to your new router so you can connect a controller, then send in a diagnostic report and reply with the confirmation number. Here's how to submit reports.
Userlevel 1
Badge
Yes, it's WPA2, smart setup turned off.

I'll wait and see when others start using the new HH6. Never be an early adopter!!
Userlevel 1
Badge
BTW -

I have one PLAY 1 directly connected.

the diagnostic number is 6356595.
Userlevel 7
Badge +20
BTW -

I have one PLAY 1 directly connected.

the diagnostic number is 6356595.


Hi Sharan,

The PLAY:1s are not successfully setting the wireless credentials. What is your wireless network's name? There are a few showing in range.
I installed a HH6 Type A a couple of weeks ago, split the bands, and named the 2.4GHz with the same SSID as I'd used before (I don't keep the default SSIDs). Everything connected to it without issue, including a small Sonos household which operates in WiFi mode. The Hub is in the default Wireless Mode 1, with WPA2 security. Smart Setup is off. WPS and UPnP control are also off. Band steering is off too, which may be relevant here.
Userlevel 1
Badge
Could be the band steering.., will let you know tomorrow. Thanks!
Userlevel 1
Badge
Band steering didn't help, but for me mode 2 did the trick. Thanks all.
Band steering didn't help, but for me mode 2 did the trick. Thanks all.
I would try reverting to Mode 1 after you've connected the Sonos. As I said, a couple of PLAY:1s connected to my HH6 happily in Mode 1. Mode 2 will compromise your 5GHz performance.
Userlevel 1
Badge
Ratty - I'm back to mode 1, all working happily!

Thanks

Steve
Userlevel 6
Badge +16
I installed a HH6 Type A a couple of weeks ago, split the bands, and named the 2.4GHz with the same SSID as I'd used before (I don't keep the default SSIDs). Everything connected to it without issue, including a small Sonos household which operates in WiFi mode. The Hub is in the default Wireless Mode 1, with WPA2 security. Smart Setup is off. WPS and UPnP control are also off. Band steering is off too, which may be relevant here.

OMG Ratty there should be a whole thread on here about the HH6, frankly and I'm very techie it was/is a nightmare to set up and had to turn off band steering etc to get anything to work, however my sonos setup went back on-line with ease (God bless you SonosNet).

As i'm typing that stupid advert for it is on TV, BT should change their trading name to BS. 😠
i set up the new smart hub 2 weeks ago and everything worked great but yesterday 2 rooms were missing
i switched off the connects and they are working again
this is the first problem in 3 years of owning sonos
i am using sonosnet and not wifi
should i set up static ip addresses for each of my units 2 connects and 3 play 1s
if so can someone tell me how to do this
many thanks
ian
should i set up static ip addresses for each of my units 2 connects and 3 play 1s
I'm not sure you really need to, since the Hub will generally hand out the same IP address each time that a device requests it.

I assume that when you installed the Hub you did a complete reboot of the network, i.e. ALL devices?

What Sonos device is wired to the router?
hi ratty
i have a bridge connected to the router
the 2 rooms that did not appear were both the connects,all play 1 were fine
yes did a complete shut down and all has been great until yesterday
as i say first time that i have had a problem
i have checked today and everything looks good
thanks
ian
Your BRIDGE power supply could be starting to fail. It's age-related and can cause intermittent connectivity issues.

If the problems recur, wire a PLAY:1 to the router temporarily and see whether everything then works as it should.

Alternatively, if you have access to a volt-meter you can test the BRIDGE supply (removed from the BRIDGE obviously). It should put out a steady 5.1-5.2V DC. If it's less, or fluctuating significantly, then the PSU is suspect.
I also just took delivery of the Home Hub 6. In order to make Sonos work I had to disable the 5 Ghz though otherwise when I tried to use Sonos with a wifi controller it said "You are on Network X, Sonos is not". Is this why you guys say to split 2.4GHz/5GHz up? If I have different SSIDs what happens if my iphone is on 5GHz will it not be able to use sonos (as it seems unable to if you combine the 2 as per default settings) - what is advantage of splitting into 2 SSIDs?
Splitting the SSIDs is advisable for some phones, which evidently get confused where both bands share the same SSID. On top of this the default band steering in the HH6/SmartHub can apparently try to shove Sonos off 2.4GHz onto 5GHz, which clearly won't allow it to connect.

User sharan found that it was also necessary to change to wireless Mode 2 temporarily for initial Sonos system setup.

Personally I always want to know which band/AP a device is attached to, so split the SSIDs anyway. A couple of PLAY:1s are on the HH6 2.4GHz SSID and I can confirm that a device attached to the 5GHz SSID was able to control them.
ok interesting. so if I re-enable 5Ghz then I can connect my phone to 5Ghz and it can still talk to Sonos... In theory.

I don't think my previous issue (when the SSIDs were combined) was a band steering kicking off issue as I am set up in Boost mode so presumably Sonos was in 5Ghz anyway - the only thing that wasn't is my Sonos controller (iphone)..

Also for the HH6 people are recommending turning off "Smart setup". Why is this suggested?

One last question (maybe?!) I am getting quite a lot of dropouts - tracks randomly stop playing and have to be restarted. The tracks are off my NAS which is wired into the HH6 so it cant be a wifi issue. Perhaps its a wifi interference issue but my HH6 is connected to channel 1 and my sonos to channel 11. Any ideas?
I don't think my previous issue (when the SSIDs were combined) was a band steering kicking off issue as I am set up in Boost mode so presumably Sonos was in 5Ghz anyway - the only thing that wasn't is my Sonos controller (iphone)..
Ah, I'd assumed you were attempting 'Standard Setup' (WiFi) mode, not using SonosNet. If you have a BOOST (or any other Sonos component) wired it shouldn't make any difference which band the phone's attached to. (FWIW Sonos only uses 5GHz for units bonded to the PLAYBAR, otherwise it's always 2.4GHz.)

Given your comment about dropouts, there are potentially other network issues which could account for the "You are on Network X, Sonos is not" message. Firstly ALL devices on your network would have required a reboot (or a forced disconnect/connect) following the HH6 installation. They all need fresh, unique IP addresses. Secondly your BOOST should ideally be placed at least 0.5m from the HH6.

Also for the HH6 people are recommending turning off "Smart setup". Why is this suggested?

"Smart setup" has been a feature of recent HHs, not just HH6. It puts up an annoying welcome screen when a new device connects for the first time. Turn it off.
Badge +3
I just got a HomeHub 6 and have a similar issue with my Sonos. Everything works except the Playbar which works after a reboot for about a day or so but then disappears.

Is there a proper solution for this ye? The Sonos support site still says the HH6 has an issue where it duplicates IPs and will hopefully be fixed with a firmware update but who knows when that might be.

Is a solution to give each Sonos device a static IP?
If you can reserve the IP addresses in the router then that may help but if you've replaced your router you'd be strongly advised to reboot EVERY device connected to the network, Sonos and non-Sonos, otherwise you're quite likely to have duplicates regardless of the router.
I'm not sure reserving IPs will help. By default the HH6 assigns the same address to a device as it used before, quite possibly because it hashes the MAC address to calculate the IP,

As I understand things the problem is that the HH6 mistakes the IP requests from the PLAYBAR's satellites (SUB, surrounds) as coming from the PLAYBAR itself, thereby handing out duplicates. AFAIK no-one has publicly stated whether this affects systems in SonosNet ('BOOST Setup') mode as well as WiFi mode.
Badge +3
I've disabled the 5Ghz network and everything seems to be behaving.
I've disabled the 5Ghz network and everything seems to be behaving.
There have been suggestions that leaving the HH6 5GHz named the same as 2.4GHz and keeping band steering enabled could upset Sonos units trying to connect in WiFi mode (Standard Setup).