Terrible Connection Issues


I have 5 Sonos products, mainly the original but of late I included a Roam.  The sound quality is add I’d expect but I have reached my limit with the poor connectivity.  I use the speakers/ app in two locations and every time I try to connect to the Wi-Fi I spend up to 20 minutes trying, and often failing to connect.  I use the songs roam on Bluetooth as connectivity to Wi-Fi is so erratic and takes too long.  I have contacted support, performed resets and still I have consistent problems connecting.  I have a £20 radio I can switch on and listen to immediately- how have Sonos tricked us all into this - I understand the desire to sell new products, but to let older products down so badly is inexcusable- I certainly will never buy another Sonos product.  Anyone else at the same stage?


10 replies

Nope, all works fine here at various locations and when travelling too. Our children have Sonos in their family Homes aswell and not seen any issues, even when switching between networks, which is instant as I move between locations. I would maybe take a closer look at your chosen network(s) and their setup and the recommendations from the various threads here, including the available support documents but all depending on how you have setup the Sonos ‘Households’ and your controller devices.

Note if you’re using the old S1 App that it does not support the Roam, but the Roam will happily switch between networks (up-to 16 different ones) if you add the SSID credentials to it.

Ken, thanks for taking time to respond.  I’m glad you’ve had good experience, I will have another go but have repeatedly reset my system under the guidance of Sonos support and hence lost confidence- I’ll try once again given your comments.  I do use the S2 app for the Roam but still have a low success rate on wifi.  Thank you.

@Ifellforsonus,
Well if I can ever help in any way with any questions you may have about the Roam or it’s setup, then perhaps just post back here and I will happily try my level-best to try to assist.👍

@Ifellforsonus,
As a starter, I would certainly put the Roam on the more penetrating/longer reaching 2.4Ghz band. Set the band channel-width to 20Mhz only and use a non-overlapping channel (channel 1, 6 or 11) - keep the channel ‘fixed’. Remove any other WiFi credentials from the Sonos App if those other network(s) are nearby.

If using a SonosNet wired connection for your other non-portable Sonos products, put that signal on a completely different channel to the chosen router WiFi channel and keep the wired Sonos device one metre away from your router. 

That’s at least a few of the basics to (hopefully🤞) help to improve network connectivity to your Sonos devices. 

@Ifellforsonus,

When switching locations and networks with your Sonos devices, for ease of use you may find it easier to first create a Sonos ‘Household’ (System) present on the network (just the once only) in order to add your Sonos products (like the Roam etc.) to it.

You should see the local network credentials added to your Sonos App network settings for use with your Household and added products .. See the example screenshot attached of a Sonos App that uses multiple WiFi networks…

You can then often easily and quickly switch between the created Sonos Households/WiFi Networks and access the speakers setup on the HH by just simply connecting the mobile controller device to the WiFi network and opening the App… the App will auto-switch to the local HH and so the Roam you added to it will then be available for use. You only need to set it up once only at the different locations.

There are a number of ways to go about doing these things easily too with just one Sonos Household (to take with you and carry between locations), without resetting any Sonos devices and you may find these three steps below useful if you ever need to use a Sonos Roam quickly at multiple locations… 

Three quick steps...

  1. Whilst still at your Home ‘A’, simply add a mobile Hotspot (WiFi = iPhone-Hotspot) to the Sonos setup via ‘Update Networks’ in the Sonos App Network settings.
  2. Then transport Sonos Move/Roam etc; to Home ‘B’. When there, first connect the Sonos controller device (an iPad for example) and the Move/Roam speakers to your mobile Hotspot (WiFi = iPhone-Hotspot)
  3. Next add the (now in range) Home ‘B’ WiFi to the setup via ‘Update Networks’ in the Sonos Controller App and all will then work on the new WiFi. (Post transfer, switch off mobile hotspot and connect mobile controller (iPad) to the Home ‘B’ WiFi).

Thanks Ken, but I need to go a little slower I’m afraid.  I reconnected my Roam to the S2 app on the house Wi-Fi after a few failed attempts then I accessed my router and verified I’m on the 2.4 GHz band.  I changed the channel from auto to 1 but couldn’t see anywhere to adjust the bandwidth to 20 MHz as you suggest.  Strangely my phone/ S2 app can no longer find my Roam!

 

I have two other wireless Sonos products in the house (Play 1 and Connect Amp) - I’m afraid I don’t understand how to perform your advice “If using a SonosNet wired connection for your other non-portable Sonos products, put that signal on a completely different channel to the chosen router WiFi channel and keep the wired Sonos device one metre away from your router.”  Can you please confirm how to do this.

 

I get the mist of creating a household network but your diagram shows your phone? I was assuming you’d have called it “Household”.  Are you just creating an access point for each location to ensure the Sonos products are pointed only at that network when I the vicinity and if so how do you do that.

 

Apologies, my IT skills are basic, I hope you don’t mind the daft questions and I very much appreciate your help.

 

allister

Thanks Ken, but I need to go a little slower I’m afraid.  I reconnected my Roam to the S2 app on the house Wi-Fi after a few failed attempts then I accessed my router and verified I’m on the 2.4 GHz band.  I changed the channel from auto to 1 but couldn’t see anywhere to adjust the bandwidth to 20 MHz as you suggest.  Strangely my phone/ S2 app can no longer find my Roam!

Ensure your phone is connected to the same WiFi as the Roam and close/open the S2 App see if that fixes it - ensure your 2.4ghz WiFi  and any 5Ghz WiFi bands are not ‘isolated’ from your wired LAN too in the router settings.

If the router has ‘Airtime Fairness’ or ‘QoS’ enabled, then switch those features off.

 

I have two other wireless Sonos products in the house (Play 1 and Connect Amp) - I’m afraid I don’t understand how to perform your advice “If using a SonosNet wired connection for your other non-portable Sonos products, put that signal on a completely different channel to the chosen router WiFi channel and keep the wired Sonos device one metre away from your router.”  Can you please confirm how to do this.

You only need do this if the Amp, Play:1 or other Sonos devices are wired to the router/LAN - if not, then ignore this - Anyhow to change the SonosNet channel, you would simply goto the Sonos App ‘Settings/System/Network’ and set the SonosNet channel there so that it’s completely different to your chosen router WiFi channel - note if no devices are wired the option will be inactive in the App.

 

I get the mist of creating a household network but your diagram shows your phone? I was assuming you’d have called it “Household”.  Are you just creating an access point for each location to ensure the Sonos products are pointed only at that network when I the vicinity and if so how do you do that.

 

Apologies, my IT skills are basic, I hope you don’t mind the daft questions and I very much appreciate your help.

 

allister

One mobile device is used for the Sonos controller and installation of the App and another can be used as a temporary WiFi hotspot network (think of it like a mobile router with an internet connection) and your Roam can be moved in its HH (or the system you created to hold the Roam) to/between the different locations - The three steps outlined at the end of my earlier post, saves you having to factory reset the Roam in order to set it up/use it at the different locations.

Note: you can of course ‘reset’ the Roam if you prefer, when changing locations and create a new Household for it, but doing that means you also then have to add your services back to it and any playlists etc. but if you carry the HH with you, then everything retains its settings.

Hope that assists.👍

Ken, many thanks again for taking the time to explain things.  I’m afraid I’m not making much progress.  My latest issues are:

  • I connected the roam to WiFi - it plays some music but not any of my stored radio stations 
  • none of my other products are hard wired to the LAN hence, as I understand your steps are not applicable- which leaves me unable to connect.
  • I couldn’t see Airtime Fairness or QoS anywhere in the router controller.

I don’t wish to trouble you further so I will try calling product support.  My son has a computer science degree but is away from home these days - I didn’t think I’d need one when I bought my Sonos products.  Apologies, I don’t mean to appear ungrateful for your assistance however, I maintain it shouldn’t be this difficult to configure.

@Ifellforsonus .. here is the contact details for Sonos Support…

https://support.sonos.com/s/contact

Also it may help the Staff if you submit a Sonos Diagnostic Report and give them it’s reference number so they can perhaps see where the issues are with your setup. See this link:

https://support.sonos.com/s/article/141

Hope you get things sorted.👍

Thanks Ken

Reply