Tenda MW3 AC 1200 Mesh network issue

  • 15 August 2018
  • 7 replies
  • 3565 views

I have multiple Sonos and am trying to use a Tenda MW3 AC1200 mesh network, when I turn off my normal 2.4 WiFi and try and connect the Sonos to the new mesh network it cant find it? any ideas?

7 replies

Sonos needs to run on 2.4ghz WiFi ... switch your Sonos system over to Boost Mode would be the easiest way to solve your issues.

Read this ...

Choosing between a Standard and BOOST Setup

Can I also suggest you perhaps read this post too...

Simple Fixes for Network Connection Issues
If the Tenda MW3 has a bridge/AP mode then use it.

If it doesn't you'll be stuck with it as a router (in addition to the main one). This means that everything must connect to the Tenda units -- either by wire or wireless. The only device which should connect to the main router is the primary Tenda unit itself.
From what I have read online, there are 2 Ethernet ports per Tenda mesh node, WAN and LAN on the primary mesh node.
However both will act simply as LAN ports on any additional mesh nodes. Admittedly, I really do like that idea.

i would personally just plug one Sonos device into ANY available LAN, best place is maybe central to the house/Sonos system and stick with 'Boost Mode'. Make sure the Tenda 2,4ghz wireless channel is made static (or fixed) and is set well away from the SonosNet wireless channel in Advanced Settings of the Sonos App.

It is also best to remove any stored WiFi credentials from 'Advanced Settings/Wireless Setup' in the Sonos App, after the switchover is complete, as these credentials will no longer be required.
I ran into the same problem yesterday, but by following the instrcutions in the sonos app, the problem solved.

My Tenda mw3 is using HDCP connection methods (As bridge mode will lose some of the funtions). (mw3 wan cable to the router lan cable ), for some reason sonos won't find the network, so I followed the instruction, connect using a wired ethernet methods temporality, then the app find the sonos beam successfully, then I can unplug the ethernet cable and use it wirelessly. Hope this helps.
Userlevel 5
Badge +9
Yes - works fine with boost

But, there's no way to select wifi channels on the Tenda - you're stuck with 1 or 6.

Just installed 3 Tenda MW3 units and very impressed with them but had problems with my Sonos system. I had not realised that the Tenda primary unit acts as a router by default so I had 2 routers on my LAN and Sonos only wanted to talk to my original FTTP router. Changed the MW3 primary to Bridge mode, problem solved!

I believe that the majority of these meshed WiFi systems contain their own router by default. This is how they provide the value-add features such as Parental Control and so forth.

Unfortunately a lot of purchasers don’t realise this, as normal internet access works whether or not the secondary router is enabled. It’s when a user attempts to use an application which communicates between devices locally, as Sonos does intensively, that the secondary router can spoil the party. It’s only doing its job, as a firewall. The blame of course is often heaped on Sonos.

The solutions are pretty simple:​​​​​ either change the mesh primary to bridge/AP mode (if it supports it), or ensure that Sonos components all connect to the LAN side of the meshed system.

Reply