symfonisk doesnt connect to wifi.

  • 3 April 2021
  • 6 replies
  • 39 views

Let me start by saying I love the sound of this speaker. I hate the connecting, Wi-Fi settings, support and the app. 
basically the main things that should work DONT. I know support will contact me treating me badly as they have due to my bad reviews but I haven’t been able to use the speaker for weeks. Just won’t connect to Wi-Fi. Had Vodafone at my house and nothing worked. Yes I know it only works with 2.5Gzh but it just won’t connect. Change router. Reset settings. Nothing works. Manage to reconnect all devices except this one. Somos is great when it works. But when it doesn’t I just want to break this thing. Not worth the hassle or money   Note that I’ve manage to connect in the past but it has always been very difficult to connect and no one in support has ever helped. 


6 replies

Let me start by saying I love the sound of this speaker. I hate the connecting, Wi-Fi settings, support and the app. 
basically the main things that should work DONT. I know support will contact me treating me badly as they have due to my bad reviews but I haven’t been able to use the speaker for weeks. Just won’t connect to Wi-Fi. Had Vodafone at my house and nothing worked. Yes I know it only works with 2.5Gzh but it just won’t connect. Change router. Reset settings. Nothing works. Manage to reconnect all devices except this one. Somos is great when it works. But when it doesn’t I just want to break this thing. Not worth the hassle or money   Note that I’ve manage to connect in the past but it has always been very difficult to connect and no one in support has ever helped. 

Set the 2.4Ghz WiFi band to a fixed non-overlapping channel of 1, 6 or 11 and use a channel width of 20MHz and see if that resolves the issue. If not bring the speaker closer to the router to see if it’s WiFi adapter is working. You can re-add the WiFi credentials to the device too by going to "Settings/System/Network” and select ‘Manage Networks’ and follow the instructions to re-add the credentials to the device.

Unfortunately it didn't work. I find its horrible I need to be some IT Tech support to setup a speaker.

I can't understand this product and why its difficult to setup but I have the speaker just siting there not working.

I wish it would just work without me having to login to the router, no other device requires this type of technical knowledge. If there is anything I can do beside through the speaker at the wall Ill appreciate it.

Channel is at 11, 20MHZ. But when it gets to the part to connect to SONOS it stops. Wont connect.

I reset, unplugged it and I confirmed other devices are working on the wifi.HELP

Userlevel 4
Badge +6

Have you tried temporarily moving the troublesome speaker close to (a couple of metres away from) the wifi transmitter in your network, just to confirm that the problem is not caused by difficult reception conditions?

I’ve got a pair of Symfonisk speakers and I didn’t have any problem at all with the setup process, so it may be that conditions where you are happen to be a bit unusual.

Congrats. You have a product that works. My sonos and router are 1 foot apart. Is that too far for this product? 
ive connected it before always with very much difficultly. It’s never been easy to connect but I’ve managed. This time nothing. I try to do via cable and even then it’s not working. I hate this product. Never again. 
All I want is tonconnect the speaker and listen to music 

Userlevel 4
Badge +6

If you’ve done a factory reset of the Symfonisk and gone through the procedure to add it again and that fails then I would think it’s faulty.

If it were mine, I would return it to Ikea as such. The current situation with store closures may delay the returns process, but that’s likely to be over soon, and Ikea is a reasonable company to deal with in my experience.

Userlevel 5
Badge +15

Hi @mindurbusiness 

Welcome to the Sonos Community!

1 foot is actually much too close for WiFi to work - all WiFi devices (not just Sonos) need about 3 feet of space from others, especially routers.

Please move your speaker further away from the router.

As your speaker lives close to your router, you could connect it with an ethernet cable. This will make it and your other speakers bypass your WiFi and use their own, which should give you better results - you shouldn’t need to do this, but it is likely the easiest path for you to take. Please still keep the space between the router and the speaker when wired, however.

 

Reply