Switching speakers to a new Boost network


Badge
I have five different Sonos speakers connected to my home WiFi network. I recently set up a new mesh WiFi network and connected a Boost to this new network (ethernet-wired). How do I switch the 5 speakers over to this new network?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

72 replies

The first thing you should do is go in to the wifi settings of the controller app, and remove the old wifi settings that you'd entered. I've never needed to do it myself, so I'm not sure how it would show up, but I'd bet there's a button in there for deleting the current wifi information.

That's actually about it. It usually takes anywhere up to around 5 minutes for the speakers to recognize that they're on a "BOOST" setup, which by the time you read this, will probably have happened.

By removing the wifi credentials, you'll remove the possibility of them "bouncing" back and forth between the two contact methods.
Badge
Where exactly in the app do I do this?
Badge
I can't find any setting that let's me remove wifi credentials. Quite unbelievable how complicated Sonos is.
The same place that you entered them originally.

As I said, I'm always run a BOOST network, so I've never entered them. If I were to guess it's probably in Settings>Advanced Settings>Wireless Setup. But since I don't have anything in there, I am not sure what shows up when you do.
Badge
There is no place in the app to do anything with wifi credentials. The 5 players are connected to one wifi network. The Boost is connected to a second wifi network. The Sonos app can only see any one of them at a time based on which network my phone is connected to. When I connect to the network with Boost, the app doesn't even let me get past the opening screen, displaying a message that "I need to set up at least one speaker" to continue. When I connect to the network with the 5 speakers and try to run Wireless Setup, it asks me to first connect a speaker to my router. However, that is impossible since this mesh WiFi router only comes with two ethernet ports. My Boost is connected to one of them and the other is connected to my ISP's router.
Badge
The mesh wifi router is Google WiFi.
Ah, I see. You've got 2 networks, essentially. What you need to do is remove the connection of Sonos to one of them. Let the Sonos run on the SonosNet, using the BOOST.

My recommendation would be to connect your phone to the "other" network so that it can see those 5 players. If you have them wired with an ethernet cable to one of the pucks that the google wifi has, disconnect those ethernet cables. If they're on the wifi of that puck, go in to the app as previously suggested and remove the wifi credentials.

Then connect your phone to the main google puck, where you should have the BOOST device connected with an ethernet cable. Within about 5 minutes, the Sonos system should pick up the 5 players that you removed from the other network, and you'll be good to go.
Badge
Unfortunately, the sticking point here is "remove the wifi credentials". When I connect to the old network (where the 5 speakers are connected), the app has no way to change or remove wifi credentials.
I just bought sonos boost today and added it to my system. In about 15 minutes, changed my standard system to boost system. My router is also google wifi mesh.

To remove wifi credentials follow this:

From the More menu, tap Settings > Advanced Settings > Wireless Setup. On the Wireless Setup screen, click the button that says "Reset". Then click "Done" on the next screen.

That’s it and enjoy!
Badge
I see no such button called 'Reset'.
hide the keyboard, you will see reset in the bottom page or just tap done i think, anyway its on the bottom after getting rid of the keybotd
Badge
Here's a screenshot. There is no Reset button
gopals,

Have you added the boost into your original Sonos network? Does it and all your other Sonos speakers appear in the list in 'Settings/About My Sonos System'

Next to each speaker entry in the list, you should see this near the bottom of each and every device:
WM: 0
This means the speaker is running on SonosNet.

Can you check that your devices are showing and have switched to SonosNet. If they are running on your routers WiFi they will have WM: 1 next to them and that infers the boost is not yet setup on your Sonos Network.

Hope that helps.
@gopals

Sonos is actually pretty simple, but the Google WiFi has complicated things.

You've accidentally created two Sonos systems (households). Your Google WiFi contains its own router, which breaks your home network into two subnets. Wiring the BOOST there left it unable to see the original 5 speakers.

Attach your phone to the Google WiFi. I suggest you 'forget' the ISP router WiFi since henceforth you should connect nothing to that router other than the primary Google unit. (Better still, disable the existing router's WiFi if possible.)

Power the BOOST off, unwire it from its Google unit and set it aside.

Wire one of the 5 speakers to the Google WiFi unit, and wait 2-3 mins. Check in your controller that you can see all 5 speakers. If any are missing, power them off, wait 15 secs and power them on again.

Leave the BOOST unwired and power it up in factory reset. When the light flashes green, add it using your controller. For now say you'll use it 'elsewhere' (not wired).

Once the BOOST has been added, unwire the speaker from the Google unit and wire the BOOST instead. Make sure all the devices appear, and show WM:0 in Settings/About My Sonos System.

Lastly, go to Advanced Settings/Wireless Setup and remove/reset the old WiFi credentials.
Badge
gopals,

Have you added the boost into your original Sonos network? Does it and all your other Sonos speakers appear in the list in 'Settings/About My Sonos System'

Next to each speaker entry in the list, you should see this near the bottom of each and every device:
WM: 0
This means the speaker is running on SonosNet.

Can you check that your devices are showing and have switched to SonosNet. If they are running on your routers WiFi they will have WM: 1 next to them and that infers the boost is not yet setup on your Sonos Network.

Hope that helps.


No, my Boost is on a new wifi network that I have just set up. I am looking to move the rest of the Sonos speakers over to this new network.
Follow the instructions above.
Badge
First, thanks everyone for patiently responding.

@gopals

Sonos is actually pretty simple, but the Google WiFi has complicated things.

You've accidentally created two Sonos systems (households). Your Google WiFi contains its own router, which breaks your home network into two subnets. Wiring the BOOST there left it unable to see the original 5 speakers.


Actually, it wasn't accidental. I deliberately created a second wifi network. And I am aware that the Boost and the Speakers are on different networks and that's what I am trying to solve. At the end of the day, this is just a question of how to switch Sonos speakers from one wifi network to another. The detail about one router being a Google product shouldn't matter.

@gopals

Attach your phone to the Google WiFi. I suggest you 'forget' the ISP router WiFi since henceforth you should connect nothing to that router other than the primary Google unit. (Better still, disable the existing router's WiFi if possible.)

Power the BOOST off, unwire it from its Google unit and set it aside.

Wire one of the 5 speakers to the Google WiFi unit, and wait 2-3 mins. Check in your controller that you can see all 5 speakers. If any are missing, power them off, wait 15 secs and power them on again.


This did not work 😞 Took one of the Play 5s and connected it directly (hard-wired with ethernet cable) to the Google puck. Removed the Boost prior to that. However the Sonos app / controller wasn't able to find the Play 5.
Yes, it is exactly as Ratty says... follow his instructions above.
Actually, it wasn't accidental. I deliberately created a second wifi network.
I wasn't talking about WiFi networks. You've accidentally created two Sonos systems, otherwise the speakers would be connecting to the BOOST.

This did not work 😞 Took one of the Play 5s and connected it directly (hard-wired with ethernet cable) to the Google puck. Removed the Boost prior to that. However the Sonos app / controller wasn't able to find the Play 5.
Power-cycle the PLAY:5. Ensure your controller is also on the same subnet, i.e. the Google WiFi. If it still won't find the speaker, reset the controller and when it restarts tell it to 'connect to an existing system'.
Here are the instructions from Ratty. I have tried to break them down step by step for you ..

Step 1
Switch off your Boost and unplug it.
Step 2
Switch off your ISP router WiFi (or I have seen some others here choose to put it into 'modem mode')
Step 3
Attach one of your previously setup and working Sonos devices (not the boost) to your new Google WiFi hub and wait until its back up and running...give the speaker a minute or so to settle. Close and reopen the Sonos app to see it appear. (Speakers are now running on SonosNet).
Step 4
Switch off/on the other remaining speakers one at a time... giving them a minute or two to each appear in your Sonos controller... you may need to close and reopen the app to refresh the screen.
Step 5
Hard reset and then add the boost to your existing network from within your Sonos App as an unwired device...do not plug it in to your Google WiFi hub or router at this stage.

Here are the instructions for a hard reset of your device ...

Factory Resetting a Sonos Product
CLICK HERE for reset procedure.

Step 6
Unplug the speaker from your Google WiFi hub and swap it for the Boost.

Everything is now setup exactly as it should be, but if things are not still sorted after five minutes or so for any reason, just switch everything off and back on again in this order.

Router
Google WiFi hubs
Boost cabled to your hub
Sonos speakers (one at a time)

Step 7
Then as Ratty says when all is confirmed as being up and running, then remove/reset your WiFi credentials from 'Settings/Advanced Settings/Wireless Setup' in your Sonos App as they are not required when running things on SonosNet.

In your last attempt it sounds like you left your old router WiFi turned on... switch the router to modem mode is perhaps the easiest thing to do here, as mentioned in step 2 above.
Step 2
Switch your old ISP router into 'modem mode'... this is IMPORTANT and often easily done with most ISP routers these days.

Unnecessary. Either disable, or ignore, the ISP router's WiFi. The Google mesh can run in double-NAT.
Will Step 2
Switch your old ISP router into 'modem mode'... this is IMPORTANT and often easily done with most ISP routers these days.

Unnecessary. Either disable, or ignore, the ISP router's WiFi. The Google mesh can run in double-NAT.

Ratty
Will the user then not have two DHCP servers running on his local network ..the google hub DHCP server and the routers own DHCP setver or do I have that wrong?
Will the user then not have two DHCP servers running on his local network ..the google hub DHCP server and the routers own DHCP setver or do I have that wrong?
The primary Google puck contains a router. There are two subnets, one cascaded off the other. One DHCP server per subnet.
Ratty,

Okay, one other thing, assuming I was to change my 'Step 2' text above, to simply read 'disable the original routers wifi' as you appear to be suggesting. I am now seeing one other further issue.

I currently cannot see how the remaining uncabled Sonos speakers can now rejoin the existing Sonos network setup by the one speaker cabled to the google WiFi hub, as they were all originally attached to the ISP routers WiFi network only (I think) ... they will only rejoin the Sonos Network if they had originally been run on SonosNet with one device originally cabled to his ISP router... it is not clear in his posts, but I don’t think the user was ever running his devices previously on SonosNet.

So will he either need to...

(A) hard reset the remaining speakers? ... that’s normally not the thing to do, I presume.... OR
(B) Use his original routers WiFi from the start (prior to step 1 above) to firstly switch his existing original Sonos network over to the new google hub and the hubs WiFi network?

I hope that all makes sense. I’m truly sorry for poking my nose in here by the way, but I was just trying to help 'gopals', so please forgive me for perhaps complicating the matter slightly... I was originally trying to simplify things, but appreciate I may have now added to his confusion.
I currently cannot see how the remaining uncabled Sonos speakers can now rejoin the existing Sonos network setup by the one speaker cabled to the google WiFi hub
They'll mesh together automatically. They all share the same household ID. If they need any encouragement they can be power-cycled. If any particular unit is especially stubborn it can be reset and re-added.