Question

Sub dropping connection to SonosNET, refuses to use nearby Arc for connectivity

  • 20 February 2021
  • 9 replies
  • 63 views

  • Contributor I
  • 4 replies

Hello All,

 

I am having a problem keeping a sub on my network connected. In my sonos system, I have a utility closet with several amps in it. The amps power ceiling speakers around the house. I also have a TV room with an Arc in it. Next to the TV room is my den where I have ceiling speakers powered by one of the amps. All the amps and the arc are hard-wired to the ethernet. I have a sub, in the den, that I would like to pair to the Den’s amp. The sub I would like to use the wireless network.

 

When I add the sub to the system and leave it unpaired, it connects to the Arc for SonosNET connectivity. I can verify this through the connection matrix (support/review). The connection is green and appears to be healthy. If I “add / pair” the sub to the Den's ceiling speakers, then it insists on connecting to the Den’s amp for SonosNET connectivity and the signal is very weak and drops frequently.

 

Is there a way I can force the sub to use the nearby arc? I bought a boost and tried adding that to my system as well, but the sub still insists on using the Den’s amp for connectivity.


9 replies

Userlevel 6
Badge +17

Does the Sonos app not allow you to add the Sub to the Arc?

It does -- but then it would be paired to the arc for music playback, and I want to listen to music in the den without having to turn it on for the arc. The reason for this is to reduce the amount of noise I am making when listening at night when the kids are asleep, etc.

Userlevel 6
Badge +17

What happens if you unplug the ethernet cable from the Amp that controls the speakers in the den and then try to add the Sub? Have you tried changing the SonosNet channel in the Sonos app? 

Fiddling with the 2.4GHz SonosNet channel misses the point. The Sub that is bonded with the Den Amp can only communicate with it wirelessly via a direct 5GHz connection. The Amp is evidently too far away. 

The options are to wire the Sub to the network infrastructure or bring the Amp closer to the Sub.

Correct, the issue is not SonosNET, it’s that the amp *MUST* communicate directly to the Sub instead of using the other devices in SonosNET :\

 

 

Moving the amp closer is not really an option since the ceiling speaker wires are in the ceiling and the best nearby location to hide the amp would require cutting quite a few holes (the joists run in the opposite direction).

 

Thanks for all the information, it sounds like my options are, somehow get ethernet to the Sub, move the sub to where there is Ethernet, or just not use a sub with my ceiling speakers.

A number of users with a centrally located closet have run into this issue. A direct connection (or a wired path) to the satellites is required to maintain the lowest possible latency for home theatre purposes. 

If the Amp is only being used for music (no TV connection) ironically the older Connect:Amp (gen2) might have been better, since it talks to its bonded Sub via the 2.4GHz SonosNet.

Yes this amp is being used purely for music :\

 

I just wish there were an option to avoid the direct connection and use either SonosNet or my wireless network. I think both would work (my wireless network is very good with multiple APs).

Trying to connect through your WiFi network wouldn’t work. The latency would be too high, and variable. The Sub would drop out.

The Sonos HT products require a very tight coupling to their satellites, so buffers can be run shallow, delay minimised and lip-sync maintained. This is why there’s a dedicated point-to-point 5GHz connection.

You could try sourcing a Connect:Amp and using that instead of the Amp for the Den. Make sure it’s a Gen 2 (post 2015) model so it can run S2 software.

Reply