Stuck on "let's get started..." on N2 android

  • 24 November 2019
  • 5 replies

  • Contributor I
  • 0 replies



I have a Odroid N2 board running Android 9.

When I try to run the Sonos app on it the app get stuck on the “Let’s get starting”

this window constantly scrolls to the left, stay for 1sec and then scrolls again.

It does not stop even after a very long wait.

I have location permission set


Any idea how to fix this?

5 replies

+1 to solve this - my android oppo phone is stuck on “Let’s get started...”  cycling every 2 seconds.

I am totally underwhelmed - my new Beam is useless at the moment.


Are Sonos awake to help?

...and I have just called the Australian help desk, as the NZ number on the quick start guide points to a local support that no longer imports Sonos! This just gets better and better.

Maybe I send this lump back and get something that works?

Userlevel 3
Badge +3

Shot in the dark suggestion: while the Sonos app is running.and doing the let's get started thing, turn your WiFi off, then back on again. 

I have 4 identical android devices.   One works well with Sonos, the other three get locked in this same interface (lets get started).


10.5 version of the APK

Same network. 


Help please. 

Same problem.


Tried the “turn wifi off and on while stuck” as described above, it worked. 


Thanks RUBIX2