Special characters in Imported M3U Playlist


Userlevel 2
Hi, I'm new to Sonos and have found it brilliant so far, so easy to set up and use.

Just one issue I've found which hopefully someone can help with.

I created an m3u playlist and saved it in my music folder, and Sonos indexed it an picked it up fine, all except for one track.

For this track it just shows the filename and cannot play it.

The only difference for this track to all the others in the list is that there is a cedilla C in the folder name, so I wonder if this is causing the problem?

The path of the offending file is:
R:\Music\JD Music\Music\Poliça\Give You The Ghost\04 Dark Star.m4a

as you can see "Poliça" is what I think might be the problem.

The same track is indexed fine in the Music Library and plays no problem.

Is there anything I can do in my playlist creation to work around this?

Many Thanks.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

18 replies

Userlevel 2
No-one any ideas on this?

I created a new playlist containing the rest of the Poliça album along with a Tiësto album.

None of these tracks show up properly in the playlist, just the filename is displayed and the track will not play.

Again, all these tracks are in the proper location and play perfectly well from the main music library, its just in the imported playlist that they don't work.

I think with my new playlist I've proved to myself that Sonos cannot handle special characters in imported playlists. So I assume the only way around this is to not have them in the names.

But surely others have encountered this? I'd just like reassuring that I'm not doing something wrong!

By the way, if I've posted this in the wrong place, please feel free to move it.

Thanks.
JDu,

Which program have you used to build your external playlist?

If you are using the PC desktop controller, go to Help --> Error Log... and copy and paste the error message for us to view. Is the 'ç' visible here?

Since the m3u is simply a text file, you could look up the problem track using a text editor and check the path and file name for the problem track.

The cedilla C could be the issue. Either the playlist building program or the hard drive operating system might balk at the 'ç'. I have encountered a few cases with odd characters where Windows can create the file name, but cannot otherwise access the file. You could research this by attempting to change the folder name to eliminate the 'ç'. Note that you'll need to update the SONOS library index if you change the file name or path.

Note that changing the folder name will not change the normal SONOS library views. The indexer works with tags, not file names. In the Folders library view, you will be able to see the actual folder and file names. Can you find the problem files in Folders view?
I think the file system might have something to do with it.

Where I have M3U files pointing at tracks containing extended char set characters which live on a WD NAS, the tracks play fine and art (folder.jpg) displays too.

If tracks containing such characters are placed on a USB flash drive attached to a router, the tracks play but the artwork is missing.
Userlevel 2
Hi, thanks for the replies.

buzz,

I used MusicBee to create the playlists.

The error log is interesting:
Tuesday, August 7, 2012 - 7:17 PM Greenwich Mean Time : Dublin, London
Unable to play 04 Dark Star.m4a - the file //NAS-53-CA-1C/media/04 Dark Star.m4a cannot be found.

Tuesday, August 7, 2012 - 7:20 PM Greenwich Mean Time : Dublin, London
Unable to play 01 Heroes.m4a - the file //NAS-53-CA-1C/media/01 Heroes.m4a cannot be found.


This shows attempts to play one Poliça and one Tiësto track. It appears to be completely ignoring the folder structure in the playlist and so looking in the wrong place. I.e. directly in the "media" folder rather than "media/artist/album".

As you suggested I changed the names of the folders to remove the special characters, updated the playlists and re-indexed the library.
All the tracks now appeared properly in the list, the 'ç' and 'ë' in the tag were displayed, so it is down to the appearance of these characters in the folder name only.

I can navigate to the offending tracks in Folder view and they are displayed and can be played properly, even with the special characters in the folder name.

Do you think it could be down to how MusicBee exports the list? I will try a different playlist creator and see.

Ratty
My NAS is a ReadyNas Duo v1 which is formatted NTFS. Is this what you mean? Could this have any effect?


Thanks.
JDu,

If the tracks are OK in Folders view, then MusicBee is having trouble with the special characters.

Open the the exported playlist with a text editor and search for one of the problem tracks. I think that you'll be able to observe the problem in the playlist. It is probably not worth the trouble, but you could repair the problem here.
My NAS is a ReadyNas Duo v1 which is formatted NTFS. Is this what you mean?
I was guessing that disk format might have been a factor in the behaviour which I reported earlier. The WD My Book World HDD is evidently formatted with xfs or ext3. The USB stick I mentioned is FAT32. Alternatively the router to which the stick was attached may have simply been doing a poor job of SMB file serving.

However all this appear moot: your subsequent post suggests that the playlist creation is going off the rails somewhere.
Userlevel 2
It does indeed seem to be the format of the playlist from MusicBee.

I used "Playlist Creator" to import the list and create it again. This list appeared to be exactly the same when opened in notepad, but this time worked perfectly in Sonos, all tracks with special characters were displayed fine.

Closer examination showed that the MusicBee playlist was "UTF-8" while the Playlist Creator version was "ANSI".

I'm not entirely sure what this actually means, but at least it explains the issue. And I now have a workaround.

Thanks very much for your help.
That would explain things. ANSI encodes the extended ('special') characters in one byte whereas UTF-8 requires two. Since the regular ASCII characters are the same in UTF-8 as in ANSI Sonos was happy to read those.

The Windows default text file format is ANSI. To convert UTF-8 you can always open in Notepad and re-save as ANSI.

MusicBee may have a configuration setting which forces the output to be in ANSI.
Since the last update, I ran into this problems well. My workflow:
- manage music in iTunes
- create/export playlists in iTunes
- Copy all music to network share
- Change all paths to MP3/M4A files int the exported .M3U files so it is pointing to the network share
- Copy these altered playlists to the same share
- Update Sonos Library
- Enjoy!

However, I have to add a few more steps to the flow. Special characters are not recognised anymore: éëïîêï and so on…

The problem: file is being saved using the UTF8 encoding. Since the update, Sonos wants you to supply files using the ANSI encoding. And it wants the Windows and-of-line commands as well: CR-LF (Carriage Return - Line Feed)

How to convert UTF-8 (UTF8) into ANSI on a MAC:
- Open the document
- Hit command-shift-s to duplicate (aka save-as)
- A new window will open with your playlist
- Hover with your mouse over the title-bar of this window and a small down-pointing arrow appears
- Click on this arrow and chose "Move to"
- Save at your desired location but, at the bottom, chose encoding: Western (Windows Latin 1)
- If this option is not available, enable it by clicking on: Customise Encodings List… (available at the bottom of encoding selection list)
- Hit the Save button

Now you're half-way. The encoding is correct, however, you're still missing the CR-LF.

Open the saved document of the previous step in BBE (BB Editor, Text Wrangler might work too, have not tested it thought). No do a save-as (command-shift-s) again, and set the line-breaks to: Windows (CRLF).

That's it! Now the playlist is ready to be imported into Sonos.

I hope Sonos will fix this in a future update. It used to work without all this, so they've clearly changed things.

All steps I've done could be automated using Apple-script, I haven't had the time to do do it yet.

Hope this helps some of you to get over this problem.

Cheers!
Hi,

I am having the exact same problem as the original poster, and woud like to add my voice to sheppyshepherd request that Sonos fix their bug in handling different file encoding.

I also dispute ratty's assertion that the problem is related to outside programs - it's not, it is related to how Sonos handles perfectly legitimate and valid text files containing playlists.

Here is my setup:
- Windows environment
- ALL my files are managed using m3u playlists (created with Playlist Creator, but I've had to convert them lately to work around various bugs in other systems).
- MANY of my files have accentuated characters (é, ç, à, etc.)
- I play my music on Sonos, on my PC using Winamp, on my iPod using iTunes ONLY to transfer the playlists (iTunes does NOT generate my playlists, nor manages my library. It would be akin asking a virus to manage your private documents...) and in my car on a SD card (Audi native multimedia system).

As it turns out, each of the system mentioned above has its limitation and bugs, which makes for a nightmarish experience. From my understanding, there are 3 ways to encode the text files that represents the playlists:
- AINSI
- UFT-8
- UFT-8 without BOM

I used Notepad++ to convert from one format to another and do extensive testing, and here is what I discovered:
- AINSI playlists will play well in Winamp and in Sonos, but in iTunes, it will not read the accentuated characters
- UFT-8 without BOM playlists will play on iTunes and Sonos, but Winamp won't be able to play accentuated characters
- UFT-8 playlists will work fine on winamp and iTunes... but not on Sonos (as I just discovered
- FYI, if others are wondering, the Audi car system has undocumented limitations, such as trunking playlists to 99 entries, and not allowing more than 512 files in a folder. It also won't play flad nor m4a. I know, how incompetent are they?!

To sum it up, each system has its own limitation that impacts the customer experience. I won't bother contacting Apple, clearly they have very little interest in their Windows-using customers, considering the "quality" (I use the term loosely) of iTunes and how buggy and not-user-friendly it is. Winamp announced a few months ago that it had stopped the development of their player, so my only hope is that Sonos looks into this and adds support to the various type of encoding used on different systems.

Hopefully others will also voice their trouble to Sonos so that this gets the developper's attention.

Thanks
In case anyone finds this old thread looking for ways to deal with bad character encodings, it can be done more efficiently than any of the above solutions using the unix "recode" utility: "recode utf8..l1 *.m3u". Failure to properly support UTF-8 is still a bug, though.
Userlevel 6
Badge +12
In case anyone finds this old thread looking for ways to deal with bad character encodings, it can be done more efficiently than any of the above solutions using the unix "recode" utility: "recode utf8..l1 *.m3u". Failure to properly support UTF-8 is still a bug, though.

Seems like "recode" is for Linux only. I can't get it to work on Mac OS 10.8.5

Instead I tried "iconv" like this:
iconv -f UTF-8-MAC -t ISO-8859-1 in.mp3u > out.m3u
Unfortunately although the command seems to work fine Sonos will not read it correctly. Anyone who has any advice here. Is ISO-8859-1 (also called LATIN1) not the right target format?
Userlevel 6
Badge +12
In case anyone finds this old thread looking for ways to deal with bad character encodings, it can be done more efficiently than any of the above solutions using the unix "recode" utility: "recode utf8..l1 *.m3u". Failure to properly support UTF-8 is still a bug, though.

Seems like "recode" is for Linux only. I can't get it to work on Mac OS 10.8.5

Instead I tried "iconv" like this:
iconv -f UTF-8-MAC -t ISO-8859-1 in.mp3u > out.m3u
Unfortunately although the command seems to work fine Sonos will not read it correctly. Anyone who has any advice here. Is ISO-8859-1 (also called LATIN1) not the right target format?


I believe I found the command for Mac OS/Terminal. The character encoding should be "CP1252". "MS-ANSI" or "WINDOWS-1252" also works.

iconv -f UTF-8-MAC -t CP1252 infile.m3u > outfile.m3u

I haven't tried it extensively on my Sonos yet but two playlist that wouldn't work (containing the nordic letters "åäö") was fixed by this.
Please not that "infile.m3u" is to be replaced by the playlist to be changed and "outfile.m3u" or whatever you prefer is name of the fixed file.
The '>' must be placed in between.
Userlevel 6
Badge +12
Sorry if the last post was a bit unclear.
"CP1252", "MS-ANSI" & "WINDOWS-1252" are all identical, they are just different names for the same encoding in iconv.
"iconv --list" returns a list of all encodings to chose from. Those on the same line are identical, only various names for practical reasons.
So if CP1252 does not return the desired result picking another one from the same line is useless.
Userlevel 2
I know this is an older thread. I've found a way around the problems mentioned.
Use a program that can export the playlist as a .wpl file. It is supported by Sonos and uses XML special coding like for instance & quot; (without the space between & and quot; ) to translate to ". I've used JRiver Media Center to export in that way and it works perfectly. All track are recognized correctly. JRiver MC can also create the playlist with relative paths.
I see Sonos has ignored the request to allow non American letters in songs. I being of Hispanic decent I listen to a lot of Latin music where it is very common to accentuate letters. It's really sad to see that Sonos has ignored this problem for so long.

My workflow is, Maintain my music in iTunes, copy music to WD DL4100 NAS, and export playlist in .m3u format. Of course Update Index Music in Sonos.

I think all music play okay until I use a playlist and songs with accentuated are said songs not found. I just bought five Sonus One speakers for the house and last night setup the NAS and quickly saw the problem.

Come on Sonos, fix this. Being a programmer myself, it's really not Rocket Science to fix. So please fix this issue!
Userlevel 7
Badge +21
I ended up having to edit my Sonos music library to swap all the unacceptable characters out, very frustrating.
I ended up having to edit my Sonos music library to swap all the unacceptable characters out, very frustrating.

I feel like I will have to do the same since Sonos doesn't appear to be doing anything about it. This thread was started five years ago!. It will be a pain to change all my music. I have around 12,500 songs and as many as 25% may contain characters that the playlist can't handle. In the song list and artist list it displays fine, the problem is just in Playlists.

An the worst part is I have to do it in two places. On Windows and Mac. I keep my music on a NAS at home and is the main repository but I have a Motorhome and do trips for months at a time and am always adding music. I use iTunes and there are some stuff that can be updated through the iTunes cloud, but changing file names requires the change to also be made on the other system.

And the iTunes database doesn't fully transfer everything going back and forth between Windows and MAC. I would always work on the MAC, but I hate Finder, the equivalent of Windows Explorer. So when I'm home I work on Windows and the NAS.

I do keep a full copy of the music on the MAC and use iTunes on it to put music on my iPhone.

It really would be great if Sonos fixed this simple problem for them instead of us spending weeks or months changing our music and damaging the correct way to write words and artists names in other languages.

Come on Sonos, please fix this problem!