Answered

Sonos ZP Play:1 How to setup network on ethernet port ?

  • 13 August 2018
  • 8 replies
  • 3044 views

  • Contributor I
  • 2 replies
I have a Sonos ZP Play:1 which is currently connected on WiFi and online. I would like to disable that and only set network connectivity over the Ethernet port. I tried to plug in a network cable but it doesn't seem to request an IP from my DHCP server over ethernet port.

Please advise, how do I setup network connectivity over wire?
icon

Best answer by Stanley_4 14 August 2018, 01:28

Do not do a Factory Reset, that will wipe out everything!

I'd try a known good cable as a start.

I don't think the Play 1 has lights on the Ethernet port, can't get to either of mine right now to verify that. Still your router or switch should have lights and show a 100 MHz connection (usually yellow) when the Sonos is plugged into the port.

If a known good cable doesn't work after you power cycle the Play 1 I'd phone in to Sonos support to see about getting a working unit.

You should see some Ethernet stats: (just use your IP address to replace mine)

http://172.16.1.115:1400/status/ifconfig

http://172.16.1.115:1400/status/enetports

http://172.16.1.115:1400/status/ethportstatistics
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

You just connect the cable. Maybe reboot the speaker? What do you see in About my. Sonos System?
About My Sonos system:
*other stuff like hardware version/serial number/sonos id*
IP Address: 192.168.1.20
WM:1

I know that WM:1 means its using WiFi, but it doesn't switch to WM:0 after connecting via cable.

Is there any setting I need to change on web interface that can trigger it? I looked up http://sonos-ip:1400/status but didn't find anything for Ethernet port
Is it possible to factory reset the controller and configure it to use Ethernet?
This is absolutely unnecessary. It is probably a faulty cable or port.
Userlevel 7
Badge +21
Do not do a Factory Reset, that will wipe out everything!

I'd try a known good cable as a start.

I don't think the Play 1 has lights on the Ethernet port, can't get to either of mine right now to verify that. Still your router or switch should have lights and show a 100 MHz connection (usually yellow) when the Sonos is plugged into the port.

If a known good cable doesn't work after you power cycle the Play 1 I'd phone in to Sonos support to see about getting a working unit.

You should see some Ethernet stats: (just use your IP address to replace mine)

http://172.16.1.115:1400/status/ifconfig

http://172.16.1.115:1400/status/enetports

http://172.16.1.115:1400/status/ethportstatistics
Thank you everyone for helping out. Cable is good, no issues.
Simply inserting the ethernet cable did not work for me as the Sonos device continued to use WiFi and did not use the wired port.
With Ethernet cable still connected, I turned off and turned on the Sonos device and it immediately picked up an IP address on the ethernet cable and WiFi was disabled (WM:0)
Thank you everyone for helping out. Cable is good, no issues.
Simply inserting the ethernet cable did not work for me as the Sonos device continued to use WiFi and did not use the wired port.
With Ethernet cable still connected, I turned off and turned on the Sonos device and it immediately picked up an IP address on the ethernet cable and WiFi was disabled (WM:0)
That is good, but my first reply suggested rebooting the speaker.....
Also, go into Advanced Settings, Wireless Setup, and delete (reset) your wifi credentials.
Yes, very good advice from John B, to reset/remove your WiFi credentials. That will ensure your devices stay on SonosNet.