Answered

Sonos setup


Badge

I am having problems setting up Sonos again the mobile app searches and can’t find the play 1 speaker.

Please help.

Deric

icon

Best answer by Corry P 10 June 2021, 11:58

Hi @DericS 

Welcome to the Sonos Community!

As you have a third-party router, you should put your Virgin Media router into modem mode. This will result in a red light at the bottom of the Virgin Media device, rather than a white light.

You should be able to log into your router to make this change at http:\\192.168.0.1. If this link doesn’t work, connect to the Virgin device instead of the D-Link.

I hope this helps.

View original

11 replies

Userlevel 7

Try unplugging the Play:1 from power for about a minute and rebooting your router and phone.

Badge

I have done that with 3 speakers 2xplay 1 and one play 5 but now having trouble registering the products.

Deric

Userlevel 7

What model router are you using? Are you able to connect one of your Sonos speakers directly to the router with an ethernet cable?

Badge

It is a D-link DIR-815 and I have been able to connect a ethernet cable direct.

I have since been able to register three of the speakers when the mobile app isn’t “greyed out” and that happens when the broadband is slow. I will have another go with a further 3 speakers tomorrow.

I have had problems with the mobile connecting to the internet since Virgin changed the hub last Friday.

Sonos in their wisdom only allow a mobile app to set things up, if it were a PC app then I wouldn’t have a problem.

This new hub has caused all the problems and Virgin have run diagnostics on it and they say all is well. I am slowly getting there now but I used to have BBC radio 2 on favourites but since the S1 controller update that has disappeared and I can only get it on Sonos radio.

Deric

Userlevel 6
Badge +17

Hi @DericS 

Welcome to the Sonos Community!

As you have a third-party router, you should put your Virgin Media router into modem mode. This will result in a red light at the bottom of the Virgin Media device, rather than a white light.

You should be able to log into your router to make this change at http:\\192.168.0.1. If this link doesn’t work, connect to the Virgin device instead of the D-Link.

I hope this helps.

Badge

When the Virgin engineer installed the new hub I asked him to put it into Modem mode but the white light is still on. However by switching the router on and off I have managed to get Sonos on all speakers again. The problem is I have lost BBC radio 2 and is not listed now on the Sonos app I can only use Sonos radio. Many thanks for your comments, I will have a word with Virgin about changing to modem only, that is what I had before the hub was upgraded.

Deric

Userlevel 6
Badge +17

Hi @DericS 

With two routers on your network, expect some weird behaviour. Switching to Modem mode is fairly simple - the option is on it’s own in a dedicated Modem Mode section in the menu. But yes, if you have a white light, it’s acting as router.

Did you go to the Search page on the Sonos app, select Stations and type BBC Radio 2? I just did and found it with no problem (the search result came from Sonos Radio). Are you able to find other BBC stations? If not, you may need to log in to your Sonos account on our website, go to Profile and ensure your location setting is correct.

Badge

The latest update on the Sonos app has dropped the “tune in “ option so I can’t select BBC radio 2 (national radio)  as I used to. I can only get BBC Radio 2 via Sonos radio option.

I have switched my route off now to see if the system still works.

Deric. 

Userlevel 6
Badge +17

Hi @DericS 

Sonos Radio gets the station links from TuneIn, so the only real difference is in how you find it in the app.

I should mention that with the VM router in modem mode, only the other router should be connected to it. Anything else will be exposed to the internet without firewall protection, and have a public IP address.

Badge

Hi Corry P,

Your comments prompted me to take out my existing router and wire up the new Virgin router as per my setup. I did try the new hub on modem only but that wasn’t 100% with my existing router.

The  system is much faster now on the new Virgin hub/router and I am able to get radio 2 with the Sonos radio option. The mobile app is fully functional, no “greyed out” options so I am happy.

Thank you Corry P for the help to resolve this issue.:relaxed:

Userlevel 6
Badge +17

Hi @DericS 

You’re very welcome! I’m glad to hear you’ve got it all sorted out, and are seeing a benefit after all your work!

Reply