Question

Sonos Connect


I have new LG TV and I have 2 Play 5 speakers + I have bought Sonos Connect. I understood I could use the Connect to hear audio from my TV wirelessly. I have been able to do that BUT I only get sound into one of the speakers (left) and not the other one. Can you help me so I can get sound into both speakers.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

15 replies

Badge
check the cable your using for TV to connect. If it is not a stereo headphone cable you could be getting just one channel connected.
Thanks I finally found on line automatic, compressed and uncompressed which you mentioned. I tried to change it but no change only one speaker in. I will contact Sonos on Monday.
Read this for more:
https://en.community.sonos.com/advanced-setups-229000/line-in-compression-36387
The search function here is of very bad quality. I found this one via google search, and you will find other threads that way on this subject as well.
It may not be strange; as I recall, using uncompressed line in is heavy on bandwidth usage. Which is probably why the two speakers work fine as a pair at all times except when via Connect/Line In.
No looked everywhere and I cannot find it. Very strange why audio only comes to 1 speaker when the room selected has 2 paired speakers. I will try to see if I can wire them with external cable to see if I ever get both to work but it is strange, very strange.
Maybe there is another tab next to the existing tabs below the room name on the settings screen, when something is plugged into the line in jack of the unit. Operating from old memories here...
Thanks I will do that. I cannot find compressed or uncompressed in settings I am afraid. I will contact Sonos.
There is also another thing to experiment, if you can. Connect the 5 units to each other by ethernet cable temporarily. If that works, and you can make this permanent, good for you. If this way isn't of use to you for any reason, it will be time to call Sonos support. When playing the speakers via Connect, at a time when only one of the two is working, submit a diagnostic to Sonos. Quote the number here and wait to see what they say. You may also want to email them the problem, with the diagnostic number mentioned.
I don't have any line in use just now, so this is from memory. In room settings, where you select line in, there should be another option below that allows you to set the line in to automatic, compressed or uncompressed. There, pick compressed.
Where do I do that? I cannot find it?
Ok, this is a puzzle; because you say that only left side 5 unit then plays. But both play fine for music. Try this then: change the selection for line in from uncompressed to compressed. This may cause sync problems for TV, but let us first see if this fixes the existing problem.
I have a wire from headphone socket into in line on Connect. 1 plug in TV going into 2 (red and white) into Connect. I am then choosing Line-in in Sonos and linking that to the room where I have both speakers. On TV I have selected to have audio also going into headphones.
So you have a wire running from the TV to the input jacks on the nearby Connect. Explain what you have done to get the TV sound to come from the 5 units - even where it is instead coming from just the left side unit.
Speakers are paired and they work fine as such when playing music. I cannot so easily wire them as they are too far away from TV although in the same room.
Are the two 5 units paired to run as one stereo pair? Also, you could run a slightly different - with one multi jack at the speaker end - cable and directly wire it to one of the two 5 units, you won't then need a Connect for this application.