Answered

Sonos Beam and Five Connection

  • 1 June 2022
  • 3 replies
  • 88 views

I have had a Sonos Beam for my TV audio and its been great. I recently made a purchase of the Five and the T1 Phono SB turntable. I have tried connecting both my Sonos beam and five together when I listen to TV and it makes this weird echo sound and the sound in the Five seems to go in and out. As well as if I connect the two when I listen to a record, the same sound falls in and out but from the Beam. However, with I choose to stream music from Spotify for example with both speaks it works beautifully. I went with the Five for the turntable since I already had a Sonos set up and thought it would work together well, but maybe I am not setting things up correctly? any advice or assistance with this issue? 

icon

Best answer by Airgetlam 1 June 2022, 01:57

View original

3 replies

With TV audio, it requires a fast timely connection between connected speakers with virtually little or no audio buffering to keep the playing TV audio in sync with the video on the TV screen.

To do such TV audio playback, two speakers and Sub(s) can be ‘bonded’ to any Sonos HT main player, like a Beam for example, over an ad-hoc 5Ghz ‘direct’ WiFi connection between all the HT players. It can be done if all devices are wired together too.

Note: it’s not possible to ‘bond’ just one Sonos ‘Five’ speaker only and even if you could, it’s line-in port, being used by a Turntable, would become disabled, as the device becomes a ‘slave’ to the main HT player.

In your case, you are ‘grouping’, not ‘bonding’ your Five speaker, over a 2.4Ghz WiFi (or wired) connection and that uses audio buffering, which has an approx 75ms audio delay - this buffering allows for grouped rooms to play in sync for music playback purposes across a wired/wireless network. It’s why all will work fine in your case for music audio, but you will encounter an echo for TV audio as the ‘Sonos Five’ buffers the TV stereo audio, but the Beam outputs the TV audio immediately to keep it in sync with the video on screen.

Hope that helps you to understand what you are seeing/hearing with your ‘grouped’ Sonos setup.

Couple of things to untangle here. 

  1. The Five will always be slightly behind the Beam when playing the TV’s input (or anything else connected to that HDMI input, even if it’s not a TV) by around 75ms. It’s the way that Sonos’ software prepares the signal for being played in sync across all other rooms, by delaying that input.  So speakers set up as part of that Home Theater room are not delayed, such as surround speakers, but you need two surround speakers, one Five can’t be used as a surround speaker, you’d need two.
  2. The sound going in and out when you’re using the Five’s line in for the turntable sounds like there’s some potential wifi interference . The two speakers (rooms) should be in sync, though. I’d be looking for areas of potential interference around either speaker. Line in signals are actually “heavier” or “bigger” than a standard streaming signal like Apple Music, or Spotify, so that signal is more likely to be impacted by some levels of interference that wouldn’t normally be an issue. 

I’d take a look at the FAQ I linked, and I’d also be tempted to reset my wifi, by unplugging both speakers from power, and rebooting your router. Once the router comes back up, plug back in your Sonos devices. 

It really should be working the way you want. There’s just some technical issue in the way right now. You could also submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

One way to quickly improve your line-in TT audio, is to increase the size of its audio buffer.. if you goto your Sonos Five ‘room’ properties in ‘Settings/System’ in the Sonos App and select the ‘Audio Delay’ section, you will see there is the option to increase the buffer size between 75ms and 2s - Just increase the delay (buffer) until you achieve a stable line-in audio output.

HTH

Reply