Sky Q surround sound

  • 6 May 2017
  • 5 replies
  • 3467 views

Just upgraded to Sky Q but cannot get a proper surround sound. Sky is broadcasting in Dolby stereo, so I'm happy to have stereo but need the rear speakers to be "louder"

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Hi Jon

Welcome to the community!

Could you submit a Diagnostic whilst you are watching a something in Dolby Digital and reply with the number, then we can confirm you are actually getting Dolby Digital signal.

Make sure you have the skybox set to "Dolby D" on the HDMI audio output settings under "setup"->"audio visual".

Then make sure your TV is set to output Dolby D on the Optical/SPDIF port.

You can see the signal that is being received in real time, in the Sonos application, go to "settings"->"about my system" and scroll to the room the TV is in and you'll see a value for "audio in" this will show you what Sonos is receiving for comparison purposes.

Many thanks
Perfect, thank you, changing the HDMI output made the difference.

Jon
Badge
Wow, I have had my Sonos playbar 2 No. play one’s for 2 years and I have never checked my TV output, I also have optical and just found my TV was set to Stereo!

I should now get a better experience! Also great advice on the About option of the app!

Thanks!
Userlevel 7
Badge +19
It is worth checking this setting periodically too. Mine had reverted back to Stereo, I suspect after a major Sky firmware update.
Mine 'reset' itself back to stereo once while moving from one house to another. Have to imagine it was a power surge that did it, but who knows.