Samsung Q7F One Remote

  • 24 January 2018
  • 20 replies
  • 3925 views

Hi

Have just purchased a new samsung QLED Q7F tv (QA55Q7FAMWXXY) to be exact. I note that this remote is different to all samsung / sonos related support topics currently available - I have tried them all.

Having spoken to Samsung, they're saying that the only infrared button on the new controller (below silver one) is the power button. They other buttons do not use infrared.

I would obviously like to have the Samsung controller to control the sound. Currently sonos works for all HDMI outputs without issue, it's just that I cannot control sound with remote. As a work around, I'm using my old universal remove (infrared) and my apple tv remote (4th gen) to control the sound.

Does anyone know how to use the samsung remote? or does anyone have a workaround? (maybe a small remote I can stick to samsung remote or something)

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

20 replies

I have the same problem. Playbase and Samsung Qled tv
I had the same problem, playbar and Samsung tv. In the source menu of the tv you can set the remote to controle a home cinema set. after you set this up just try to set up the remote for the playbar or playbase. it works fine for me.
Thanks Zelf, but do you have a few more details about the steps to take?
Same issue here. But I believe Qzelf's reply is correct, but the playbar/playbase should be in the line of sight of the connect box to make the IR connection. As long as Samsung does not send IR data for volume directly from the One Remote, this workaround is needed. Main issue for me: why the f would I place the connect box in the same space as my Playbase? Thousends of euros spent on a QLED and Sonos and still issues with a remote. Seriously.
Works fine, the remote can actually transmit ir so no need to put the oneconnect close to the playbar. When selecting the soundsystem, select one that emits ir (you can check this by using your cellphone'ss cam,I believe the pioneer and then the 5th try) and have your sonos learn the codes which is done through your sonos app. No biggie.
Works fine, the remote can actually transmit ir so no need to put the oneconnect close to the playbar. When selecting the soundsystem, select one that emits ir (you can check this by using your cellphone'ss cam,I believe the pioneer and then the 5th try) and have your sonos learn the codes which is done through your sonos app. No biggie.

Problem is that I have my apple remote set up with Sonos. But now I have a completely new remote and it won't learn the codes of my Samsung One Remote. I've done some research, but I might need to bring the settings to factory default for my Sonos system.

Or do you have another solution? Thanks.
By default your Samsung remote is RF only, you will have to change that. Check this video on one of the solutions: https://www.youtube.com/watch?v=ck03WhZkWSU Hope this helps.
Badge +12
a simple samsung solution for your qf7, get a samsumg bn59-01175n remote. It will control your q7f with IR vs RF. Get a new one on amazon at time for 10 buck. I know for a fact that remote works. Other models might work, but not 100 sure.
By default your Samsung remote is RF only, you will have to change that. Check this video on one of the solutions: https://www.youtube.com/watch?v=ck03WhZkWSU Hope this helps.

Nope, unfortunately not. I tried different brands (Panasonic, JVC, Pioneer, etc) and still the Sonos app did not recognize the One Remote when it asks me to point the remote and push the Volume Up button. I've even put my Sonos Playbase back to factory settings, removing the apple remote, but still: nothing. It is driving me absolutely crazy...
BonanzaNLD,

I’m not certain, as I don’t use Samsung myself, but I found this link in the Sonos Support Pages. Not sure if it may help you or others here:

Configure Sonos PLAYBAR/PLAYBASE with Samsung One Remote
Badge +12
On the Q7FN you can change the remote to work with sonos.

1 sound bar on
2 home button
3 scroll to source
4 once on source scroll up to select universal remote
5 new device
6 home theater
7 type sonos search for brand and enter
8 click sonos
9 select optical
10 go through the test on the screen setup. once the sound turns off on the bar the right codes are set on the remote

Good luck, it should be the same for the q7f
I’m having the exact same issue. I just bought a Q9F (2018), in part because I liked the clean and hidden one connect box. I’ve spent the last week reading all these pages and talking to Samsung and have come to the conclusion that IR signals (other than power) on Q7 and Q9 come from the one connect box. I think the solutions above are for the Q6 and Q8 TVs without the one connect box. I can get it to work, but the one connect has to be in line of site of the Playbar. This is...for top of the line tech driven products...crazy. How Sonos and Samsung can’t get some kind of wireless connection for volume control is crazy. I even came up with what I thought was a workaround, which was buying a Samsung IR blaster extended that I planned on routing with the one connect fiber cable to keep everything tidy, only to find out there is no IR out port on the back of the one connect box. Hilariously, I’d also been searching for small Sonos remotes I could tape to the silver “one remote” to make it a “one+1remote” similar to the original post above. I got the TV as an open box deal from Best Buy for a steal of a price, and am very happy with it otherwise, so plan to live with this inconvenience (currently just operating volume through Sonos app on my phone...again, crazy). If anyone figures out this crazy IR vestige incompatibility cluster, I would much appreciate a viable solution!
I have the Q9 also and the fixes mentioned may work for the other models but not the Q9. Im so frustrated and disappointed .
Same issue here. My workaround is I have to go to my cable input source then go back to my amazon firetv then my sound will suddenly work and will continue to work until I switch to a different input source. Playbar and sub only. Strange because its like this also for my HBO GO and showtime anytime app.
I have also issues with the connection between my Samsung QE65Q7F 2018. My Samsung forgets the remote. So I can connect it, but when I switch of my TV and the other day switch it on again, I have to do the procedure of adding a remote again.
The TV forgets the remote? That's very odd. You're not unplugging the TV from the power every time, are you?

Hmmm. I'd have thought even if you were (which I doubt, but it's worth asking), your TV should "remember" the remote. You may want to ask this question on a Samsung forum.
Yep, each time I have to connect it to the Samsung. Of course it remember the remote to control my TV, but not as a remote for my Sonos.

Sonos isn't in the list with available Homecinema systems (which makes sens, because it isn't a homecinema system). So every time I have to connect it again and fill in the name. My Samsung TV does connect with the Sonos.

I will ask this on a Samsung forum. It's very odd.
Had the same issue - this was is how I solved it.

Simply run the “Power Test” in the Remote Setup TWICE on you Samsung Q6/7/8/9. You answer “No” the first time it asks you if it restarted Sonos. Then run “power test” again and this time answer “Yes”. This resolved my issue and the Sonos finally responded when I did the “volume +” during Sonos Remote Setup.
In one way or another the problem is solved. I don't know what I did, but it's working fine now. Perhaps I did the same as @richard6575 did.
I don't get how you got your Samsung RF remote to work as IR. Iv tried all these work around and I still can't change the volume on my Sonos bar.........