Question

Ripping my hair out

  • 8 September 2019
  • 7 replies
  • 101 views

Okay so to keep it short, system was working (Beam & 2 Play 1s) in surround absolutely fine. I added alexa and a couple days go by with no issue. I borrow a friends sub. While setting it up something with my TV came up a problem with HDMI & CEC. My CEC was enabled and I use an ARC port anyways.
I started troubleshooting obviously. The sub is returned to the friend and my beam works with the TV again, but I'm still unable to get my Play1s to work in a surround. Basically at this point I have factory reset everything a number of times. I have reinstalled apps. I have plugged speakers into the ethernet and removed.
I can find them, add them and even pair them in their own room. However when I load the beam and try and make them my surround speakers, they are found loaded and then cant seem to ever work together. When I go to the room on the app with surround I get this Room(+?+?). If I plug them into ethernet I get the (+LS+RS). As soon as I unplug them and put them in their location they drop off.

Thanks for any help and letting me VENT!!

7 replies

First, please stop doing a factory reset on the speakers. All that you're doing is erasing any data that might help Sonos help you.

Since the speakers are working as separates, and just not as surrounds, it's pretty clear the issue isn't with the speakers.

The ?+? is a good indication that your router isn't passing a valid IP address to the surround speakers when they're connected via the Beam. The Beam uses a 5Ghz channel to connect to the surrounds, and the process gets handled through the Beam. When you connect them with ethernet, and set them up not as surrounds, then the IP address is being given directly to the speakers by the router, rather than going through the Beam.

So I'd be looking at some sort of change that's occurred recently on your router, either by you doing something, or by a background process updating it, with the end result that it's not passing an appropriate IP address to the surrounds.....or possibly with the moving around that you've been doing, there could be some sort of interference introduced near the Beam that's keeping it from communicating properly on the 5Ghz network with the surrounds.

I'd recommend at the least that you make sure your router's firmware is up to date. Then I'd be looking around the Beam for some source of 5Ghz interference, and maybe try moving the surrounds to be a bit closer as a test, and you can move them back once we figure this out.
Okay, I'll stop with the factory resets.

Okay so part of the whole Alexa thing was an Amazon tech installing a Ruckus router. But he set up everything and it was working though for a week or so.

I will try moving them close and see if its an interference.
I tried putting them right next to the beam. No luck. It doesn't even recognize their individual identification.
If they installed a new router, after which it stopped working, it might be worth calling them and talking to them about it. There is possibly a setting on the Ruckus router (never heard of them) that's blocking the ability for the Beam to extend an IP address to the surrounds. At least we've deleted the possibility of wifi interference.

After calling Amazon and talking to their tech, you may want to contact Sonos Support directly to discuss it.

I suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.
I appreciate the help
Not sure I was that much help, but either way, you're welcome.

When you find out what it is/was, come back and let us know 🙂
THE FIX!

In short contacted Sonos support via phone and they identified it immediately. Ruckus wireless router comes with several settings that basically block "multicasting". Which means the Play1s couldn't connect to the beam as a group.

Finally got a hold of Ruckus support and they have to go in and run some different commands on the wireless router with you. Not a super easy process but its done.

Reply