Playbar with LG Magic Remote

  • 5 December 2013
  • 35 replies
  • 48420 views

I'm using my play bar with lg smart tv and Harmony Remote.

It works ok but i wanted to switch to original remote from LG = Magic Remote.

Playbar won't recognize this remote if i klick on volume up button as requested.

As far i can remember, first time i bought play bar it worked very well with lg magic remote.

The strange thing is that if i push power off button on magic remote play bar recognize this.

Has someone have some solution?

Thanks

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

35 replies

Does anyone have any ideas to get Playbar to work with the LG Magic Motion remote for volume control? If not, it'll have to go back...I'll never talk my wife into using her cell phone to control tv volume.
Which model TV are you using? I doubt that this LG remote will work with PLAYBAR because these Magic remotes are RF and PLAYBAR needs IR.

Some of the SAMSUNG sets use a Bluetooth remote, but there is an arrangement to allow control of IR only devices.
Argh! Ok, back to Amazon it goes. That would be a handy warning for Sonos to issue in order to save folks the hassle. I get that they don't want to deter people from buying their product, but I doubt very many folks hang on to a Playbar that requires a remote and a cell phone to run.

I actually downloaded an app from LG that allows me to run my TV with my cell phone, but even switching the apps is a pain, and even at that I need the TV remote to turn the TV on. Does point out that you don't need RF or IR to change the volume though...just WiFi. Which is what the Sonos app uses.
nwh,

The control interface with TV's is a universe of shifting sand. Due diligence would require owning and testing every possible TV model and, if the a model offers a firmware update scheme, checking each of these models every day for subtle changes in the control protocol. This could result in situations where a diligent manufacturer might need to send out a message to all customers that, "as of 0000hrs today, our equipment is not compatible with TV model XYZ1234". At one point some of the SAMSUNG TV's would actually crash when used with PLAYBAR. This was quietly fixed with a TV firmware update. Another SAMSUNG firmware update in October 2013 improved audio streaming compatibility with PLAYBAR -- for some models. (no, I don't have a model list)

If enough users return their purchase because of control issues, maybe a group of smart MBA's will figure out that it is in everyone's best interest if an industry standard control interface is developed. I'm not holding my breath for this development because this sort of return is usually thrown into the "user error" bin and the set is sent out again as a "repack". If such an interface was developed, someone would "own" it and want to charge everyone else for using the intellectual property, but since TV's are so price sensitive, manufacturers would be reluctant to pay another TV manufacturer royalties for the control protocol.
Never mind. The cheap universal remote will also do the job.
Buky: Given that you initiated this post back in August, I'm assuming you have something that works. Mind sharing. Ultimately a universal remote might do the trick, but I don't think my wife will want to memorize a whole bunch of buttons, which is to say that while it doesn't have to keep the "cursor" functionality of the magic motion remote, it can't require memorizing which button means what with respect to "Netflix", "Pandora", etc. Also, did you experience any of the latency issues JDCJ and I experienced (see "Playbar lipsync delay" post). Haven' packed it up yet, but will have to do so pretty quickly. Hasn't soured me on Sonos, I'll just replace it with a Play 5 and skip the TV functionality (keep the TV speakers...not using for home theater anyway...just an upstairs television).
Go to Settings on your TV and choose Audio Out: External Speakers Optic. (Probably you have already done this when you installed the Playbar).

Go to Settings on your TV and choose ALT and then Universal remote. Choose to use your LG Magic remote with an external Playbar. As Sonos is not listed I've tried different brands and got it to work with Harman Kardon (remote 1).

When you do this setup you have to have a Sonos controller (iPad, iPhone etc) and there you choose Configure remote. When the Sonos app tell you to press + do so at the testpage on your TV. After that confirm the set up at the TV and do the two last step in the setup in the Sonos Controller.

Drop me a mail if you want further information.

//Marcus
Userlevel 2
I don't know how, but it works. 😉 Great! But mute doesn't work as mute, rather as volume down. How about you? The same?

Thank you very much, Joerg
Userlevel 2
Hi guys,

I just got an LG LA9700 and I can't seem to find the ALT & universal remote settings. I assume it's no longer part of the LG settings available,

Any other suggestions for getting the magic remote to work with the playbar??? this is so frustrating!

Jess
Userlevel 2
Just picked up an LG 55" GA6400 and I too can't find the ALT setting. Any other ideas to get the LG Magic Remote to work with Sonos?
I have two new LG TVS with webos (lb 7100 series) and was able to pair the magic remotes to my playbars using the Phillips soundbar remote type 3 setting. In the device connector set up on the tv, select phillips as the soundbar manufacturer. On the next screen, use remote type 3, then click done. To link magic remote to the playbar, open sonos controller app and select replace remote and go through the steps by pressing volume +/-/mute as indicated. Once Sonos says the pairing is done (on the app), then click NO on the LG screen that asks if you want to reset AV. NO, not yes! Your volume +/- buttons on the magic remote should now work your sonos playbar / sub. Please note that the mute button on the lg magic remote will delete these settings so don't press it. There is no mute option that I can find but at least you can change the volume. Let me know if others have a better solution.
Here is the solution as posted by manuel on this forum: "https://ask.sonos.com/sonos/topics/connect_lg_remote_with_playbar[/url]"

This works for my Magic Remote 4K Ultra HD TV UB980 series (you have to be patient with it and the onscreen menu was slightly different for my TV from what is described below. You also need to move quickly so timeout doesn't return you to menu screen but I now have my Playbar and Sub working fully (Vol+, Vol- and Mute) with magic remote finally after asking both LG and Sonos, neither of who could resolve it:

"Ok I resolved it - here is how:
1) Go to the LG "Universal Control" and add a Philips sound bar
2) Once done exit the setup and switch to your normal TV input
3) Bring up the LG on-screen remote by pressing the "123/QMenu" button
4) Choose the left/right arrows on top of the on-screen remote until a grey "S.Bar" button appears in the top row
5) Choose the "S.Bar" button which changes the on-screen remote to shrink, show a green "Phillips" button and more importantly the Vol+ and Vol- buttons
6) Launch the Sonos contoller, go into the remote control setup and choose "Replace Remote"
7) When the Sonos controller asks for the respective Vol+ / Vol- buttons use the ones off the on-screen remote from step 5
😎 The mute button was not available on the on-screen remote so to complete the Sonos remote setup go back to step one and go through the same sound bar setup again which will give you the mute button on-screen as some of the button to test

There might be an easier way of doing this but the above worked for me and hopefully for some other people as well...

Cheers,
Manuel"
I can confirm setting as Philips type 3 soundbar worked for me on a 2014 LG oled tv with wand remote. Steps much the same as above, however I used the physical volume buttons (and mute) on the remote when doing the setup to Sonos. All works perfectly.
Userlevel 2
Selecting 'Phillips - type 3' worked for my Magic Remote and LG UB9800 television. Thanks!!
Userlevel 1
Here is the solution 65uf8600
This works for my Magic Remote 4K Ultra HD TV 65uf8600 series. but I now have my Playbar and Sub working fully (Vol+, Vol- and Mute) with magic remote finally after asking both LG and Sonos, neither of who could resolve it:

"Ok I resolved it - here is how:
1) press input key on remote (top Right key)
2) go to all inputs
3) go to edit universal remote then add sound bar
4) choose phillips then (arrow right to remote 3)
5) follow on screen instroctions
6) Launch the Sonos contoller, go into the remote control setup and choose "Replace Remote"
7) When the Sonos controller asks for the respective Vol+ / Vol- buttons use the ones off the on-screen remote from step 5
😎 The mute button was not available on the on-screen remote so to complete the Sonos remote setup go back to step one and go through the same sound bar setup again which will give you the mute button on-screen as some of the button to test
SoundWorld - thank you so much! I was pulling my hair out trying to find a solution. Even Sonos couldn't find a solution. Thank you!!!!
To everyone who don't have the possibility to choose the manufacturer: see this https://en.community.sonos.com/home-theater-228993/how-can-i-configure-lg-magic-remote-with-sonos-playbar-tv-model-55lm7600-6487430/index1.html#post15993142
The solution from SoundWorld above works with a 55UF950V, magic remote and Sonos Playbar. A big Thanks!
I can confirm SoundWorld instructions work perfectly on the LG 55EG910V
Has anyone been able to get this to work with a 2016 LG model TV? I have the OLED65B6P and have tried everything I've found in the forums with no luck.
Userlevel 2
Badge
I looked superlong for this to work and there is a simple way to get it to work (or atleast for me)
Im on a LG 70UH700V with webOS 3 and sonos Playbar and some Play:1 mainly

Part 1:
1) Click the home button on your magic remote and scroll along the bottom (where Netflix, etc is) until you get to a purple icon "device connector"
2) Select soundbar and pick the Phillips brand and select remote type 4
3) Select done

Part 2:
1) Open the Sonos app on your iPad or phone
2) Select the gear icon "settings"
3) Select the room your system is in
4) Select TV setup and control
5) Select remote control set up and follow the prompts using your "Phillips" magic remote

You are done!

Hope it works!

Ps. all props to https://en.community.sonos.com/home-theater-228993/how-can-i-configure-lg-magic-remote-with-sonos-playbar-tv-model-55lm7600-6487430/index1.html#post16025454
TheyCallMeAndy -



Thank you for that.
Thank you Andy!! Works great on B6 Oled!
Worked an absolute treat :D

thanks
I've followed the following steps to successfully pair an LG Magic Remote for LG projector PF1000U (image attached) with a Sonos Playbar:

1) Get to the Device List or Device Connector screen (setup screen seem to change across LG TV models)
2) Select "Add Soundbar" and pick the Phillips brand and select remote type 4. The TV/projector will then load the remote settings and show three "virtual remote buttons" on the screen (Power, Volume + and Mute).
3) Open the Sonos app on your iPad or phone
4) Select the gear icon "settings"
5) Select the room your system is in
6) Select TV setup and control
7) Select remote control set up and follow the prompts. You will be asked to click the "Volume +" button on your remote. You should select (click) the "Volume +" icon on the TV screen using you remote and not click the actual "Volume +" button on the remote. If you're successful, the Sonos app will say that it recognized a remote click and will then ask you to click the "Volume -" button. This is where I got puzzled since the TV virtual buttons did not include a "Volume -" button. What I did was to click the Power button, and then the Sonon app will ask you to click the Mute button which I then did by selecting the virtual mute button on the TV screen. The Sonos app will now say your setup is done, but what I ended up with is that the "Volume -" action was triggered by the remote power button... To fix this follow step 8.
😎 Repeat steps 1-6 and then select "Replace Current Remote". Now, after I clicked the "Volume +" button the Sonon app skipped the pairing of the other functions and all buttons worked as expected (Volume +, Volume - and Mute).