Play 5 Gen 2 suddenly disappeared and I can't Find Missing Product

  • 19 October 2019
  • 4 replies

My Play 5 Gen 2 has disappeared from the network.  I can still use my connect:amp.

I tried the “Find Missing Product” routine.  It worked until the point that it said my Sonos would create a temporary wifi network - but there was no SONOS wifi network.

I tried the alternative ethernet connection method.  Didn’t work at first.  Then I reset the Play 5 (Power-on-while-holding-connect-button).  Then it appeared to work until the point where it said press connect and listen for a chime.  I pressed connect, heard a chime…. then nothing!

I have uninstalled and reinstalled the sonos app on my i phone.

Am v frustrated now.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies,


Is this a recently new speaker, or one that you have had working okay on your system in the past? If it’s a fairly new addition, then check if your router settings has an option called ‘Airtime Fairness’ and switch that off.

Its also worthwhile rebooting the router.

If you have any WiFi access points, repeaters, or WiFi guest networks enabled, switch those off temporarily. Make sure the mobile device meets the Sonos system requirements and try the factory reset / setup process once again and see how that goes for you.

Userlevel 7
Badge +26

Good suggestions, just one more that you might want to start with, can you run an Ethernet cable from the router to your Play:5? Maybe you could just move it into the room with the router and run an Ethernet cable between them. That way you can see if it connects on a basic setup. If it does, you can send a diagnostic under Settings > Help and contact the support team to investigate it.

Userlevel 7
Badge +26

Thanks for the details, if it won’t find the unit when it’s also wired into the network, most likely there’s some permissions or network limitations at the router’s level that’s preventing the Play:5 from connecting to the network. If you’re familiar with checking, you can log into the router’s administration page and check for parental controls for just that unit, or maybe some access restrictions. If you want a hand with this, feel free to contact the support team to investigate it, if you haven’t done so already.

Thanks @Ken_Griffiths - The speaker is a few years old and has been working happily.  I have this Play 5 in one room and an Connect Amp in another.  The amp is still working fine.  This Play 5 just suddenly became unavailable.

My iPhone went through a standard upgrade last night, but I haven’t used the sonos for about a week so unsure if the two things are connected.

My iPhone is pretty recent - gen 7 or 8 I think.  Have tried most of the things you suggested.  Will run through it again.

Thanks also @Ryan S  I have connected the Play 5 directly to the router.  It runs through the whole Find Missing Product routine just fine - it finds the speaker, goes through a set up routine, asks me what sort of speaker it is, tells me to press the connect button and says listen for a chime.  I press the button and I hear a chime, but then the set up routine on the iphone sits in the same place.  Nothing else happens and the only button I can press is back.