Answered

No Sound From Sonos Ray With Vizio D43-D2


Badge

The Visio TV is located in my backyard bar area.  I have many Sonos speakers throughout my home so wanted to buy the Ray to couple with this TV and also join my Sonos family of speakers extending the music to the outdoor bar. I have been unable to get the TV audio to play through the Ray so seeking some community input. It’s an inexpensive and older TV but it does offer optical out. There are only a few settings on the TV to alter the audio output but I haven’t been able to find the combination to make this happen. I am using an Apple TV 4K gen 1 as my only source to the TV. I have not yet tried a different optical cable so a bad cable, which came with the Ray, is a possibility. 
 

Here are the TV and Apple TV setup options that may/may not be in play for this:

Vizio D43-D2 TV Settings 

TV speakers on/off - I set to off

Digital Audio Out - PCM or Bitstream. I have tried both but believe PCM is correct for the Ray

CEC - Disable/ARC only/Enable. I have tried all but not sure of the relevance with no HDMI on the Ray

Apple TV Settings:

Default Audio Output - TV speakers is my only choice

Audio Format - Dolby Digital 5.1 or Stereo. I selected stereo to match with PCM on the TV 

Audio Mode - Auto or 16 bit. It is set to auto

Thank you for any comments. 

icon

Best answer by Western 1 16 July 2022, 05:27

View original

11 replies

Userlevel 7

Is the optical cable fully inserted into the ports on the Ray and TV? Did you remove the plastic caps on both ends of the cable?

Badge

The optical cable was fully inserted when I went to check the plastic caps. Cap was still on the speaker connection so I just pulled it off. Took the cable out of the TV port and the cap was not on the cable however it may have remained in the port when I pulled the cable out because still no sound when I tried. I will need to take the TV down from the mount to check for that. The caps are a great suggestion and I thank you very much.  It’s been a long time since I’ve used an optical cable but still a bonehead move to not realize there were caps on! 

Normally one can ‘see red’ when the TV optical connection is active. A cap would prevent this or make the ‘red’ very dim.

Badge

I checked the port on the TV and there was no plastic cap in there so it must have been removed, unlike the other end of the cable that still had the cap on. I have confirmed now no caps and the cable is fully inserted into the ports. I’m getting a bright red light from the end of the cable going into the Ray. The Ray works fine playing music through the Sonos app. But still no sound from the TV. I’m guessing I need to change a setting on the TV or the Apple TV but I haven’t been able to get the right combination, and there aren’t that many choices as I laid out in the initial post. 
 

There is another setting I just noticed on the TV named “surround sound” and I had that set to on but have changed it to off since the TV digital out is set to PCM and the Apple TV Audio Format has been set to stereo. 

You could temporarily use the TV’s speakers in order to verify that audio is presented to the TV.

CEC means nothing to RAY, but my be required between the TV and AppleTV.

Userlevel 7
Badge +17

Some TV’s cannot output sound received from HDMI sources to optical. This may depend on the format the HDMI source is delivering the sound in. You could try and set the ATV to a simple, non-surround format like PCM 2.0 and see if that works. 

Badge

You could temporarily use the TV’s speakers in order to verify that audio is presented to the TV.

CEC means nothing to RAY, but my be required between the TV and AppleTV.

 

There is sound from the TV speakers, as long as the TV is set to TV speakers on. I now have it set to off but have tried it set to on and confirmed still no sound from the Ray but there is sound from the TV speakers when that is set to on. 
 

Some TV’s cannot output sound received from HDMI sources to optical. This may depend on the format the HDMI source is delivering the sound in. You could try and set the ATV to a simple, non-surround format like PCM 2.0 and see if that works. 

I was not aware of this. I do have the ATV audio format set to stereo when doing all of this, the only other option was DD 5.1 and they Ray doesn’t support that. I will look a bit more closely at the ATV settings but feel like I have reviewed all the ATV sound options available to me. 
 

Thank you all for your input! 

@Western 1 

TV User Manual her:

http://cdn.vizio.com/manuals/kb/d43d2manual.pdf

You do need to set the TV and Apple TV to output Dolby Digital 5.1 audio with HDMI input format set to Bitstream - note the Vizio TV supports both DTS and Dolby Digital Plus, but do not select those in the TV settings and don’t bother with PCM stereo here either.

For the DTV audio out - you want Dolby Digital 5.1 to be output to the optical port. DD+ will not work with the Ray.

The Ray does support DD 5.1 audio in.

 

Badge

This issue was resolved with the help from Sonos Tech Support.  It took 24-48 hours for each reply but at least it was resolved. The only change required from my original settings I posted up top was to enable the autoplay feature in the Ray settings.  You can do this from the Sonos App > Settings > System > Ray “speaker name” > TV Autoplay.

Thanks to all for your interest and help! 

Userlevel 7
Badge +17

Autoplay is a useful feauture but you could have chosen the TV als an input for your Ray in the Sonos app. The musical note in the app lets you switch sources.

Badge

Autoplay is a useful feauture but you could have chosen the TV als an input for your Ray in the Sonos app. The musical note in the app lets you switch sources.

Thank you, I didn’t know about that either. I tried it and did see what you explained.  This is my first experience with a sound bar and I’m pleased it’s finally working as it should. A few more instructions with the Ray referencing the helpful things in this post would have saved a lot of time. 

Reply