NAS for Mac OS X


Show first post

30 replies

Userlevel 1
Hi

The files are visible using the Finder in the source location only, which is an internal HD, but are not visible on the mounted linkstation.

I can only see that they are on the linkstation, by opening it in Transmit.

If I open a particular folder in the right window of Transmit, it shows there are 15 items in the folder (of which one has a file name of >32 chars). However if I open the same folder in the left window of Transmit, it shows there are only 14 files in the folder (minus the >32 chars file).
Userlevel 1
OK, just a guess but the file that isn't visible when viewing the left hand window may be a system file which is "hidden" when viewing it in finder but would likely show up as an accessible file on the NAS. Dragging and dropping the folder copies everything over to the NAS but OS X might be hiding any files that are system files as its viewing default.
Userlevel 1
Many thanks for the replies so far.

As I see it, the easiest thing for me to do is to copy files across to the linkststion using the finder, but to keep any files >32 characters on an internal HD.

So is it possible to write something lika an applescript to move all the files >32 chars into there new location first, allowing me to then just move the rest of the files to the linkstation via the finder.

many thanks for your time
Userlevel 1
I'm using the Maxtor Shared Storage NAS. It was recommended elsewhere on these forums as being quiet - that's why I went with it, and it certainly is. I've had no problems mounting it to my mac desktop as a SMB share. I don't know what this 32-character problem is, but admitedly I have no filenames that long anyway.
Userlevel 1
Zorba, using either ftp or mounting the NAS via smb you should be able to move the files irrespective of the length of the filename. I'm fairly sure your missing file problem might be down to those you can't see being system files, but with an ftp transfer (when the NAS is ftp enabled) or just mounting the NAS via smb you should be able to move the files with >32 character filenames.,

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)