Question

Moving a Move to SonosNet

  • 19 February 2021
  • 14 replies
  • 78 views

Userlevel 3
Badge +3
  • Prominent Collaborator I
  • 86 replies

I’ve got an existing S2 based system comprising a Boost and 3 Ports, and I’ve just added a Move as my final component.

Prior to adding the Move, everything worked Ok. The problem I’m having is that the wifi reception is very poor on the Move, even though I’ve followed the setup steps in the Quickstart Guide.

If I look at the Move in “About my system”, it appears with WM:1 at the end. Does this mean that it is connected directly to my router via wifi, rather than via Sonosnet? The Ports all display WM:0.

If so, how do I make it change to use the Boost instead of my router? Things I’ve tried so far: reboot the router: doesn’t change it. Power off and on the Move: doesn’t change it. Reboot the Boost: everything briefly swaps from Boost to router, and then back again when the Boost is running again, but the Move stays with WM:1.

Any suggestions what to try next?


14 replies

Userlevel 6
Badge +17

“Sonos Move will always be in a wireless setup (WM: 1) even if your other products are in a wired setup.”

https://support.sonos.com/s/article/3237?language=en_US

Userlevel 3
Badge +3

Thanks - my understanding of WM:0 and WM:1 was not correct! The article is a bit ambiguous though. It’s not clear whether it means that a Move cannot use Sonosnet, or that it can but it is not considered to be “wired”!

At the moment it doesn’t seem to be participating in the mesh that the Ports are.

Unfortunately it will probably need to go back for a refund, as performance as it stands is not acceptable -  If I start playing a track on all four devices, all of the Ports will start immediately, but the Move stays silent for around 10 seconds or more :-(

@Antifon, The Move isn’t capable of joining SonosNet.

The Move is supposed to have a good radio on board. It might be worth changing the channel on your router.  Or try connecting the Move to whichever band it's currently not using. 

Userlevel 3
Badge +3

@Antifon, The Move isn’t capable of joining SonosNet.


Ach, thanks for the info. That’s a pain. Unfortunately the intended “home” of the Move is right at the opposite end of the house to the router, and on the ground floor, while the router is on the first floor. I could relatively easily move the Boost, but not the router.

So the fact that the Ports have good reception (via the Boost) is no help at all. But… at least I know not to mess with the Boost’s channel, as all the Ports work Ok with SonosNet set to Channel 6.

I’ll have a look at the router’s config. At present the Move is on 2.4GHz Channel 11 (channel selection set to Auto). So perhaps I could manually choose a different one. The problem with messing with the router channels is that there are a lot of permutations and combinations, especially when you think that the neighbours’ routers may be set to “auto” and may start channel hopping as soon as you do!

So the fact that the Ports have good reception (via the Boost) is no help at all.

Not entirely. The Ethernet ports on your Ports (excuse the pun) are live. You could therefore wire a small WiFi access point and thus provide a local WiFi signal for the Move.

Userlevel 3
Badge +3

That’s not something I had thought of, nor would it ever have occurred to me but… I don’t think it should be necessary - I’m not living in a mansion!

I’ll try manually setting to channel 13 on 2.4GHz and see what happens. Fortunately everything else wireless (non-Sonos) is using 5GHz so (in theory at least) they shouldn’t be adversely affected by the change.

Channel 13 is not a good choice. It will interfere with, and suffer interference from, any nearby users of channel 11. Use only channels 1, 6 or 11 at 2.4GHz, and always choose 20MHz width.

As for the idea that exploiting SonosNet as a meshed backhaul for an AP should ‘not be necessary’, you have a range problem from the router. I suggest you make use of what’s available.

Userlevel 3
Badge +3

I understand what you’re saying, but the Move is movable! I don’t want to put in place a solution for a specific location, when I might be using it at the other end of the house or indeed at the other end of the garden!

Ok, I’ll maybe try channel 1, and see what that does. I don’t seem to have any option to choose a width, though there is an option to select the bandwidth available - currently “802.11 b/g/n (up to 144 Mb/s)” but with 54Mb/s and 300Mb/s as alternatives.

‘Up to 144Mbps’ is 20MHz. 

As for the AP suggestion, you could of course configure it with the same SSID, security and channel as the router, and have the Move connect to whichever is closer.

Userlevel 3
Badge +3

Ok, thanks. Moving to Channel 1 and rebooting didn’t seem to make any difference - the delay when (for example) choosing to “track forward” was around the same 10-20 seconds.

I wonder if turning off 2.4GHz altogether and just leaving 5GHz active would make any difference. It would mean everything sharing 5GHz, but that probably wouldn’t be an issue.

Or… on the other hand I could just leave it alone and accept its limitations!

If you can have separate SSIDs then you can force the Move onto 5GHz by only having that SSID in the Move's WiFi settings.  No need to turn off 2.4GHz for the whole network. Not sure it will help though.

Moving the wireless router a foot this way or that might help.

As a general rule, 5GHz has shorter range than 2.4GHz. This is a mixed blessing. On the plus side, 5Ghz neighbors are less likely to interfere because they are out of range.

In my area many of the houses were started in the late 1700’s. They were tiny back then, but have been augmented over the years by adding more rooms. These rooms are outside of the original structure that had stone walls. Stone is opaque to WiFi. Even though these houses are still considered small, it is very difficult to get proper WiFi coverage from front to back using a single access point. More modern houses often have marble floors -- also opaque. In these modern structures floor to floor WiFi coverage is difficult. A double whammy can be an old house updated with marble floors.

Multiple wired access points or one of the relatively new WiFi mesh systems is the solution. (SONOS had mesh in 2005)

I also find that the new WiFi6 access points are more effective. This is partly because they are newer, better, premium designs and partly because WiFi6 is better overall. In order to realize the full WiFi6 potential, all devices need to be WiFi6. We are still a few years away from this because existing devices will need to be replaced. But, it is usually beneficial to move to WiFi6 wireless routers and access points.

Userlevel 3
Badge +3

Thanks for the suggestions. I’m fairly sure that I can change SSIDs independently, so I may try changing the 2.4GHz SSID to something else, which should force the Move onto 5GHz, though I share the view that this won’t help, and may make things worse, given that the cause is probably distance more than anything else. I control the system from two Lenovo tablets which are both connected at 5GHz and neither shows good signal strength in that area.

I understand the point about house structure, but there’s nothing complex about this one - just typical rubbish 1980s brick build with mainly stud partitions internally and no fancy floors. The total distance from router to Move is probably 25m in a straight line, so that probably is the main cause, plus of course whatever my neighbour’s router is pumping out!

Reply