Mac can not add library

  • 13 August 2019
  • 6 replies

I used Sonos for a long time on my Macbook Pro 2013, last year I moved to a new Macbook Pro 2017 and continued to use my Sonos with this newer Mac.
Now I would like to reactivate the old Macbook.
Sonos app itself is working but I can't add my Music Library.
Sonos asks for the admin password but then an error message appears, your Macbook Pro 2013 has rejected access to the Sonos System. No error code.

I followed many suggestions I found when googling this error message.
I deactivated file sharing and reactivated it.
I removed my Music folder from Sharing, added it again.
I move a folder with just 2-3 songs to a different location.
Then I realized on my 2017 that there is a "user" called SonosDMS which has access to my Music folder there.
So I tried to add a user SonosDMS on my 2013 and got an error message that this user exists, but it seem to be hidden. So, I used some Terminal commands to get rid of the user and set it up again, or let Sonos do it automatically (I think this is happening when adding the library).
Still getting the same error message.

Any other ideas apart from a clean install ?

This is how it looks before I add the Library

and while trying to add the Library for 1-2 seconds this "new" user is trying to get access to the folder (not sure what "loading" means)

I'm running macOS Sierra on the 2013 machine, same OS was on the 2017 machine.
Sonos 10.3.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

I cleaned up the access privileges of the whole music library, did not solve the problem.
Created a new user account, put the new (cleaned up) music library onto a different user account, did not solve the problem.
Remote desktop access to the 2013 through the 2017 machine and the new user account, did not solve the problem.
Logged in (remotely) as standard admin user added the same old library as before - and it worked!

X-Files, case closed.
Userlevel 7
Badge +20
It may help to update the OSX. You might try setting it up as a network share instead. To do so, you'd want to head into the 2013 machine's system preferences and share your music folder manually, setting permissions for a user account with a password. Then choose the network share option in the Sonos app and set it with the path "\\Macbook-Pro-2013\Shared Folder Name" and the user name and password you set. This should get around any issues with the local Sonos account.
Yes, that's the second machine.
Computers are named differently one is Macbook-Pro-2013 and the other one Macbook-Pro-2017, you would get something like (2) when adding a computer named the same.

Same user account, even the same audio library, not cloned.

Streaming from the 2017 machine works, library can be easily added and removed.
Streaming from the 2013 machine (which was used 2 years ago with exactly the same Sonos speakers), library can not be added.

Sonos app works on both machines, same version number. Mac OS version is different is Sierra vs Mojave, so the old one has not been updated to Mojave yet. Both were on Sierra until 2 weeks ago. Saying that, streaming from the new machine did not break since Mojave, do you think that a Mojave update on the old machine could solve the problem. I'm hesitating a bit since I lost 2-3 apps on the new machine after updating to Mojave ?
Userlevel 7
Badge +20
Many thanks. No antivirus or firewall in place.
I submitted a diagnostic report under 1926552791

Thanks for the report. Your router is returning a different network address for your computer when Sonos tries to connect. Do you have a second computer named "MacBook-Pro-2017" on your network? If so, it may help to change the name of either computer, reboot it, then try to set up the share.
Many thanks. No antivirus or firewall in place.
I submitted a diagnostic report under 1926552791
Userlevel 7
Badge +20
[h4]Hi McPrell,[/h4]

Thanks for reaching out. Please check your antivirus and firewall settings, then try to add the music share again. If that doesn't work, submit a diagnostic report and reply here with the number.