Linksys Routers need to have the Filter multicast option checked


First of all, I have to give credit where credit is due: Dale from Sonos Support figured this out - not me!

The first problem that I had to overcome was that my Linksys EA8300 has a Guest Network. And that's what the Sonos speakers attempt to connect to by default, whereas all the devices I would use to control the speakers are on the Internal WiFi network. Which means that the speakers and the controlling device would not be on the same network.

After disabling the Guest WiFi on the Linksys, I got further, but still couldn't get the speakers to finish their setup, even with an Ethernet cable connected. They would start the process in the app, and my smartphone could see them, but the process would ultimately fail.

Once Dale from Sonos got on the phone with me and looked at my router setup, he explained that the Sonos system requires Multicast to be functional within the network. Despite ALL the information I had reviewed on the Internet, on Linksys' Support Site, etc., this was the fix:

In Linksys Security Settings, under "Internet filters" there is a checkbox called "Filter multicast." This box is UN-checked by default from Linksys. Check the box, and it ALLOWS Multicast traffic - against all reasonable assumption.

Thank you, Dale - loving my Sonos now!

1 reply

Userlevel 7
Badge +20
HairyTick05 wrote:

First of all, I have to give credit where credit is due: Dale from Sonos Support figured this out - not me!

The first problem that I had to overcome was that my Linksys EA8300 has a Guest Network. And that's what the Sonos speakers attempt to connect to by default, whereas all the devices I would use to control the speakers are on the Internal WiFi network. Which means that the speakers and the controlling device would not be on the same network.

After disabling the Guest WiFi on the Linksys, I got further, but still couldn't get the speakers to finish their setup, even with an Ethernet cable connected. They would start the process in the app, and my smartphone could see them, but the process would ultimately fail.

Once Dale from Sonos got on the phone with me and looked at my router setup, he explained that the Sonos system requires Multicast to be functional within the network. Despite ALL the information I had reviewed on the Internet, on Linksys' Support Site, etc., this was the fix:

In Linksys Security Settings, under "Internet filters" there is a checkbox called "Filter multicast." This box is UN-checked by default from Linksys. Check the box, and it ALLOWS Multicast traffic - against all reasonable assumption.

Thank you, Dale - loving my Sonos now!



It's good to hear your system is working. I'll send your thanks along to Dale.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings