Issues with Sonos 5.1 sound output

  • 20 January 2018
  • 4 replies
  • 2025 views

I'm having too much troubles configuring Sonos 5.1. I have a PlayBar connected to TV (Sony Sony KD-65S9005B ) that supports (DOLBY®️ DIGITAL / DOLBY®️ DIGITAL PLUS / DOLBY®️ PULSE). I have also a sub and 2 play1's connected all to eachother and as sourround speakers. The problem is i have this setup for more than 1 year but i have never experienced 5.1 sound. Eventhough the audio settings in tv are set to Dolby Digital . I have tried playing special movies 5.1 using usb, played video's in youtube, connected my laptop to tv using hdmi and trying to play some 5.1 content . When i connect my laptop to my TV , my laptop sees that audio output through the tv and i can chose for stereo or Dolby Digiatal 5.1. So i chose DD5.1 and when i test the speakers all the sound (from rear speakers) comes through the front speakers. When i test SUB it doesn't do anything. Is there anyone who can recommend me something what i can do please!!! I'm now very disappointed in my setup.

P.s. i have tried every time checking in SONOS app for audio input: at most of time it is stereo but the maximum that i ve got from it was Dolby Digital 2.0 .

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

OK, I'll give it a shot.

Your TV should be set in the audio settings to DOLBY DIGITAL. Not DD Plus, or Pulse. Make sure that it's locked down to just Dolby Digital.

You say you've played USB movies. I'm assuming that you've connected a USB drive to the TV's USB port? Have you double checked that the movies themselves are in 5.1?

How have you connected your laptop to the TV? There are some sound cards that will play 5.1 on the laptop, but not send it out to other devices. It might be worth double checking the data on the sound card that you're using, to make sure it really outputs Dolby Digital. In fact, even checking the sound settings for your sound card might be worthwhile.

Do you have any other inputs to the TV? Cable box? DVD player?

The easiest way to see what the PLAYBAR is receiving from the TV (while the TV is sending something) is to open up the Sonos app, click on the three dots at the bottom (... you may need to swipe down from the top to see them), then click on settings, and finally click on About My Sonos System. In the bottom box, you will see a list of all of your connected speakers. Find the area for the PLAYBAR, and in that section, third up from the bottom will be "Audio In". That's where it will tell you if the signal being received by the PLAYBAR is either Stereo, or Dolby DIgital 5.1

Honestly, if i were you, I'd be hooking a DVD player to my TV and testing with a DVD first. Or maybe a cable box. There's enough potential issues with your current sources that I'd want to make sure that the Sonos system is working properly, before moving on to troubleshooting the USB or computer connections.

Hope this helps.
Userlevel 3
Badge +3
I bet any amount the sources you downloaded onto your USB aren't proper 5.1. Most of the stuff you download onto your UBS stick will be in 2.0 format, YouTube only does stereo. Can you try Netflix or Amazon Video? Sony TVs are fine to pass through 5.1 via Optical so your TV can definitely do it, we just need to play with the settings.
I have a Samsung TV with TruSurround XT and I too have never experienced 5.1 sound through my Sonos Soundbar and two Play 1s. What gives?
First, I’d turn off the TruSurround XT, it would likely just add latency to the signal going out through the optical port. Then I would double check the other settings on the TVs audio settings, to make sure that it is passing Dolby Digital only to the optical port. Finally, I would check the audio settings on each device that you have connected to the TV to be sure that each device is passing only Dolby Digital to the TV over the HDMI.

You can check in the Sonos controller app under “About my Sonos system” to see what the PLAYBAR thinks it is getting in terms of a signal. On the line under the room name, ipthere would be Audio In: followed by either Stero or Dolby Digital 5.1. If it doesn’t show the latter, go back and check the audio settings again.

Important to note that on many TVs settings, Dolby Digital will be grayed out ( not selectable) if what is currently playing is only in Stereo, so make sure that while your looking at these settings, you’re watching a movie or smoother show that you’re sure is in the Dolby Digital format.