Answered

How to set up a NAS drive with Sonos?

  • 12 April 2018
  • 34 replies
  • 29273 views

How to set up NAS drive with Sonos?

I have a Sonos Playbar and a Play 5 and want to set up a NAS drive to serve up the music, instead of coming off the iMac, which is how it is been done at the moment.

Just bought a Synology DS115j 2TB NAS drive.

Question: what is the best server software to install on it i.e. Twonky, Minimserver etc?

What is the procedure/instructions for installing said software and how do I set it up as a NAS drive to use with Sonos.

Any pointers or advice will be much appriciated.
icon

Best answer by jgatie 12 April 2018, 17:12

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

Badge +1
Thank you all for your great help. No matter all the obstacles put in front of me by Apple (long complex naming regime) and Asustor-the NAS (insisting since it was an Apple computer I must use AFP not SMB) you have successfully given me the tools to fix my problem. I got a small HDD stuck it in the USB port on the router, shared it, dumped all my music on there and viola!! It hooked up as an SMB drive using the router's IP address, Sonos Controller found it as a networked drive without any problem, Apple's Finder (Explorer equivalent) had completely lost sight of my NAS (no great loss really) but I was able to work around that. I haven't tested it to see if I can operate Alexa (with My Media) when the computer is switched off, but I live in hope. I the mean time I will enjoy my music. Thanks again.

K
Userlevel 7
Badge +21
Can't you set up another sharing point? Call it something short.

Another option, set up an alias in your DNS server with a short name for the NAS.

IP isn't a bad thought either.
Badge +1
That a great idea. I will try tho smb May stump me. I’ll post success or otherwise
Thanks for having a go at my problem. Much more help than Customer Service provides. However I have read the FAQ and well aware the Apple/ASUSTOR generated name is a problem but to remedy the naming I would have to find and change years worth of references to the NAS just because Sonos can't find it. I asked the "Customer Service" about a connected USB drive connected to the Mac (named Macintosh) not being recognised or even if I could hook one up to the router. They deferred to your reply to me. Thanks for the help but I am gobsmacked by the lack of support from those paid to provide it.
I don’t know the NAS, but to get around the netbios name you can simply use the IP address instead... however I think you need to enable SMB v1 on the NAS for Sonos to be able to work with it.
Badge +1
Thanks for having a go at my problem. Much more help than Customer Service provides. However I have read the FAQ and well aware the Apple/ASUSTOR generated name is a problem but to remedy the naming I would have to find and change years worth of references to the NAS just because Sonos can't find it. I asked the "Customer Service" about a connected USB drive connected to the Mac (named Macintosh) not being recognised or even if I could hook one up to the router. They deferred to your reply to me. Thanks for the help but I am gobsmacked by the lack of support from those paid to provide it.
Userlevel 7
Badge +21
Looks like the computer name may be the issue, length and the space.

afp://ASUSTOR (AFP)._afpovertcp._tcp.local/Public/Music/

From the link above: Troubleshooting tips

SMB requires that the computer name is no more than 15 characters, with no special characters or spaces. Make sure your NAS drive's name is not too long. Consult with the manufacturer for information on how to change the NAS drive name.

And from the Mac sharing FAQ:

Special characters include the following: < > ; : ' " * + = \ | ? ,
Badge +1
https://sonos.custhelp.com/app/answers/detail/a_id/79 was the link in the first answer. Your link works thanks
I am using a mac and the structure of the location is substantially different afp://ASUSTOR (AFP)._afpovertcp._tcp.local/Public/Music/ than what is asked for \\Mynetworkstorage\shared\music. I do note that Sonos has adopted the apple format for helping "Follow the in-app instructions to complete the setup" If that actually worked I wouldn't have to make these enquiries. I'll try and figure out where to get a help ticket and Post the result so the next poor schmuck with a mac and a NAS doesn't have to go through this . Thanks again for the working link. Oh somewhere along the line somebody suggest chageing the name of the ASUSTOR etc to something shorter and without the extra spaces and such. That means I would have to change by hand every reference to the ASUSTOR. Not a valid solution.
Not sure what link you’re talking about, but here is what I found when I went to the Support link above, and the typed NAS setup in the search field

https://support.sonos.com/s/article/78?language=en_US

Does that link not help?
Badge +1
I don't think anyone successfully answered. The link that may have helped is dead. I cannot believe that Mac users have a seamless integration with sonos considering the trouble I am experiencing. What is the solution? without the pendant stuff, resorting the Apple the standard answer, or grand gestures to let me know what a newb I am, please tell me how I am able to access my music library on a NAS connected to a newish Mac desktop using a sonos beam. Sonos simply will not do it straight out of the box.
Userlevel 7
Badge +21
If you want to try something really neat with your Pi, turn on the VNC Server (Pi Configuration, Interfaces tab) and be able to connect to your Pi from any machine that supports a VNC client. That allows you to put your Pi anywhere you can feed it power, no keyboard, mouse or monitor are needed.

If you have good WiFi you could even try using the PI's WiFi to connect instead of the Ethernet option, you'd only need to supply power then.

I'm very happy with the Pi as a Sonos music server, it sits on a shelf working away with no babysitting needed on my part. I do run updates once a month and reboot if they require it.
Badge
That's great - i think it's the ntlm auth = yes that did it. I had tried that earlier but probably had something else wrong. Thank you.
Userlevel 7
Badge +21
Snips from my /etc/smb.conf I don't have your protocol settings in my file.

[global]
# enable v1 authentication for Sonos access
ntlm auth=yes

[music]
Comment = Pi shared folder
Path = /mnt/ssd-music
Browseable = yes
Writeable = Yes
only guest = no
create mask = 0555
directory mask = 0555
Public = yes
Guest ok = yes


I did a hard mount by UUID in my /etc/fstab to keep the USB auto-mounter from moving the drive around at boot time. Here is the line I used for my xfs formatted drive and notes about working around not knowing the UUID.

# UIUID notes about my drive
#PARTUUID="54285699-bf0c-4f92-b846-082114177b6b" is the whole drive
#PARTUUID="d450bd65-603d-4e13-8b32-41ed9ea3e354" is sda1

# actual mount line in use:
PARTUUID="d450bd65-603d-4e13-8b32-41ed9ea3e354" /mnt/ssd-music xfs defaults,auto,users,rw 0 0

# If UID mount fails this will work until you can fix it
#/dev/sda1 /mnt/ssd-music xfs defaults,auto,users,rw 0 0
Badge
Here is global setting that i have that doesn't work:

# For SONOS
max protocol SMB1
client max protocol SMB1

Here is share-specific setting:

[music]
comment = My Music
path = /media/usb-music
valid users = @users
force group = users
create mask = 0660
browsable = yes
directory mask = 0771
read only = no
guest ok = yes
guest account = nobody
Badge
I am trying to figure this out myself. I have a WD USB drive connected to my RP3b+. I have configured SMB via posts i have seen. I can connect from my Mac and scan the music files. When I try to connect Sonos it says I can't authenticate. Does someone here have this setup and can provide an SMB conf that works?
Userlevel 7
Badge +21
SMBv1 is needed by Sonos if you don't want to use some form of third-party server software. Your NAS doesn't need to be (and shouldn't be) accessible from the internet. While that doesn't prevent attacks where you download something nefarious to your computer and it starts spreading around your network, it doesn't mean that the world will be able to access your NAS just because you enabled SMBv1 on it. If your router/firewall is worth its salt, no one on the internet will be able to access your NAS unless you add a port forward or firewall rule allowing them to.

As far as your Shodan search of Sonos... yes, those are incompetent users who have either placed their Sonos devices directly on the internet with no firewall, in their router's DMZ zone, or are setting up port forwards for Sonos' UPnP port (1400) on their router/firewall, allowing it to be accessed directly from the internet. None of these is necessary for Sonos to work properly. This is also the reason that Sonos removed a significant amount of helpful technical info from their device web pages.
Cheers guys
Userlevel 7
Badge +22
Yea if your worried about security (which the op has not expressed) just put music on it only. Someone hacking you Micheal Jackson playlist isn’t the end of the world.
Userlevel 7
Badge +21
Sonos doesn't need much of a NAS to serve up your music so if you are concerned about SMB v1 you can add a cheap NAS to serve up copies of your music files. A Raspberry Pi works, a WD Live drive works.
Userlevel 7
Badge +22
One of great things with Sonos is the nas doesn’t have to run any server software. Sonos will do all that for you.
Userlevel 7
Badge +22
Yes follow jgatie advice second post and let us know any questions. It’s an easy setup.
OP back. Still looking for my answer ;)

Second post.
OP back. Still looking for my answer 😉
Hopefully the original poster got his NAS setup despite all the tin foil in this thread

Yes. To the OP, ignore the nonsense. Keep your NAS and computers updated and you can sleep at night, despite the sky-is-falling posts.
In fact, all the lolz



What does this even mean?
Userlevel 7
Badge +22
Hopefully the original poster got his NAS setup despite all the tin foil in this thread