Answered

How to set up a NAS drive with Sonos?



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

Badge +1
I don't think anyone successfully answered. The link that may have helped is dead. I cannot believe that Mac users have a seamless integration with sonos considering the trouble I am experiencing. What is the solution? without the pendant stuff, resorting the Apple the standard answer, or grand gestures to let me know what a newb I am, please tell me how I am able to access my music library on a NAS connected to a newish Mac desktop using a sonos beam. Sonos simply will not do it straight out of the box.
Not sure what link you’re talking about, but here is what I found when I went to the Support link above, and the typed NAS setup in the search field

https://support.sonos.com/s/article/78?language=en_US

Does that link not help?
Badge +1
https://sonos.custhelp.com/app/answers/detail/a_id/79 was the link in the first answer. Your link works thanks
I am using a mac and the structure of the location is substantially different afp://ASUSTOR (AFP)._afpovertcp._tcp.local/Public/Music/ than what is asked for \\Mynetworkstorage\shared\music. I do note that Sonos has adopted the apple format for helping "Follow the in-app instructions to complete the setup" If that actually worked I wouldn't have to make these enquiries. I'll try and figure out where to get a help ticket and Post the result so the next poor schmuck with a mac and a NAS doesn't have to go through this . Thanks again for the working link. Oh somewhere along the line somebody suggest chageing the name of the ASUSTOR etc to something shorter and without the extra spaces and such. That means I would have to change by hand every reference to the ASUSTOR. Not a valid solution.
Userlevel 7
Badge +21
Looks like the computer name may be the issue, length and the space.

afp://ASUSTOR (AFP)._afpovertcp._tcp.local/Public/Music/

From the link above: Troubleshooting tips

SMB requires that the computer name is no more than 15 characters, with no special characters or spaces. Make sure your NAS drive's name is not too long. Consult with the manufacturer for information on how to change the NAS drive name.

And from the Mac sharing FAQ:

Special characters include the following: < > ; : ' " * + = \ | ? ,
Badge +1
Thanks for having a go at my problem. Much more help than Customer Service provides. However I have read the FAQ and well aware the Apple/ASUSTOR generated name is a problem but to remedy the naming I would have to find and change years worth of references to the NAS just because Sonos can't find it. I asked the "Customer Service" about a connected USB drive connected to the Mac (named Macintosh) not being recognised or even if I could hook one up to the router. They deferred to your reply to me. Thanks for the help but I am gobsmacked by the lack of support from those paid to provide it.
Thanks for having a go at my problem. Much more help than Customer Service provides. However I have read the FAQ and well aware the Apple/ASUSTOR generated name is a problem but to remedy the naming I would have to find and change years worth of references to the NAS just because Sonos can't find it. I asked the "Customer Service" about a connected USB drive connected to the Mac (named Macintosh) not being recognised or even if I could hook one up to the router. They deferred to your reply to me. Thanks for the help but I am gobsmacked by the lack of support from those paid to provide it.
I don’t know the NAS, but to get around the netbios name you can simply use the IP address instead... however I think you need to enable SMB v1 on the NAS for Sonos to be able to work with it.
Badge +1
That a great idea. I will try tho smb May stump me. I’ll post success or otherwise
Userlevel 7
Badge +21
Can't you set up another sharing point? Call it something short.

Another option, set up an alias in your DNS server with a short name for the NAS.

IP isn't a bad thought either.
Badge +1
Thank you all for your great help. No matter all the obstacles put in front of me by Apple (long complex naming regime) and Asustor-the NAS (insisting since it was an Apple computer I must use AFP not SMB) you have successfully given me the tools to fix my problem. I got a small HDD stuck it in the USB port on the router, shared it, dumped all my music on there and viola!! It hooked up as an SMB drive using the router's IP address, Sonos Controller found it as a networked drive without any problem, Apple's Finder (Explorer equivalent) had completely lost sight of my NAS (no great loss really) but I was able to work around that. I haven't tested it to see if I can operate Alexa (with My Media) when the computer is switched off, but I live in hope. I the mean time I will enjoy my music. Thanks again.

K