Answered

Help - cannot add Sonos One & Beam to Alexa or see in Spotify

  • 26 December 2018
  • 4 replies
  • 651 views

Hey all,
I have 2 Sonos speakers, one and a beam.

Issue 1: I cannot seem to setup Alexa
I have installed both the devices and got them playing music and connected to my TV/Spotify, however when i try and add the voice services, with Alexa, i get the following issue:

"Add your Sonos speakers to your account
You need to link speakers to jamiepryer@hotmail.com before you can add this skill.

Go to More > Settings > Sonos Account in the Sonos app to link your speakers. (If you don't see Sonos Account, your Sonos system needs an update.)"


now when i open the Sonos app on my mobile, i DO NOT see "More -> Settings -> Sonos Account", i do however see "More -> Settings -> Account Settings" which shows my email? not sure if these are the same or if this is the issue?

Things ive checked:
- im using the correct email and its the same between Sonos and Alexa.
- my address is populated on sonos.com website
- my account on sonos.com, with my correct email, is showing both devices
- ive rebooted my router, modem and wifi etc..
- ive unplugged both Sonos devices and tried those again
- ive changed the names of both rooms to something unique so they dont get mixed up with common "bedroom" names
- when i try and "discover" devices within Alexa, i dont see either app appear either


Issue 2: I cannot seem to see Sonos speakers within Spotify, even thought they are linked and setup properly. Eg. if i go to the Sonos app, i am able to play spotify music. Plus, using my IphoneX, i can see the speakers with AirPlay. I just cant see them within "devices" from Spotify?
icon

Best answer by JamieP83 27 December 2018, 10:32

found the issue, my MTU was too high, changed down to 1370 on my nighthawk, which resolved all issues
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

not sure, but if this helps, by going to:http://192.168.0.xx:1400/tools.htm

ping
running /bin/ping -c 3 sonos.com
PING sonos.com (104.98.128.44): 56 data bytes
64 bytes from 104.98.128.44: seq=0 ttl=57 time=32.523 ms
64 bytes from 104.98.128.44: seq=1 ttl=57 time=33.282 ms
64 bytes from 104.98.128.44: seq=2 ttl=57 time=32.751 ms

--- sonos.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 32.523/32.852/33.282 ms



ping6
running /bin/ping6 -c 3 sonos.com
ping6: bad address 'sonos.com'


traceroute
//doesnt show anything


traceroute6
running /bin/ping6 -c 3 sonos.com
ping6: bad address 'sonos.com'

nslookup
sonos.com: dns (27 ms) -> 104.98.128.44 mdns (0 ms) -> failed netbios (0 ms) -> failed


MDNS Announce
Success
Userlevel 7
Badge +22
The should all show in spotify as both Spotify Connect Devices and under other as Airplay devices.

Have you gone into your Alexa app and installed the Sonos skill and asked Alexa to discover your Sonos devices then.

Do you have spotify setup as a service inside the Sonos app - - settings + Add music services.
I can’t setup the skill in Alexa - when I try that, I keep getting an error that I don’t have any devices associated to my account (issue 1)
found the issue, my MTU was too high, changed down to 1370 on my nighthawk, which resolved all issues