Existing Sonos System Now Won't Connect - Please Help!!

Hi everyone,

I am having a huge problem with my existing Sonos system, which was previously working fine in our house. Please forgive my lack of technical knowledge, I will do my best to explain properly. The system was originally made up of 2 x Connect:Amps in our downstairs living room (one for the living room and one for the patio outside) and a Sonos Control (the old handheld controller) also in the living room. The Connect:Amp's are hardwired into our house which has a StarServe system that I believe connects everything. The internet modem/router is in the garage plugged into the StarServe and everything else just plugs into the wall wherever data points are in the house and gets internet access from there - voila! Music library is accessed from our home computer which is in the upstairs study - I have no real idea how this connection works, the computer is also plugged into wall and accesses internet from the Starserve.

All was working fine until our Control started to get dead spots on the screen and became super hard to use. We then decided to try and start using our phones and/or iPad as the controller, but were unable to get them to connect. We have tried an iPhone, an Android and an iPad, all just sit on the same screen forever which says "Connecting to your wireless network..." and nothing happens. All were in range and everything else in the network was connecting fine so I can't figure out why they can't. We tried and tried to get this to work restarting the system, the but eventually just gave up and kept using the crappy old Control where possible and otherwise having to run upstairs to our computer to use the Desktop Controller for other things.

We don't keep our Connect:Amps on at all times as they seem to get require a fair bit of power, so we switch them off at the wall when not in use. This has never been a problem before and everything has always connected straight back up when turned on - however just recently when we turned everything on it decided not to talk to each other anymore and now nothing is connected. We can't get the Controller or the computer or the Connect:Amp's talking, and still no joy with the contoller apps either. We have tried everything I can think of, soooooo many hard restarts of every component and nothing is working.

My hubby went to talk to someone at Videopro and they decided it wasn't working anymore because the Controller is dead and apparently we need a Bridge to get everything talking again... however I really don't understand this as they also told him it should be set up wirelessly and we have never had everything wireless, it's always plugged into data points in the house. Anyway, they sold him a Bridge which we have tried installing both wirelessly and wired, it's current plugged into the internet modem/router and the Starserve in the garage with everything else but still nothing is working.

After reading a lot of posts on the internet I am guessing it may be something to do with IP addresses or something like that, but that's pretty much as far as I understand it and I can't work out how to troubleshoot it. I can't even figure out what the IP addresses of each component are as I don't have access to the Desktop Controller interface anymore to look at the components. We are not super technical people so this seems way beyond our capabilities. I feel like I may need to actually hire someone to come out and look at it but no idea who even does that sort of thing or where to find them!

I'm sorry if this is a redundant topic, I have honestly tried everything I can think of to fix this problem on my own and have trawled through the Forums here and elsewhere looking for answers, but I couldn't find any situation exactly the same as mine and nothing I've tried has worked.

I am seriously at my wit's end, I have no idea where to go from here and would appreciate anyone's assistance.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Welcome to the forums.

I'm sorry to say that the person at Videopro has not given good advice. The fact that the CONTROL is on the blink has nothing whatsoever to do with the fact that your Desktop Controller can't see the players. The Bridge you've been sold is superfluous.

Videopro saying the system has to be set up wirelessly is also totally inaccurate. Wired is always best if it's feasible to do so.

You clearly have multiple problems at present, but they're distinct and unrelated.

The touchscreen problem on the CONTROL has been well documented. It affects just that device.

Your inability to connect to the CONNECT:AMPs has the hallmark of duplicated IP addresses. This is usually caused by a router having been power-cycled, then a Sonos unit subsequently booted (or rebooted). What happens is that the router loses its memory of which addresses it's allocated to what, and the Sonos unit picks up an address which is already in use. This causes endless confusion at a network level.

Tedious as it is, you'll have to find every active device on your network and power it off. Make sure you include all mobiles etc. Then restart each device in order:
- router
- wired Sonos devices
- wireless Sonos devices
- everything else

Wait for each device to reboot fully before moving to the next. Once done, you should be clear of IP duplicates.

On the question of your inability to associate iDevice/Android controllers with the system, it sounds like your router and/or WiFi access points are blocking the broadcast traffic which Sonos controllers use to discover the players. This is not uncommon. Can you identify the make/model of router and any additional access points?
Thanks for the welcome and for all the info. I am pretty sure I have already restarted absolutely everything but maybe I didn't do it in the right order so I will try again.

The modem/router is a Cisco DPQ3925. We have about six data points throughout the house which run off it, but all we have plugged in currently is the two CONNECT:AMPS, our home computer, and now the BRIDGE.
cc_bob wrote:

The modem/router is a Cisco DPQ3925.

There's your problem. The DPQ is one of those that feature in the hardware compatibility guide.

You'll need to turn off the WiFi on the DPQ and invest in one or more separate WiFi access points.
Wow ok. So is this likely to be what is causing all my problems, or just the iPhone/iPad connection?

I have been able to turn off the Wifi on my Cisco, but I have no idea about setting up a wireless access point. Is there a specific product that you could recommend which will be compatible with Sonos?
OK, wireless has been disabled and all components are now hardwired through the datapoints. I have done the restarts in the sequence suggested and it is still not working.

Have discovered that through My Computer under Networks I can still see the two Sonos AMPS (including their IP addresse), but when I open the Sonos program it takes me to Setup Assistant which still doesn't detect them, so I can't get through to the Desktop Controller. Also with what little usability the busted CONTROL has, it can still detect the two AMPS and their Zones, but when you try to play music it says "Cannot connect to HOMECOMPUTER" (1002). Does this provide any more clues?
The iPhone/iPad problem is distinct, and is related to the Cisco DPQ. Alternative access points are plentiful, Netgear for example.

I know for sure that the Edimax EW-7416APN works well. However it defaults to 40MHz channel width (300Mbps) and even though your Sonos is full wired you still ought to change its channel width to 20MHz to avoid hogging the 2.4GHz spectrum.

The difficulties you're having with the Desktop Controller and playing music from 'HOMECOMPUTER' are due to continuing network connectivity issues. If you've really done the full restart of everything on the network (incl mobiles etc), then one starts to suspect a firewall problem. Have you tried disabling it?
I have same problem as above but apple phone iphone 6S plus connects fine but not mu Samsung Galaxy 7 after 8.1 update.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings