Answered

Does anyone know the technical details of how Sonos actually works??


I have a stable and good performance wifi network at home. 4 Ubiquiti access points, all connected back to a router connected to fibre. Fibre connection is 300MB up and down. All fine.

Then add 3 off Sonos Play to give streaming radio around the house. Oh mine what a pain this Sonos is.

Everything works one day. Sonos app on the phone works great, Sonos app on Macbook works great. Then it all stops. Nothing works. What is going on this the Sonos?

I keep a permanent ping to all three Sonos Play units so I know the IP connectivity is all good. I can ping them all. However, the phone app can't find anything. The Macbook can't.

I have to reset everything and start again from scratch. What a pain - does anything know what the Sonos are actually doing, given the IP is all good, what are they doing?

I am very close to giving up, any suggestions what to replace the 3 Sonos units with?
icon

Best answer by ratty 7 July 2019, 12:24

If you want to force mixed mode operation:
  • re-enable the wireless on SP1
  • bring SP2 and SP3 to within range of SP1 and power them up
  • make sure all show in the controller (they should all be WM:0 at this point)
  • go into Advanced Settings/Wireless Setup and reconfirm the WiFi details
  • wait 30 seconds
  • power off SP2 and SP3
  • disable the wireless on SP1
  • take SP2 and SP3 to the remote area and power them up
  • you should see WM:0 for SP1 and WM:1 for SP2/3 in About My Sonos System
View original

23 replies

Make sure that multicast traffic is not blocked in any way. Sonos players and controllers must share the same broadcast subnet. Controllers use SSDP multicasts to discover the players.

Note that if the Sonos is connecting to multiple access points, the recommendation is that they be set to the same channel. See Setting up your Sonos system. This is for optimum performance in groups.

Alternatively, wire one Sonos unit to the network. This will make the system operate in SonosNet mode, using its own wireless mesh.
Userlevel 7
Badge +21
Sounds like you might be using Standard Mode for your Sonos (none wired) that comes with a lot of restrictions on multiple AP setups. I don't remember them all but the Sonos support FAQ probably has them all listed.

I looked at that a few years back and realized Boost Mode (one or more wired) was going to be far less frustrating and not restrict what I could do with my home WiFi by limiting me to the options that work with Sonos. I'd recommend you switch to Boost Mode too, either wire one of your Sonos or pick up a Boost and skip all the frustration.
Thanks every one. I have expected that might be the answer. I can easily get one of them onto the LAN and so that might help from what you all say.

I will add one to LAN and see what happens
Ok. I have added a first Play to the LAN with ethernet. All connects just fine of course.
Can see it on iphone Sonos app and confirm the mode is "wm:0" eg; wired

Then I go to the other end of the house to add a second Play on the WiFi. I can ping everything so IP connectivity is there. However it will not connect to the other Sonos. Nothing on app and can not add.

Surely I don't have to wire all of the Sonos Play in?
What is the point of the WiFi connection if it can't work across IP?

Am I still misunderstanding how this works?
No wonder the forums are full of people who can't keep this all working
Your Sonos units will only be able to connect over SonosNet if they are actually within range of one another.

Even if a player couldn't mesh via SonosNet, but it could see a known WiFi signal, there should still be a connection. The fact that the units are pingable -- presumably all on the same subnet -- bears this out.

I suspect that your Ubiquiti kit may need to be configured to forward multicast traffic. There have been many related reports over the years.

By the way, considering the millions of Sonos customers the people who post here with connectivity problems are a tiny fraction. It's unwise to judge the health of a general population by those one finds in a hospital.
Userlevel 7
Badge +21
The Standard Mode Sonos WiFi is designed for very simple networks, you might get it working long enough to get your Sonos all moved to Boost mode by powering down all but one AP and rebooting the Sonos gear. That eliminates many possibilities that Sonos does not deal well with.

Probably easier to run a temp Ethernet connection to each device, reboot it and let it wake up in Boost mode. Once all are in Boost mode go in and remove your WiFi credentials from the Sonos and power back up your other APs.

There may well be a better way to do this but until one comes along this should work. I still have my 100 foot Ethernet cable I picked up to do this with my Sonos, haven't needed it since.
Userlevel 7
Badge +20
I suspect that your Ubiquiti kit may need to be configured to forward multicast traffic. There have been many related reports over the years.
This may help: https://help.ubnt.com/hc/en-us/articles/360001004034-UniFi-Best-Practices-for-Managing-Chromecast-Google-Home-on-UniFi-Network#enable

I'd unwire the wired speaker and try this first.

Am I still misunderstanding how this works?
You're getting there, but the details can be subtle for SonosNet/Boost/Wired mode. For Standard/Wireless mode the situation is usually simpler, but complex mesh WiFi networks introduce additional possibilities for network misconfiguration.

No wonder the forums are full of people who can't keep this all working

As ratty stated, the vast majority of Sonos installations just work. It's a tiny fraction of Sonos customers who even visit this forum, let alone report connectivity problems.
So I had it all working for about a week.
One Sonos Play connected to the LAN, two Sonos Play working on WiFI.
Was all good.

Now the two WiFi connected Sonos have disappeared and will not connect to anything.
LAN connected on still works just fine. The two "wifi" connected ones won't connect to the wifi any more.

This is so temperamental. Time to start again and reconfigure everything....again.
Very frustrating system this.
Can someone give me a foolproof way to install this?
Assume the following:
  • The 3 Sonos Play will **not** be able to see each other wirelessly as they are too far apart
  • 1 of them is currently installed on the LAN and working fine
  • The other 2 will be installed from scratch and must only use WiFi after setup (no LAN after setup)
  • There is very good WiFi everywhere and 300MB up and down Internet
How should I install and configure the 2 "new" Sonos Play?
So I had it all working for about a week.
One Sonos Play connected to the LAN, two Sonos Play working on WiFI.
Was all good.

Now the two WiFi connected Sonos have disappeared and will not connect to anything.
LAN connected on still works just fine. The two "wifi" connected ones won't connect to the wifi any more.

This is so temperamental.

It will be. You're trying to force the system into 'mixed mode'. This can easily be unstable, as WiFi-connected units will be trying their best to seek out a SonosNet connection. Even if mixed mode holds up, the units are likely to be on different channels, potentially compromising group performance.

  • The other 2 will be installed from scratch and must only use WiFi after setup (no LAN after setup)

Why must they use WiFi? Could you not purchase a Boost and wire it to Ethernet connection somewhere within range? For example on the nearest access point, which you said was in turn wired back to the router?

Alternatively simply place a Boost -- connected only to power -- somewhere roughly halfway between the two WiFi-connected units and the wired Play. It could then act as a relay.
SonosPaul,

With one player connected to your LAN, you’re running the Household on SonosNet. Did you go onto remove your WiFi credentials in the “Advanced Settings/Wireless Setup” of the Sonos App? ... that will stop your speakers switching between SonosNet and your WiFi.

Ensure you set your Ubiquiti WiFi to all use the same fixed channel as mentioned by @ratty if that’s possible to do with that system.

Then set the SonosNet channel (in Advanced Settings) at least 5 channels away from the chosen ubiquity 2.4ghz channel.

Hope that fixes things for you.
Ah @ratty beat me to it. A boost would likely help.
Ubiquiti access points have adjustable RF output power. It seems counter intuitive, but it is usually best not to use maximum power. At full output power a client could lock on to an access point signal, but not have enough power to return communication to the distant access point. By reducing the Ubiquiti output you will force the client to use a closer, more appropriate access point. Phones/Pads are often caught up in this sort of drama because they will not give up a distant access point after the portable device is moved to another area. If you are using a Ubiquiti CloudKey, there is quite a lot of historic data available that can be used to troubleshoot connections.
@Ken_Griffiths If I remove the WiFi credentials then how will they use SonosNet when they are too far apart to see each other?

I think SonosNet is all part of the problem - and as several of you have said this mixed mode.

I would like to just use plain old WiFi - is that possible? No?
Userlevel 7
Badge +20
I would like to just use plain old WiFi - is that possible? No?
Yes — just disable the wireless radio for all wired Sonos devices. It’s under ‘Advanced Room’ settings for each ‘room’.
@Ken_Griffiths If I remove the WiFi credentials then how will they use SonosNet when they are too far apart to see each other?

I think SonosNet is all part of the problem - and as several of you have said this mixed mode.

I would like to just use plain old WiFi - is that possible? No?

The ubiquity router/hubs will all need to be on the same WiFi channel and just uncable your Sonos device. Obviously you need to ensure the WiFi credentials in that case are stored in the Sonos App.

Personally I would go with SonosNet and buy a Boost and stick your current cabled speaker as “the man in the middle” device.
Ok guys thanks.
This is starting to make some sense to me now.
I will give it a bit more of a play and then if I still have issues I will get a Boost.

I would like to just use plain old WiFi - is that possible? No?Yes — just disable the wireless radio for all wired Sonos devices. It’s under ‘Advanced Room’ settings for each ‘room’.

This will stop WiFi-connected units from attempting to mesh with the wired ones over SonosNet, and could stabilise mixed mode operation, but using multiple APs in WiFi mode is not hugely recommended.
Userlevel 7
Badge +20


I would like to just use plain old WiFi - is that possible? No?Yes — just disable the wireless radio for all wired Sonos devices. It’s under ‘Advanced Room’ settings for each ‘room’.
This will stop WiFi-connected units from attempting to mesh with the wired ones over SonosNet, and could stabilise mixed mode operation, but using multiple APs in WiFi mode is not hugely recommended.

Doesn’t this just effectively disable SonosNet? That’s my observation, with multiple APs. I’ve used this configuration quite successfully, as long as the WiFi infrastructure is solid.
SonosNet is formally disabled in WiFi mode (and STP is inactive), but the peer-to-peer connections are still available for the audio stream within a group ... unless the peers are tuned to different channels.
Starting from scratch.
Let me check I have this right.

I have SP1 connected via LAN, with wireless disabled via Room Settings.
When I check on the app I see:
Associated ZP: 192.168.1.50
SP1
IP:192.168.1.50
WM:0

That is a single SP with SonosNet disabled. Correct?

What is the correct way to add SP2 and SP3?
With or without LAN connection - even though I want to use normal WiFi?
If you want to force mixed mode operation:
  • re-enable the wireless on SP1
  • bring SP2 and SP3 to within range of SP1 and power them up
  • make sure all show in the controller (they should all be WM:0 at this point)
  • go into Advanced Settings/Wireless Setup and reconfirm the WiFi details
  • wait 30 seconds
  • power off SP2 and SP3
  • disable the wireless on SP1
  • take SP2 and SP3 to the remote area and power them up
  • you should see WM:0 for SP1 and WM:1 for SP2/3 in About My Sonos System
Thanks everyone for the help. I am now up and running in "mixed mode:

I have:
SP1 on LAN WiFi off WM:0
SP2 on IP WiFI WM:1
SP3 on IP WiFi WM:1

So far so good, and anyway I actually understand what is going on now :-)
Thanks all

Reply