Answered

Connecting Yamaha Music Cast Vinyl 500 to Sonos Port

  • 15 September 2021
  • 5 replies
  • 37 views

Hey 👋 

Ok, so I’ve recently bought the Yamaha MusicCast Vinyl 500 turntable. 

I realised I’d need the Sonos port to connect the to my Sonos system, (2 x SL one & 1x one)
the trouble is, I’m getting nothing. 

On the S2 app the cable looks like it’s connected, but I get zero sound when I press play on the turntable and through the S2 app. 
 

As far as I’m aware the turntable has a built in amp. 
 

Any tips or help would be amazing. 

icon

Best answer by melvimbe 15 September 2021, 18:14

The first place I’d look is to make sure you select the Port’s line-in as the audio source for your Sonos speaker(s).  If that’s all set correctly, then I would make sure your turntable is set to output through the RCA line output.  Since it has phone output and music cast output...that’s not a given.

 

 

View original

5 replies

The first place I’d look is to make sure you select the Port’s line-in as the audio source for your Sonos speaker(s).  If that’s all set correctly, then I would make sure your turntable is set to output through the RCA line output.  Since it has phone output and music cast output...that’s not a given.

 

 

I’d also double check that the ‘built in preamp’  is actually turned on, as it likely can be switched between on and off, depending on what device the Yamaha can be connected to. 

Hey,

 

I checked that and switched it over to the correct setting. 
 

I don’t know if it’s an issue with the port or the turntable 😫

Easiest way to test the Port is to connect almost any other device like a CD player, DVD player’s audio out, etc, to the line in port, and see if it works. I expect it will, then you just need to figure out why the LP isn’t working. 

I’m  assuming you’ve messed with the line in sensitivity on the Port?

Userlevel 7
Badge +17

Hi @RCDRJ 

Thanks for your post!

Just to make sure: you are selecting the rooms with Sonos speakers, and not the Port’s room, in the Sonos app and then telling the room to play the Port’s line-in? You don’t want to tell the Port to play anything - that’s for using line-out to a third-party amplifier.

I hope this helps.

Reply