Answered

connecting music library on Synology NAS to Sonos


Badge

I’ve got a new Synology NAS and trying to connect Sonos to the music folder on it. I’ve enabled SMBv1 and tried everything else that I’ve read in the Sonos community and Synology knowledge base. (I used a WD NAS for years with Sonos, BTW)

I’m using a Mac and the path to the music folder is:

//NASsynology/Volume 1/for sonos

(I’ve tried creating a separate folder just called “sonos” thinking maybe it doesn’t like the space in the name; also tried removing the “Volume 1” from the path and/or taking the space out and just calling it “volume1” which is how the name appears sometimes in Synology; also tried the IP address in place of the “NASsynology”...all with no luck)

 

I’m getting an access denied error (telling me to check the ID/password) when using the Synology user-ID/password, as well as when I just skip the ID/password step and just leave it blank.

 

Thanks for any help!

 

 

 

 

icon

Best answer by Stuart_49 1 September 2021, 19:23

View original

10 replies

As suggested in the several threads about this, did you also enable NTML1?

Badge

Thx, I did notice that in other threads, and the best I can tell, Synology doesn’t have a setting for enabling NTMLv1.

If I recall correctly, one of those other threads certainly suggested that it does, but since I don’t own a Synology device, I’ve not searched the online manual for the term NTML to see. YMMV, and it’s entirely possible it’s based on the particular version, although it would seem odd that they don’t all run on the same firmware, but I don’t design NAS devices for a living. 

I’m using Synology and haven’t had any trouble. It was one click to enable SMBv1 and I was off to the races. I will say that the drive is in my face for user/password entry and a little slower at startup than I like.

Badge

buzz, are you simply using the main Synology ID for Sonos that you setup when initializing your NAS? (versus Guest or Admin, for example) Also, on the path name, are you including Synology’s volume? (as in my case it’s “Volume 1”). Thx

In terms of the NTMLv1 that Airgetlam brought up, I did eventually find a doc that Synology removed the option in their latest released software version (v7, the version that’s on my NAS).

I’m using the admin id with the Volume name visible in my Windows Network.

Badge

Just to close with success on this, in case someone else has difficulty with the Synology NAS connection to Sonos as I surely did. There was in fact an additional setting that enables NTMLv1 on Synology (in addition to SMB setting). Thanks Airgetlam for that, I just couldn’t find it anywhere in Synology settings until I got on the phone with Sonos support and they were able to show me where the NTMLv1 enable is. Also, on the Mac at least, the path that worked for Sonos excluded the “Volume 1” qualifier, since that threw an error when I tried to include it.

Hi Stuart_49

I'm having an identical experience (WD to Synology, can’t access, etc).  You mention that setting up NTMLv1 did the trick, but you didn't say where to find that option.

I looked is DSM help but it doesn't mentioned NTML.

It does have SMB but advises against using SMB1 because of security issues.

Should I call Sonos like you did?

Cheers

Peter

 

With respect to the SMB1 security issue, you have no choice but to accept this risk because SONOS requires SMB1. Hopefully, SONOS will start accepting SMB2 or SMB3 in the future.

Also see this link…

https://en.community.sonos.com/advanced-setups-229000/smb1-security-issue-lack-of-response-from-sonos-6860761?postid=16551779#post16551779

Reply