Connecting a Sonos Connect to my Denon AVR-S720W receiver

  • 29 August 2017
  • 8 replies
  • 3472 views

I have connected my Sonos Connect to my Denon AVR-S720W receiver via a digital audio optical cable to TV Audio In. Would have used the Media Player 2 port, but my AppleTV is connected there via HDMI. I cannot get any sound from my stereo speakers. All other rooms and a portable Play3 all work just fine, but can't get sound in my main listening room. Help!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

First, have you confirmed that the optical cable is carrying a signal? i.e. is the end of it shining red before you stick it in your receiver? I've never used a CONNECT's optical out port, so I don't know if there's something in the app that you need to turn on in order for it to work. I would suppose there's something in a FAQ about that, have you checked?

Second, have you selected TV as your source on the receiver?

Is the volume turned up both on the CONNECT and the receiver?
Hey Bruce, yes the cable is glowing red, I have selected TV as input and checked volume on all components. No sound.
Will check the FAQ
Yea, I couldn't find a FAQ either. But it might be worth looking through the app itself to see if there's something in there to turn on the digital output. But you'd think if there was a red light coming out of the cable, then it's on. I'm afraid you've done all the trouble shooting ideas I have, so we'll have to wait for someone who actually uses a CONNECT optical output to weigh in on the issue.

Sorry I wasn't of more assistance. Completely understand your frustration, it sure seems like it should work.

Random thought, there's nothing in the receiver that you have to "switch" to turn on that input, is there? It's an unlikely thing, but it sure seems like it should be working.
Thank you for taking a stab at this. Appreciate it.
Userlevel 2
Badge
This is a case of you need to RTM of the receiver. You need to assign the optical input you're using to something other than the TV input. TV is reserved by the ARC of your TV if you have a TV which provides ARC, and you have HDMI-CEC enabled.

You go into the setup of the receiver, choose an unused source and assign it to the Optical 1/Optical 2 input (whichever you're using).

On a Denon receiver, any input can be assigned to any namedsource, with very few exceptions. The source labels on the back are merely the defaults - but you can choose any input by number in the menu to assign it properly. 🙂
And by RTM, he means Read The Manual....

Thanks, jec6813! Figured it might be something like that, but didn't want to pull up the manual via google myself.
The solution is to go to setup, input, select the right one , then set up ur correct connection mode. I mean optical, rca etc..sorry for my poor english, but hope will help ! 😃