Connect AMP as surround


I am trying to setup a connect AMP for surround speakers with my playbar.

Here is what I have done:
* Connected an ethernet cable from my router to my playbar
* Connected an ethernet cable my playbar to my connect:AMP
* NOTE: Each are in Boost mode (WM:0)
* Added Connect: AMP as surround speakers to my playbar's room so that both components and they show up in "about my sonos system" Playbar: roomname and Connect:AMP room name (LS+RS)

The problem:
* While trying to execute the Trueplay tuning, I got the "lost speaker error" during the first tuning step.

Things I have tried to see if any sound comes out:
* Skipping the tuning step, set source to TV (Audio in: Dolby Digital 5.1) and I did not hear anything coming out of my speakers.
* Trying to play music from Pandora and no audio comes out (assuming something should, but not sure if this is valid)
* Disconnected the surround speakers from the room and played music verifying that the wires were connected properly to my in ceiling speakers and music did come out.

Any thoughts on what is going on?

Thanks

3 replies

Userlevel 7
Badge +22
You can't trueplay tune with a Connect Amp and third party speakers.

Many stations while broadcast 5.1 don't put any sound to the mix. So it can be hit or miss.

Let focus on music. Go into your room settings for the Playbar ...advanced audio...surround settings. Last entry change Music Playback from Ambient to FULL.

Now your music will play in stereo on the surrounds so you can see that they are working properly.
Thanks Chris. It seems weird that if you can't tune with connect amp and third party speakers that it is part of the "add a speaker" setup with connected amp selected. Maybe a potential workflow improvement for Sonos.

When I went into the sonos app for some reason I did not see the Connect amp as part of the system. Not sure if this is the root of the issue because this has been happening to me all day. Any idea why it keeps disappearing from my network? I have been having wifi issues today in a snow/ice storm so maybe that's why.

Anyway, I unplugged it and plugged it back in. Once it came back online I followed your steps: Room settings -> advanced audio -> surround settings -> music playback -> from ambient to full.

When I changed the room source from TV to pandora I put my ear next to the ceiling speaker and did not hear any music coming from it. Is there a way to isolate surrounds from playbar?
Thank you Chris for your input. Switching to "full" mode was great for troubleshooting. I determined that one end of my custom ethernet cable had the wires in the wrong pin location. That resolved the problem and then setting it up was as simple as it should be. haha

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings