Answered

Can't login to my wife's account via iPhone

  • 10 January 2021
  • 8 replies
  • 127 views

The iPhone app connection to our Play:1 and Play:3 got screwed up, such that I had to go thru the reset process of temporarily connecting one of them to the router via Ethernet.  That only partially worked, and various attempts to correct it finally got them both working, but with the Play:1 on my Sonos account and the Play:3 on my wife’s Sonos account.  But after logging out of the app on either/both iPhones, it won’t let us log into the other account - demands the credentials for the account we just logged out of.  How to fix/workaround this?

icon

Best answer by Ken_Griffiths 11 January 2021, 00:48

Ah...I see what has ‘likely’ happened here and it seems you initially introduced the issues when you added the eero mesh WiFi system and also left your original ISP Comcast ‘WiFi’ system still up and running. You have got your setup into a bit of a mess with two separate Sonos Households. Here are my suggested steps to fix the issue...

  • I would suggest you switchover the Comcast router to modem mode, or if that feature is not supported on the router, then at the very least switch off all its WiFi beacons completely and just use the eero WiFi system - you likely don’t need both WiFi networks and that was perhaps what led to the first steps towards your current problems.
  • So with the Comcast router in ‘modem’ or ‘bridged’ mode with its WiFi switched off, you are then best to ‘wire’ one of your Sonos devices to the primary eero hub only.
  • This wired Sonos device will become the root-bridge to your Sonos system, which will then connect to other Sonos products using its own internal wireless signal, called SonosNet.
  • Once you have one Sonos device wired to the eero hub, connect all Sonos controller devices to the eero WiFi and open the controller App. You may see either one or both speakers.
  • If you do not see the speaker that is wired to the eero primary hub within the Sonos App, then I suggest  you reset the App in "Settings App Preferences" and then choose the option to connect to the "existing” Sonos system. Do not create a new system.
  • After the App reset, if you see just the one wired speaker only,  I would simply ‘factory reset’ the ‘other’ (missing) speaker and add it back to the system using ‘Add Product’ in ‘Settings/System’ in the Sonos App.
  • And the last step (phew!!), when everything is back up and working well, then goto "Settings/System/Network/Wireless Setup" and reset/remove your WiFi credentials from the Sonos App, as these are not needed when the devices are running on SonosNet and it will prevent your speakers losing connection by trying to hop between the SonosNet signal and your eero WiFi signal.

Hope the above suggestions help to get things sorted.

View original

8 replies

More re my problem.  It may have started after installing an eero mesh system - don’t remember, since it started weeks ago.  In any case, after my first post above, I noticed that my Play:3 was connected via the eero at 2.4 GHz, but my iPhone was connected to the eero at 5 GHz.  And my Play:1 was connected to my ISP’s (Comcast) modem/router, but their app doesn’t seem to tell if connections are 2.4 or 5 GHz.  So I disconnected the eero, and voila, both speakers are now accessible to my iPhone, via my Sonos account!  (Don’t know about my wife’s iPhone/account yet.)  So “surely” the speed (2.4 vs 5) and/or the connection box (Comcast or eero) control what’s happening here.  So I COULD spend more hours trying to sort this out, OR I could hope that someone out there understands how this all works, and can tell me in simple terms.  The latter would be GREAT, and I would sing your praises.  (Of course, none of the above addresses why I can’t log out of the iPhone Sonos app and then log in to a different account.  That seems less important now, but an answer to that would also be interesting.)

Ah...I see what has ‘likely’ happened here and it seems you initially introduced the issues when you added the eero mesh WiFi system and also left your original ISP Comcast ‘WiFi’ system still up and running. You have got your setup into a bit of a mess with two separate Sonos Households. Here are my suggested steps to fix the issue...

  • I would suggest you switchover the Comcast router to modem mode, or if that feature is not supported on the router, then at the very least switch off all its WiFi beacons completely and just use the eero WiFi system - you likely don’t need both WiFi networks and that was perhaps what led to the first steps towards your current problems.
  • So with the Comcast router in ‘modem’ or ‘bridged’ mode with its WiFi switched off, you are then best to ‘wire’ one of your Sonos devices to the primary eero hub only.
  • This wired Sonos device will become the root-bridge to your Sonos system, which will then connect to other Sonos products using its own internal wireless signal, called SonosNet.
  • Once you have one Sonos device wired to the eero hub, connect all Sonos controller devices to the eero WiFi and open the controller App. You may see either one or both speakers.
  • If you do not see the speaker that is wired to the eero primary hub within the Sonos App, then I suggest  you reset the App in "Settings App Preferences" and then choose the option to connect to the "existing” Sonos system. Do not create a new system.
  • After the App reset, if you see just the one wired speaker only,  I would simply ‘factory reset’ the ‘other’ (missing) speaker and add it back to the system using ‘Add Product’ in ‘Settings/System’ in the Sonos App.
  • And the last step (phew!!), when everything is back up and working well, then goto "Settings/System/Network/Wireless Setup" and reset/remove your WiFi credentials from the Sonos App, as these are not needed when the devices are running on SonosNet and it will prevent your speakers losing connection by trying to hop between the SonosNet signal and your eero WiFi signal.

Hope the above suggestions help to get things sorted.

To Ken_Griffiths -- Thanks so much for the reply!  I’ll be out of town for a few days, and so won’t be getting right on this.

Yes, after my second post, I discovered a Post-It note on my desk wherein I linked the two events (installed eero, and then speakers disappeared) when the problem first arose many weeks ago.  (It’s the sh!ts getting old.)  At the time, I got the speaker connections limping along, so put the issue aside in favor of more pressing needs (we had just moved into a new house).

One question: you don’t mention any problems with mixing 2.4 and 5 GHz.  Is that not an issue, as long as devices that need to communicate are linked to the same Wi-Fi “box” (eero or Comcast)?

Latest developments: Unsurprisingly, soon after reconnecting eero yesterday, my phone couldn’t find either speaker, but the buttons on the speakers themselves still worked.  This morning, my phone finds both speakers, but says no music is selected, even as both speakers are playing!  And the volume controls in the app work!  The Play buttons in the app are greyed out (reasonable, since it thinks no music is selected), but after selecting music (which worked), it still says no music is selected, and the Play buttons are still greyed out!  Weird to me, but then I don’t know what’s under the hood.  Not asking for any diagnosis or explanations, because I’m sure your suggestions above will fix all this - just volunteering some data in case other people run across similar symptoms.

One thing that might be worth emphasising is that you cannot have two Sonos accounts on the same system. You have to have just one Sonos account.  If you both have music service accounts they can both be added to the single Sonos system. 

 

Jerry_2,

If you follow the bullet points, you should hopefully end up with one system running on ‘SonosNet’ and as John mentions, any current music services belonging to both you and your Wife can be added to the one system. 

With any mesh WiFi home setup, it’s usually good practice to run Sonos in SonosNet mode with one device wired to the primary mesh hub. Just don’t wire anything to any secondary hubs.

Oh and good luck to you and the Wife in the new home too.

Ken_Griffiths -

I got back to this last weekend.  It wasn’t immediately obvious how to kill the router functionality on my Comcast modem.  Besides, having that router capability available could be a benefit from time to time.  So I thought that perhaps all I really needed to do was to change the SSID for the modem/router, and set the few devices that roam (mainly computers and phones) to not automatically connect to that new SSID.  (I don’t think I made it clear that I had given the eero system the same SSID as my Comcast modem/router.  Seemed like an obvious approach to me … but I didn’t understand that they are separate networks, which would lead to problems.  I foolishly thought the eero system would just seamlessly integrate into my existing Wi-Fi system.)  So that’s what I did (ie, renamed Comcast SSID and blocked auto-switching to that new name), and voila, everything then seemed to work … and has continued to work for a week now.  However, that means that I don’t have the configuration that you suggested -- eg, no wired speaker, etc.  And I have no idea what use my system is making of SonosNet (which I had never heard of before).  So, will I eventually run into trouble this way? … and if so, what sort?  (Re the new house, we are slowly chipping away at getting truly moved in.  A lot of work.)

 

John B -

I presume that by “on the same system”, you mean Sonos system?  But what defines a “Sonos system"?  And where is “ownership” info stored? -- in the speaker(s), or in the app, or in the cloud, or … ?  (FWIW, we also have a different couple of speakers (one is Alexa-enabled) at a vacation house, but my phone can only see the non-Alexa speaker.  The ramifications of ownership may explain what is going on there.)  Both of our phones were (yesterday) signed into my Sonos account, and both could control both speakers (unsurprisingly).  But we couldn’t switch either phone to HER Sonos account, as far as I could tell -- the app won’t allow it.  Today, she signed out with her phone, but could still control both speakers!  So I signed out also, and could also still control both speakers.  So evidently being signed in bestows benefits different than just controlling speakers.  In any case, her not being able to sign into her account is OK in the short run, but presumably she will NEED to sign into her account at some point.  So what’s going on here?

 

Of course, as always, neither of you is obligated to address my new questions.

 

Ken_Griffiths -

I got back to this last weekend.  It wasn’t immediately obvious how to kill the router functionality on my Comcast modem.  Besides, having that router capability available could be a benefit from time to time. 

The likely consequence of running both WiFi systems side-by-side is that either the eero wireless, or the Comcast wireless will auto-change channels at some point (perhaps during their next reboot, or update etc.) and that could introduces possibilities of wireless interference, plus if Sonos devices are on one system and your controllers on another I can see the controllers likely losing contact with your Sonos products.

So I thought that perhaps all I really needed to do was to change the SSID for the modem/router, and set the few devices that roam (mainly computers and phones) to not automatically connect to that new SSID.

It will still not reduce the potential (at some point) for wireless interference to occur and possibly cause you communication problems with Sonos.

  (I don’t think I made it clear that I had given the eero system the same SSID as my Comcast modem/router.  Seemed like an obvious approach to me … but I didn’t understand that they are separate networks, which would lead to problems. 

I am quite certain that you will encounter ‘SSDP discovery’ issues if your mobile auto-connects to the Comcast WiFi subnet and your speakers are operating on the eero subnet… there’s no way the ‘discovery’ information will pass between them.

I foolishly thought the eero system would just seamlessly integrate into my existing Wi-Fi system.)  So that’s what I did (ie, renamed Comcast SSID and blocked auto-switching to that new name), and voila, everything then seemed to work … and has continued to work for a week now.

In which case it still is a much better idea to switch off the Comcast WiFi completely, in my humble opinion… I’m fairly confident it will otherwise likely create interference at some future point. The eero hubs on there own will likely provide the coverage you need for home use.

  However, that means that I don’t have the configuration that you suggested -- eg, no wired speaker, etc.  And I have no idea what use my system is making of SonosNet (which I had never heard of before).  So, will I eventually run into trouble this way? … and if so, what sort?  (Re the new house, we are slowly chipping away at getting truly moved in.  A lot of work.)

I guess many would say here, if it’s not broken then leave it alone… whilst I personally wouldn’t recommend the current setup you have, there’s nothing to prevent you from leaving things as they are and if you later do encounter any issues with audio, or device, dropouts, then there is still nothing preventing you from hanging onto the earlier suggestions/recommendations above and trying those at some future point in time, if necessary.

So perhaps see how it goes and maybe change things later, if you encounter any problems with your Sonos system.

Hope that assists..👍

Thanks! :thumbsup_tone3:

Reply