Question

Can't download App for windows

  • 12 September 2017
  • 3 replies
  • 576 views

Hi people, I just bought a Sonos Play1. I went to the support page and tried to download an App for my Windows 10 system. However, whenever and whatever I tried to click the "Download Windows controller" button. Nothing shows up afterwards. I tried firefox and Chrom, and they acted the same. Could anyone had the similiar experience before or know how to solve this kind of problem can give me a hand? I really apprecate your time and help. Thanks.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Have you looked in your download folder?

Have you tried right clicking on the graphic that says Windows, and selected "Save Link As"?
Thanks for the quick reply. There is nothing in my download folder. As your advice, I tried "Save Link As" and then I got a file called "SonosDesktopController74", which has 0mb as its size. And also, when I try to run it, can't be ran on windows.
That's odd. Which version of Windows 10 are you running (and I'm not asking for myself, I'm just an occasional user, not an expert, but there are others here who might chime in, if they had the information).

Try putting this in your menu bar in your browser: https://www.sonos.com/redir/controller_software_pc