Answered

Beam to Samsung Q7

  • 4 August 2018
  • 8 replies
  • 3719 views

Badge
Not loving Sonos right now. New Beam and new Q7.

Samsung Q7 will connect and recognize in the TV but won't play any sound. Also won't allow you to play the TV sound unless you manually turn off the CEC setting. The Beam works fine on its own and with Alexa but right now its just a glorified and rather expensive mid-level speaker.

I have unplugged all other devices and HDMI connections from the TV and unplugged the TV and the sonos to reset everything and no change each time.

Any ideas? Thanks
icon

Best answer by DePa 10 August 2018, 14:56

Not loving Sonos right now. New Beam and new Q7.

Samsung Q7 will connect and recognize in the TV but won't play any sound. Also won't allow you to play the TV sound unless you manually turn off the CEC setting. The Beam works fine on its own and with Alexa but right now its just a glorified and rather expensive mid-level speaker.

I have unplugged all other devices and HDMI connections from the TV and unplugged the TV and the sonos to reset everything and no change each time.

Any ideas? Thanks


I spoke with Sonos Support, i have QE65Q7005, the issue were the Smart Connect box (HDMI BOX). U need to unplugg the powerplug, sonos recomended 10 min, i waited 15 min then reconnected BEAM to HDMI ARC (input 2). The smart Connect Box will remember what were last conncted to it, it needs to be unplugged. After i saw Sonos BEAM as a Source on TV, i reconnected all other HDMI Connections 1 by 1. Worked for me. Good Luck!
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 2
Badge +4
Have you tried connecting the Beam using the Optical Coupler into the Optical port on the Q7?

Also check how the sound settings are configured on the TV as it may modify the signal as its passed through into a format the Beam won't support.

I have a Q7 that I use with my Playbar, it required some tweaks in the TV to get it working and carrying out a proper pass-through of DD5.1

Use the Sonos App under Help, about my Sonos and under the beam details it will say Audio: followed by 'Stereo', 'PCM' or 'Digital 5.1'

If it says No Audio then start looking at connections, if 'Unsupported' its a format the Beam does not know how to decode.

I find the Samsung CEC implementation to be annoying at best and its disabled on all my equipment.
Badge
Thank-you very very much for the reply.

I am getting the exact same symptoms on both the HDMI and the optical. It seems as if the TV and Beam both recognize each other and on the TV the little symbols move as if there is sound coming in but no sound out of the Beam. The remove even pops up the HDMI symbol on the TV and the + flickers as if it is raising the sound but no sound.

In the Sonos app for the Beam the audio in field just shows blank. It doesn't have anything, stereo, digital, PCM or anything both when the HDMI cable and the optical is used. I tried multiple HDMI cables so it is unlikely that it is that.

In the Beam guide it says I have to hit a 'source' button on the side of the Beam but I don't see any additional buttons so i think the documentation is just wrong.

Any further thoughts?

Samsung is a pretty major TV supplier, and the Q is their premium line. It is hard to think that Sonos is so bad that they don't either make the Beam work with Samsung or at least be honest and say it doesn't work with Samsung. Or at least have a simple set of steps on how to make it work with Samsung. I've always had a good impression of Sonos so it is hard to believe that are that pathetic when launching this new more main-stream oriented product.

Thanks again for the help.
Userlevel 2
Badge +4
As the Beam is not putting anything in the Audio field in the about box it isn't receiving anything from the TV, or the Beam or its cable could be defective.

I have a number of Samsung Model TV's including the Q7 & not one of them behaves the same way!

Is it possible to feed the Beam from another optical source? I.e if you have a satellite box or something you know works! Just to confirm that the Beam is OK. essentially if it receives an optical feed it will produce audio. Using optical feed it is just a listening device, Using ARC and the CEC nonsense just adds a complication into diagnosing the problem.

Also to eliminate the inputs, try just using the TV as the receiver and audio source as that will simplify your problem solving.

If that works then concentrate on the TV. The Q7 does pass through, but there are settings to change. I will have a look at my Q7 tomorrow and post the setting in this thread.

If you're still having issues I will connect my Beam to my Q7 and see what happens!
Userlevel 2
Badge +4
Hi,

Here are the settings for the Q7 that works with the Playbar, These should work with the Beam, with th eoptical adapter:

Settings Menu in the Q7 TV -
Select - Sound
Set Sound Output to Audio Out/Optical

Select Expert Settings

Set HDMI Input audio Format to Bitstream
Set Digital Output Audio to Dolby Digital

That will take Digital Audio from your HDMI inputs and transcode them to Dolby Digital which the Playbar/Beam can use.

Let us know how you get on.
Badge +1
Not loving Sonos right now. New Beam and new Q7.

Samsung Q7 will connect and recognize in the TV but won't play any sound. Also won't allow you to play the TV sound unless you manually turn off the CEC setting. The Beam works fine on its own and with Alexa but right now its just a glorified and rather expensive mid-level speaker.

I have unplugged all other devices and HDMI connections from the TV and unplugged the TV and the sonos to reset everything and no change each time.

Any ideas? Thanks


I spoke with Sonos Support, i have QE65Q7005, the issue were the Smart Connect box (HDMI BOX). U need to unplugg the powerplug, sonos recomended 10 min, i waited 15 min then reconnected BEAM to HDMI ARC (input 2). The smart Connect Box will remember what were last conncted to it, it needs to be unplugged. After i saw Sonos BEAM as a Source on TV, i reconnected all other HDMI Connections 1 by 1. Worked for me. Good Luck!
Badge
John_93

I can change these settings and still nothing from the TV. On the Sonos app it still has a blank line on the Audio In field. Any other thoughts?
Badge +1
Do you use HDMI or Toslink converter? Sounds like its your TV settings

Set Sound Output to Audio Out/HDMI (Reciver HDMI) PCM or BITSTREAM and choose Dolby Digital
Userlevel 2
Badge +4
No not really, you need to determine if it’s a faulty TV or Sonos, the settings I gave you do work so something is faulty.