Beam Gen 2 Sky Q and Remote Issue

  • 1 November 2021
  • 5 replies
  • 224 views

Hi all, 

Joined the community in the hope someone could confirm something for me.

Just set up my Beam Gen 2 this evening and I’m having issues.

There doesn’t appear to be any volume control showing, from the various forums I’ve read this appears to be an issue with my Samsung TV, I take it there is now work around for this?

I am also getting lip sync issues on Sky Q, only works fine when using normal PCM thus missing out on DD / Atmos.

I am trying to weigh up whether to just return the Beam or see if I can cope without a volume indicator and have to miss out on DD / Atmos whilst watching Sky Q.

Hoping I am just being a complete novice here and I am just doing something stupid and would really really appreciate someone helping me with some advice.

Thanks in advance! 


5 replies

Hi all, 

Joined the community in the hope someone could confirm something for me.

Just set up my Beam Gen 2 this evening and I’m having issues.

There doesn’t appear to be any volume control showing, from the various forums I’ve read this appears to be an issue with my Samsung TV, I take it there is now work around for this?

I assume you have the volume control working (via HDMI-CEC) and that there is simply no volume indicator on screen - this is apparently quite common for a lot of TV’s when controlling a Receiver using CEC. However if your TV ‘remote’ operates over Infrared, you could setup the ‘remote’ in the Beams ‘Room’ settings in the Sonos App ‘Settings/System’ (select ‘TV Remote Setup’ to allow the Beam to recognise your remote). With control operating via infrared you will see your normal on-screen volume control indicator. If however your TV ‘remote’ uses Bluetooth to connect/control the TV, then you are probably out of luck.

I am also getting lip sync issues on Sky Q, only works fine when using normal PCM thus missing out on DD / Atmos.

I am trying to weigh up whether to just return the Beam or see if I can cope without a volume indicator and have to miss out on DD / Atmos whilst watching Sky Q.

Hoping I am just being a complete novice here and I am just doing something stupid and would really really appreciate someone helping me with some advice.

Thanks in advance! 

If the TV connected-devices, like SkyQ, are giving you lip-sync issues, then I would check your TV user-manual to see if the TV supports audio pass-though on its ports - many TV’s have their digital sound-out set to ‘Auto’ and in that case it may try to check/process the audio passing-through it’s ports, en-route to the Receiver. To avoid any interruption/delay, it’s often helpful to set that sound-out option to ‘pass-through’ the audio and that should solve your lip-sync problem. Note however, not every TV supports audio pass-through and if their internal processor is not quick enough, then you may have to consider other options to bypass the TV with an audio extractor/splitter such as the HDFury Arcana, which you can read more about here:

https://www.hdfury.uk/product/hdfury-arcana/

As with all Receiver/Speakers, the Sonos Home Theatre products like the Beam, can only play the audio when it’s actually received and it’s usually the TV’s job to do that quickly enough to play the audio in time with the video on screen.

Hi Ken,

Many thanks for your reply, I really appreciate it.

The Sky Q remote is Bluetooth, to be more specific it does pop up on screen showing HDMI Receiver with a + & - but I no longer get the volume level if you know what I mean so the only visual way of knowing how high the volume is would be by looking in the SONOS app, maybe a minor thing but I do like to to know if I’m on volume 10, 25 etc. Your response gave me the idea to maybe try set up my IR Samsung Smart Remote, not sure if that would bring back the volume indicator but it’s something I can try. Seems this is more a Samsung specific issue and how it utilises the Anynet function.

 

Not entirely sure how I find out but it doesn’t look like my Samsung qe65q60r supports pass through. So only option is to use the normal audio option within Sky Q or set up using the Optical adapter to sort out the lip sync issues unfortunately meaning I miss out on DD.

Thanks for the info on the HDArcana, looks like that would sort it right out, just not sure if I am happy to fork out more money.

 

Thanks again for your help, I do really appreciate it 

Badge

Hi Ken,

Many thanks for your reply, I really appreciate it.

The Sky Q remote is Bluetooth, to be more specific it does pop up on screen showing HDMI Receiver with a + & - but I no longer get the volume level if you know what I mean so the only visual way of knowing how high the volume is would be by looking in the SONOS app, maybe a minor thing but I do like to to know if I’m on volume 10, 25 etc. Your response gave me the idea to maybe try set up my IR Samsung Smart Remote, not sure if that would bring back the volume indicator but it’s something I can try. Seems this is more a Samsung specific issue and how it utilises the Anynet function.

 

Not entirely sure how I find out but it doesn’t look like my Samsung qe65q60r supports pass through. So only option is to use the normal audio option within Sky Q or set up using the Optical adapter to sort out the lip sync issues unfortunately meaning I miss out on DD.

Thanks for the info on the HDArcana, looks like that would sort it right out, just not sure if I am happy to fork out more money.

 

Thanks again for your help, I do really appreciate it 


Your tv must support DD passthrough, else you would not be getting DD from the Beam. The issue is that the TV is doing some sort of processing on the signal and introducing the delay. Do you get lip sync problems on other devices?

Have you tried putting the TV into game mode, which is supposed to switch off a lot of the processing the TV does - mainly for the picture but I have read on some forums that it can help with lip sync where the TVs processor is being stressed by all the processing  

I have a much older Samsung TV from 2013 and a gen 1 Beam. I get lip sync issues appear sometimes when using Sky Q but never from my Apple TV. Sky Q and my TV seem to have some HDMI handshake issues as depending the order the devices come out standby I get a pulsing sound when changing from HD channel to HD channel.

Hi,

I did try Game mode, I have spent the last few days trying everything possibly it would seem.

The in built apps play fine without delay but my PS5 is also suffering synch issues, basically the picture comes before the audio.

I watched a video on YouTube from some big Tech company that said Sonos and Sky were aware and trying to work on the issue.

These issues along with the fact that I can’t get a visual representation of volume level have convinced me to return the Beam as I’m just not getting all the benefits. I nearly purchased the HDFury to solve all the issues but decided against the extra cost.

Shame as it did sound bloody good when working!

Thanks for your reply 

The solution to getting the Sky Q working with the Samsung Smart remote and Sonos is to disconnect the optical cable from the TV end and reconnecting leaving the Sonos system on. I’ve just done it, my Samsung TV registered the Sonos automatically and it works brilliantly. 

Reply