Answered

Asus Zenwifi XT8 with Sonos


I recently added the Asus Zenwifi XT8 to create a better network throughout my home and its brilliant except with my Sonos products. I am unable to be fully wireless, I have to have at least one player connected via ethernet for all my Sonos products to work which is not ideal. Any ideas? Everything  else works perfectly.

icon

Best answer by Steviegal 12 May 2021, 13:43

View original

22 replies

Userlevel 7
Badge +17

Hi @Steviegal 

Welcome to the Sonos Community!

Have you taught Sonos the new WiFi details? If not, you can do so from Settings » System » Network » Manage Networks » Update Networks

Have you disabled Airtime Fairness on the router? If not, I recommend you do so.

If that doesn’t help, you may need to get a Boost to wire to ethernet instead of a speaker - though I recommend you first get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Userlevel 7
Badge +17

Hi @Steviegal 

We’ve also seen issues whereby certain Asus routers need a factory reset after updating their firmware. You may want to try this if all else fails.

Hi Corey,

Thank you for your time.

I have already done all you suggest but have decided to try the Boost route to put all my speakers on a separate network. There are several on eBay and not expensive should that also not work but from what I’ve read they seem to cure others network problems.

Thanks again

Steve

Userlevel 7
Badge +17

Hi @Steviegal 

Yes - if you can only get your system to work with one unit ethernet wired, but don’t want a speaker in that location, then a Boost is for you. Please make sure you don’t get a Bridge.

Running Sonos on SonosNet will have a three-fold effect:

  1. Your router’s WiFi, it’s settings, and any extenders/boosters are bypassed, thus eliminating many possible configuration or incompatibility issues
  2. Sonos doesn’t have to share bandwidth on 2.4GHz with other devices (assuming your WiFi and SonosNet are on separate WiFi channels), so playback can be more reliable
  3. Sonos creates a mesh, with each player extending the range for the next, so your speakers may get better signal strength in certain locations than they would when using WiFi

I would still recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and network, prior to spending any money (if you haven’t been in touch already).

If you do get a Boost, please keep it 1m away from your router and other WiFi devices.

As with buying any Sonos product second-hand, if it doesn’t flash green about 1 minute after you first turn it on, factory reset it to make it ready to be added to your system (the seller should really do this, but sometimes they don’t realise).

@Steviegal Did you contact support or just opt for purchasing the Boost?
I think I am suffering the same issues you experienced.

Well my issue is resolved but not in the way I expected. I did purchase a Boost from EBay but by the time I received it I no longer needed it so will be selling on EBay unopened.

While I was awaiting the Boost I had full fibre installed at home and my provider supplied an ASUS CT8 for my router and I used my existing 2 x ASUS XT8 as nodes which now gives me complete full fibre speeds in virtually every corner. So no need for me to contact support, one happy bunny.

Sorry I can’t be any more helpful but strong WiFi in every corner seems to be the answer, well it was for me.

Steve

Following some advice I did a full reset of the XT8 (router and node) and a delete and reinstall of the Sonos app on my phone and I now have the Sonos speakers working with my XT8 WiFi network.

The XT8 reset requires a long press of the WPS button when turning power on. The LED flahes white and then green, after which you can release the WPS button.

Keeping my fingers crossed I don’t have to do a factory reset of the XT8 and Sonos app if/when Asus release more firmware updates. Re-adding all the IP assignments and MAC filters is a time consuming process.

Glad you sorted it, let’s hope it lasts. I have done a firmware upgrade and all has held up OK since.

After the latest firmware update from ASUS xt8, got the same issue, tried anything to solve it but just finally ended by do a factory reset of the router. It worked perfectly !

Basically after update, need to factory reset. Not ideal but I’m happy now

So after a factory reset of the router, you have to manually reconfigure everything?

I bought an Asus XT8 a few days ago (a pair of units). My two SONOS speakers worked fine on the new setup until I upgraded to the latest firmware (3.0.0.4.386_43181).

I found the airtime fairness was already disabled for my 2.4GHz channel, so that’s no help.

The other suggestion here seems to be a factory reset, but I assume a factory reset would return the router to an older version of the firmware? I.e. whatever the compatibility problem is was introduced in recent versions? What version of firmware are the people who have this working here using? (It’s visible on the main router console).

No, a factory reset of any device should not change the firmware it is running.

 

I bought XT8 yesterday and upgraded the firmware to (3.0.0.4.386_43181) during set up. In the end I couldn't add my Sonos 1 after 3 hours. Finally today hard reset the routers to factory and flashed to firmware 3.0.0.4.386.42095 which was also released on the same date 11 Aug.

 

Miraculously Sonos 1 finally was able to be added.

 

Hope this helps all who are having issue with XT8 pairing with Sonos.

 

I’ve been running 3.0.0.4.386_25790 for about 3 months.  It predates all the sonos problems and my system runs fine on it.  I’m not going to upgrade the ASUS firmware until I know its not going to block communication with Sonos products.

I picked up a pair of brand new Asus XT8's yesterday.  I set up my whole home network today and it all worked like a charm, apart from the Sonos.  I can't get the Sonos network (x3 Play 1 and x1 Play 5) to work without plugging one in with an ethernet cable.  Any attempt to create a new wifi network in the S2 app fails with it being unable to find my device.

This thread seems to address the issue and I'm thinking the fact my system upgraded to firmware (3.0.0.4.386_43181) as part of the setup today is my problem.

If i did a factory reset of the Asus XT8's though, what does that mean for my network settings?  I.e. do i need to go round my house reconnecting the 21 other devices I've spent time connecting already?

Also, how does a factory reset help?  Does it return the firmware to an older version that works, or are we just saying that for some unknown reason a factory reset will work and it will still keep the firmware as the latest version?

I had the same problem with newer firmware.  I could keep at least one unit wired and the Sonos system would “work”, but it still would have trouble using a third party music source.  I would get errors trying to play Spotify using the Sonos app, but I could open Spotify and play to one Sonos speaker.  Basically, the Sonos speakers could not look out of my network, but Spotify running on a phone in my network could see my speakers. It was maddening.  I’m not upgrading the firmware until something else stops working.  

You don’t need to do a factory reset.  Get your Asus network running like you want it and then download an older firmware.  Make sure you push it out to all your nodes.  The Sonos should work fine on the old firmware.  I haven’t noticed any issues running my Asus on the old firmware, other than you don’t have as many icons to choose in the network map.  

Well, definitively it is an Asus firmware problem. For sake of sharing with the community, I had this issues with our Sonos One and Yale Lock. Exactly the same problems. 
Downgraded to 25790 firmware and voila. Everything is working. FWIW, with latest tried everything, AF off etc. Nothing, nada.

I tried Asus support a few times, no responses. But I can claim it is affecting at least two different products in the 2.4 band.

Can anyone point me to a source of the older firmware version 25790?  ASUS only has the latests available on their website. 

I’m having the same issue and have put in a ticket with ASUS about it.  I tried down grading the firmware to a different version, which caused the SONOS to work but it caused a problem with the connection between the modem and the router.  

In the meantime I’ve connected my Beam via ethernet and everything is working again (for now).

Thanks!

Can anyone point me to a source of the older firmware version 25790?  ASUS only has the latests available on their website. Bump

finally decided to deal with this after getting at XT8 pair.  Currently on firmware 3.0.0.4.386_43181.

its been previously mentioned but was solved by doing a full factory reset (didn’t re-upload old settings).

devices now present in app and via airplay.

https://dlcdnets.asus.com/pub/ASUS/wireless/ZenWiFi_XT8/FW_ZENWIFI_XT8_300438625790.zip

I have the same problem with my symfonisk connecting to my XT8. My firmware version is 43181 as well. Symfonisk was able to connect to my XT8 and get an IP address, yet the Sonos app fails to pick it up. 

 

Tried so many times and ready to give up until I found this incredible post, I followed olliewolf’s suggestion to do a full factory reset and everything just works after that. Cheers mate. If you have asus router and problem to get symfonisk recognized in Sonos app, you can definitely try resetting the router. ;)

Reply