UX feedback: Struggles with Roam + multiple paired bluetooth devies

  • 4 December 2022
  • 2 replies
  • 21 views

Hi!

I own a Roam (SL) and love it - although I have come across two frustrating issues:

  1. I’ve found that if the Roam is connected via bluetooth to device A, and device B attempts to connect, the Roam disconnects from device A.
  2. When entering bluetooth pairing mode, the Roam will connect to any available paired devices, making it tricky to pair new devices.

Elaboration on (1):

Since I use it with both my phone and PC, this happens a lot when I’m listening to something with my phone, then goes to turn on the PC. The PC attempts to connect via bluetooth, as they are paired, the Roam drops the connection to my phone, which then requires me to reconnect and resume playback.

This issue is quite easily reproduced by pairing two devices, connecting with one, then attempting to connect with another.

In my opinion, the Roam should refuse bluetooth connection requests when another device is connected.

 

Elaboration on (2):

An issue with my PC sometimes requires me to remove and re-pair bluetooth speakers - this has happened with other speakers as well. When I do this with the Roam, I have to disable bluetooth on my phone, otherwise it will connect to the Roam when I enter pairing mode. Not sure why this happens.

It’s a minor issue, but imagine sharing the Roam with someone, both having your phones paired, and you want to pair it with a third device. Then, you first have to disable bluetooth on both phones…

 

Hope this can be fixed.

Best regards,

Rasmus


2 replies

Perhaps see if this support link might assist to resolve some of your ‘re-pairing’ issues:

https://support.sonos.com/en-us/article/pair-sonos-roam-with-bluetooth

Just switch on/off the pairing with the Roam on the sending device instead of using the Roam. That should resolve some of the things mentioned.

OH! It’s a feature, not a bug! This indeed does resolve issue (2). Thanks!

Perhaps see if this support link might assist to resolve some of your ‘re-pairing’ issues:

https://support.sonos.com/en-us/article/pair-sonos-roam-with-bluetooth

Just switch on/off the pairing with the Roam on the sending device instead of using the Roam. That should resolve some of the things mentioned.

Reply