Answered

Random disconnects for Move & Roam SL (wifi)

  • 28 March 2023
  • 1 reply
  • 72 views

It appears that Sonos support is backed up so I guess I’ll post my question here also…

 

My existing system (two Ones (G2) & Sub) that are connected to the Boost do not have this problem. Apparently these two devices connect to my wifi and not the boost so I assume we will have to blame my wifi, yet the 66 currently connected devices which is a mixture smart TV's, streaming devices, security cameras, smart devices, etc... do not have random disconnect problems.

I'm doing my share of searching, I see posts about Asus routers and disabling QoS or Airtime Fairness, some say nothing changes...

So I guess I need to know what magic settings the Move and Roam SL require in order to work as expected.

Honestly I expect these things to work with minimal screwing around because I paid for $ONO$... If the cheap $5 smart plug can stay connected to my wifi, why not almost 600 bucks worth of speakers?

Router is Asus RT-AX92U AX6100

icon

Best answer by Corry P 29 March 2023, 10:55

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +18

Hi @lv426525 

Without seeing diagnostics from your speakers or the current settings on your router, it’s difficult to say what’s going wrong, but I recommend reserving IP addresses for your Sonos devices in your router’s DHCP/Network settings page and ensuring there are no sources of interference within a metre of your portable Sonos devices, or your router.

Reducing wireless interference

For how to reserve IP addresses, please see your router manual.

Disabling QoS and Airtime Fairness may indeed help.

Please note that if the speakers continue playing (or can start playing with a press of a button on the speakers or by voice command) then the issue isn’t that they are disconnecting from the Wi-Fi, but that the router isn’t allowing communication between the speaker and the app. This may be due to other devices on the network - multicast flooding, perhaps.

If you continue to have trouble contacting support, please submit a support diagnostic while the devices are online in the app and report the given number here, but please be aware that it will be a much slower process than a phone call.

I hope this helps.