Answered

My Sonos Roam keeps loosing my Eero wi-fi network

  • 24 January 2023
  • 5 replies
  • 70 views

Userlevel 1

I have a Sonos Roam and an Eero wi-fi network. My Roam keeps losing the network every three or four days.

 

I’ve been reading and it sounds like Sonos and mesh networks don’t play togehter. I’m not sure what my options are. The Boost doesn’t work with portable devices, and setting my Eero into bridge mode also doesn’t seem like an option.

 

I can no longer return my Sonos Roam. Do I have any other options?

icon

Best answer by bockersjv 24 January 2023, 10:06

View original

5 replies

Userlevel 1

It’s been six days since I gave my Sonos roam a static IP address and turned off the battery saving options, and it hasn’t dropped off of the network since! I think my problme is solved, so thanks for the help!

Userlevel 7
Badge +17

Have you tried reserving an ip-adress for the Roam?

Userlevel 7
Badge +21

As above.  I have added a reserved IP address for all my Sonos speakers, including the Roam and Move.  No issues since, but then neither did i have before.  It is very easy to do too on the Eero app.  You can also name the devices for easy identification.

 

Also see if turning off the WiFi battery saving option makes a difference.

Userlevel 1

First, I made a small discovery. My Sonos Roam would drop off the network, and taking it in and out of sleep mode didn’t change that. I discovered though that if I power the Sonos Roam off and power it back on that it rejoins the network.

 

I went into my Eero app and assigned a static IP address to my roam.

 

I also turned off both battery saving options on my Sonos Roam.

 

It usually takes around three days before it drops off of the network, so it’ll take me a while before I’m convinced it’s working, but at least I’m more optimistic than I’ve been in a while! thanks for the tips, and I’ll keep my fingers crossed!

Userlevel 1

I spoke too soon. My Sonos Roam fell of my network twice today. I powered it off and restarted it to get it back on the network. I’ll keep using this as a work around, unless there are any other ideas to try.

Reply