Answered

Resolved - Spotify Playback Issues and Spotify Connect from Android - December, 2017



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

172 replies

Badge
Had the connect issue and fixed it by installing Spotify beta 8.4.31.723 apk. You can get it here: https://www.apkmirror.com/apk/spotify-ltd/spotify/spotify-8-4-31-723-release/ It's been working fine for couple days after the install
Works for me. Thanks! :D


Beta did it for me!
Userlevel 1
Badge
I just wanted to got the official update and now it works again.

I hope Sonos does a RCA on this and a lessons learned session and also take into account the lost confidence in your product.
Userlevel 1
Badge
Can confirm that the spotify update 8.4.31.723 today fixed it ?
Same here, the current spotify update has fixed the issue
Sorry to disappointment - the Spotify update at least now make you connect again to the Sonos system but when you try to change volume it doesn't work or changes volume on the phone. Then system drops out again and won't come back. This is not even in a beta but rather an alpha status. Really annoying
Userlevel 1
Badge
Sorry to disappointment - the Spotify update at least now make you connect again to the Sonos system but when you try to change volume it doesn't work or changes volume on the phone. Then system drops out again and won't come back. This is not even in a beta but rather an alpha status. Really annoying

I can change the volume with the volume keys on my phone but the "bar" showing the volume doesn't update until the popup disappears and I press the volume rocker again so I tend to agree this needs further work.
Now working great for me
Updated to 8.4.31.723 and it's not working for me. Using a Nexus5x on Android 8.1. When I connect to the Play:1 it selects it but no songs can be played - it just skips from song to song in silence. Anyone else having no success with the update?
My setup:
- Sonos One
- Spotify Family
- MacOS desktop Spotify app
- 2x Android Spotify app
- iPad Spotify app

All devices connect to the speaker using the Sonos app. But no device even sees the speaker in the Spotify app. And yes, updated Android Spotify to 8.4.31.723. I see other devices (MacOS sees the Galaxy S7 phone, etc.) in Spotify, but never the Sonos speaker.

Using my 100 day warranty next week if not resolved.
Updating my status from yesterday. I just got the update to the Sonos App 8.2.2 (which also prompts to update speaker firmware) and it has brought back Spotify Connect functionality. Everything seems to be working ok now. Make sure you use the latest Spotify version as well.
Worked for a day and now not working again. I am never buying Sonos speakers again. Absolute sick of constant problems with something that should be quite simple.
Userlevel 7
Badge +26
Thanks for posting everyone. We're working with Spotify still on getting a revised version of the Spotify app out for this. I believe the beta version as some of you have listed might have the fix, but there could be some lingering issues. We're still looking into it with them and I'll let you know when we can officially call it resolved.
My setup:

Bridge connected to router (yes I've had some of this stuff for 10 years)
Connect at Denon AV receiver in TV room (also used to connect receiver to home network, receiver has no wifi)
6 play 1s as 3 pairs
3 play 5s 1st gen, 1 set as pair
4 Echo devices
Spotify
Amazon music
Synology NAS

Phone App firmware update via Pixel android 8.1.0 would never install. Updated Sonos and Spotify via laptop win7 64. All worked. Have learned that Sonos firmare updates seem to always work via laptop, not so much via phone. No breaks in Spotify now. YMMV
Finally!! - the latest Spotify update solved the problem
I have been following this thread since I began having issues following the update. Sonos have told me the issue is fixed. Google play casting works fine but Spotify connect still not working. After an hour on the phone to Sonos they have told me the problem is my router! How can this be when Google play casting working no problem and before the updates Spotify connect working perfectly? I have had enough and contacted the retailer, the speakers are going back tomorrow. If you are considering purchasing Sonos speakers - don't dot it!
I have been having issues for a month or so playing spotify through the Sonos app or playing Sonos through the spotify app. Occasionally it will work but lots of times it does not. Currently it does not work at all. If there had been a fix, it was definitely short-lived or nonexistent. I have 5 Sonos 1 speakers and play them through my iphone. What's the deal? Spotify is my main source of music while at home and this issue has rendered these speakers to be essentially worthless for the month of December. Merry Christmas.
Two of our devices offered an update through the Sonos app. I do not understand if it was an update of the Sonos app, or the speaker firmware itself, but seems like since then all our issues are gone. Both me and my wife can use our Spotify apps with different accounts to control and stream to the speaker.
Userlevel 5
Badge +11
Today it is happening again, I cannot see sonos speakers from Spotify connect app for Android.

Diagnostic is 8307264

Yesterday everything was fine.
Nothing changed, no updates.

My chromecast is there always and visible.
Only sonos.

Please help.
Thank you
Camillo
Getting really, really hacked off with SONOS. Constantly switching off and saying "SONOS product not found".
Passed three days have been a SONOS nightmare.
Not again. My spotify can't find the speaker. This is getting REALLY annoying.
Userlevel 2
Sounds like I have the same issue https://en.community.sonos.com/ask-a-question-228987/spotify-via-sonos-looses-connection-to-sonos-connect-6797627/index1.html#post16189953
Userlevel 7
Badge +26
Hi everyone, the latest version of the Spotify app has the fix for this issue included now. Please make sure that you're running the latest version of the Spotify app. You may want to uninstall the app entirely and re-install it from the Store.

If you're still unable to connect with Sonos players from the Spotify app on any device, I'd suggest that you give us a call on our support line. A technician will be able to help look into the system and see what's causing your trouble. There may be trouble with a router or network configuration here, or something account related.

Because of how long this thread has gotten, we're going to close it down, but if you see anything new come up, please feel free to open a new thread, or join an existing one.