Answered

Resolved: Problems with Sonos Alarms for 12/31/16 - Updates Inside



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

182 replies

Badge
Hello, same problem started this morning with my Sonos Play 1 (saved alarm set to on) - could not pause the radio station (via TuneIn) from the controller or by pushing the physical play/pause button. It would mysteriously start to play again!
At the same time, attempting to change to a different track produced error code 1002.
Anyway, thanks to forum advice, deleting alarms has proven to be the workaround for now, until the problem gets fixed!
This can't be so difficult. Sonos, you must have changed something this morning. Just undo this.
Theres a work round just turn off the internet time setup and manually change the date , theres a bug
Userlevel 1
As an IT consultant and engineer, for myself i think this is taking by far too long. This obviously is a Date/Time issue and maybe because of being a leap year.
Userlevel 4
Badge
This can't be so difficult. Sonos, you must have changed something this morning. Just undo this.

No, it's been in the software for a while, but only manifested itself today. Possibly due to this year being a leap year.
Theres a work round just turn off the internet time setup and manually change the date , theres a bugTheres a work round just turn off the internet time setup and manually change the date , theres a bug

Santacruz is correct. I change my time from Internet controlled to manual. I set it back to a day in Nov. This takes the end of year bug out of play until Sonos fixes it. Since I changed my system more than 3 hours ago, my timer started to perform normal once again. Before that, my system when out control just like so many others on this thread. I think it is a good work around.
My wife thought she was going mad! come to shut the sonos down this evening (we have alarms for week days and weekends) and although you could silence it briefly, kept restarting! Had a bit of a laugh about it and remembered seeing a email earlier about this, went in and turned off the alarms and could then shut it off...

All good fun this, never been knowingly struck with a sonos bug yet so can't be bad!

Happy new year!
I appreciate that Sonos staff are working on fixing this.

Having read most of the entries above, and given that the problem seems to have to do with calendar date, the best patch/fix at the user level seem to be:

- turn OFF the alarms, or
- reset the Sonos clock to another date, not using internet time.

I tried resetting the date to one year in the past (same time/date, but 2015 instead of 2016). Problem seems to be gone. A little more elegant than setting the date to one week in the future or some other date. This will work at least until they sort things out.
NONE of these fixes have worked for me! I reset the clock to manual, and I deleted ALL my alarms ... BUT still one of my PLAY1 speakers can not be shut down without pulling the plug on it! ??? It continues to play the Sonos playlist that was scheduled for this morning, 12/30/16 10AM PST, Los Angeles, USA ... What now???
NONE of these fixes have worked for me! I reset the clock to manual, and I deleted ALL my alarms ... BUT still one of my PLAY1 speakers can not be shut down without pulling the plug on it! ??? It continues to play the Sonos playlist that was scheduled for this morning, 12/30/16 10AM PST, Los Angeles, USA ... What now???NONE of these fixes have worked for me! I reset the clock to manual, and I deleted ALL my alarms ... BUT still one of my PLAY1 speakers can not be shut down without pulling the plug on it! ??? It continues to play the Sonos playlist that was scheduled for this morning, 12/30/16 10AM PST, Los Angeles, USA ... What now???NONE of these fixes have worked for me! I reset the clock to manual, and I deleted ALL my alarms ... BUT still one of my PLAY1 speakers can not be shut down without pulling the plug on it! ??? It continues to play the Sonos playlist that was scheduled for this morning, 12/30/16 10AM PST, Los Angeles, USA ... What now???

Robert-Manually set your date to something not near today. Do not use internet time. I set mine to Nov 2016, and the problem went away. It must be a bug for an end of leap year date. Until Sonos fixes it, I think what I said is a good work around.
SONOS 1 has been singled out several times; including by me....
You cant set the date manually to the 31st dec either manually or via Internet.
Badge
Like a few other people below I am currently away from home, which makes this even more of an issue to resolve. I will likely now have to travel home tomorrow and kill the alarms directly as a result of poor Sonos quality control.

For anyone in a similar situation, and whose alarm is linked to a Spotify playlist, you may want to try accessing your Spotify account and telling them to de-register all devices (see: https://support.spotify.com/uk/account_payment_help/account_settings/can-i-sign-out-of-my-account-if-im-signed-in-on-another-device/)

This initially seemed to make the speakers revert to a Sonos Chimes alarm, which is not much better, but after a while the alarm does seem to have stopped. I don't know if this is permanent or if it will reactivate later. However it could be worth trying if you're also stuck away from home and trying to resolve the alarm issue remotely.
Thanks Jack5150, I reset my clock to 12/1/2014, and unchecked internet time and date. (as well as delete all alarms) This DID work! 🙂
It would be "nice" to have some sort of update from Sonos regarding their progress on this rather nasty glitch! With a manually set date of 12/2/2016 and the alarm set for "once", can I feel confident that my alarm will function properly?
Badge +3
Earlier today we discovered a bug in how some Sonos players interpret leap year dates, resulting in unexpected behavior for alarms set through your Sonos speakers. We're sorry for any inconvenience this has caused.

Until the end of the day on January 1st, 2017, alarms set on Sonos may trigger on the wrong days or times, not trigger at the time you set, or repeatedly loop / not turn off.

For the rest of this weekend, we recommend you disable any existing alarms. If your alarm is going off and can’t be silenced, disable the alarm and then stop the music. You’ll find instructions for alarms here.

After the 1st of January, we expect all alarms will resume their normal behavior. You have our commitment that we will fix this bug in a future update.
After encountering this alarm issue -as most of us Sonos users did this morning- I simply pulled the plug out of the wall socket and continued about my day. I came home to try and resolve the issue and now I cannot connect to my sonos speaker. I've tried everything including a wired connection and nothing seems to work. It blinks the white light, after about a minute it turns solid white... then turns off. The sonos is not recognized in the app and isn't playing any music. I don't know what to do with it. Will an update fix this?
Userlevel 1
Badge +1
After encountering this alarm issue -as most of us Sonos users did this morning- I simply pulled the plug out of the wall socket and continued about my day. I came home to try and resolve the issue and now I cannot connect to my sonos speaker. I've tried everything including a wired connection and nothing seems to work. It blinks the white light, after about a minute it turns solid white... then turns off. The sonos is not recognized in the app and isn't playing any music. I don't know what to do with it. Will an update fix this?

Treat it as a new speaker install. When the power is off for an extended period, I have found this to be necessary.
Userlevel 5
Badge +8
Earlier today we discovered a bug in how some Sonos players interpret leap year dates, resulting in unexpected behavior for alarms set through your Sonos speakers. We're sorry for any inconvenience this has caused.

This is a sneaky little edge case that I'll bet will be added to the testing. 🙂
Userlevel 1
Badge +1
BTW, if you are doing the manual clock reset trick, I'd suggest the year 2011. December in 2011 and 2016 began on the same day of the week. Using that year should make alarm/day alignment work correctly.
Any updates yet? It's 11.20am 31 Dec 2016 in Singapore (GMT +8). So far I re-added the alarms back to sonos app and no restarting of any alarms. Hope it stays that way.
Badge
Offending unit here was a 1st generation Play5 among multiple other units in house. Turns out it did have Saturday alarm enabled.
Tried all the home network resets. No fix.
Tried all the Play5 resets including factory reset. No fix.
Stumbled into triggering alarm on non-offending Play1 when grouped with offending Play5. Tested this three times. Alarm seems to work as intended.
Deleted all offending Play5 alarms.
For grins, set up new alarm on non-offending Play1 and included grouped offending Play5. Typical alarm time so hope it does not "crazy" trigger, but fascinating experiment to appease software bug Deities.
Thanks to forum for workarounds. Never had a bug like this over many years of Sonos use. :?
To satisfy users affected, how about add Sonos playlist export function; sure would like to import them into MediaMonkey !!
Apologies if this has already been suggested in prior messages, but when I couldn't get my PLAY:1 speaker to stop playing the alarm music, I just "overrode" the alarm by manually playing something else to the speaker, and then stopped that. Presto!
Badge
I had the same problem isolated the one player that was on the alarm & disconnected the power overnight, left off until after the alarm time this morning & everything is ok today grouped together able to alter the station / volume even knock off which I wasn`t able to do yesterday
FWIW, I just changed the sonos system date to 2015 and the problem is solved. At least this morning.

Eric