Answered

Youtube Music, wrong format code, no way to link account

  • 17 February 2019
  • 4 replies
  • 162 views

I have a Sonos Play3 and a premium Youtube Music subscription. I tried to link my sonos to the YTM account, but I have a problem that I cannot. overcome.
Sonos APP provides me a code in ABC-DEF-GHI format, see below:



Anyway, when I move into google environment, google requires a code in the format ABCD-EFGH, and therefore there is no way in which I can enter the provided code:



Result: I cannot use YTM on my Sonos.

I tried to contact YTM music assistance but a stupid robot continue to send me standard instructions on how to setup Sonos and YTM, that obviously do not work.

Anyone having the same issue? Any solution?

Thanks,
Ilario
icon

Best answer by Ken_Griffiths 17 February 2019, 17:15

It worked for me here in the UK. Not sure if the below might help...

I’m just wondering if this is perhaps a Country based issue? So perhaps first check your Sonos Account Profile, to ensure it is registered correctly to one of the following countries...

Australia, Austria, Belgium, Brazil, Canada, Denmark, Finland, France, Germany, Ireland, Japan, Luxembourg, Mexico, the Netherlands, New Zealand, Norway, Spain, Sweden, Switzerland, the United Kingdom, and the United States. 

You can follow this link to check ...

https://www.sonos.com/myaccount/profile/ (select flag icon in left hand column below the menu options).

Then perhaps do a similar check with your YouTube Music account by going here:

https://music.youtube.com/

Goto 'Settings/Language & Region' and ensure it is set to the same 'valid' country setting.

Like I say, I’m not sure if that maybe the issue here, but it’s perhaps worth checking those things.?
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

I have the exact same issue. No way to authorize my Sonos, because of the wrong auth-code format. 😞
It worked for me here in the UK. Not sure if the below might help...

I’m just wondering if this is perhaps a Country based issue? So perhaps first check your Sonos Account Profile, to ensure it is registered correctly to one of the following countries...

Australia, Austria, Belgium, Brazil, Canada, Denmark, Finland, France, Germany, Ireland, Japan, Luxembourg, Mexico, the Netherlands, New Zealand, Norway, Spain, Sweden, Switzerland, the United Kingdom, and the United States. 

You can follow this link to check ...

https://www.sonos.com/myaccount/profile/ (select flag icon in left hand column below the menu options).

Then perhaps do a similar check with your YouTube Music account by going here:

https://music.youtube.com/

Goto 'Settings/Language & Region' and ensure it is set to the same 'valid' country setting.

Like I say, I’m not sure if that maybe the issue here, but it’s perhaps worth checking those things.?
It works today. Code format from Sonos matches the format required by Google.
It works today. Code format from Sonos matches the format required by Google.Ah good news, someone must have fixed it. Good to hear your now up and running.?