Answered

Youtube Music won't play certain songs

  • 29 January 2020
  • 3 replies
  • 87 views

Hi, I have a Youtube Premium account and have linked Youtube Music up with my Sonos app. However, there are certain songs/ artists that will not play through my Sonos speakers via Youtube Music. For example Coldplay songs will play fine however, if I select a song by the Artist Daniel Ferri for example and press play nothing will happen - no error message either which is kind of frustrating. Please can someone help?

 

Thanks in advance.

Graham

icon

Best answer by grahamw2000 12 February 2020, 00:15

Hi David, I figured out what the issue was thanks. It seems to be the battery optimisation settings for the YT Music app on my phone. After disabling the batter optimisation it now seems to work thanks.

View original

3 replies

Userlevel 2
Badge +6

@grahamw2000 

 

Welcome to the Sonos Community.

 

I understand that you are having issues with playing certain artists on Youtube Music on Sonos. I would like for you to send us a diagnostic report so we can what is going on when that issue occurs. Reply back with the confirmation number.

Hi David, I figured out what the issue was thanks. It seems to be the battery optimisation settings for the YT Music app on my phone. After disabling the batter optimisation it now seems to work thanks.

Badge +1

Hi @grahamw2000, I tried this and still getting the same issue. Error is - Unable to play, song not encoded correctly but it does play as soon as I try again.

Also not sure how logical is to optimize battery on the android phone since I am getting this issue on my mac as well.

However, it looks like it did get better after battery optimization, getting that error less than before.

Reply