YouTube issues

  • 24 November 2020
  • 24 replies
  • 301 views

I am a member of YouTube Music and I have successfully added the service to my Sonos app in Android.

However, when I try to play music from YouTube Music it is showing a message that access is denied. Please help. Thank you.


24 replies

Userlevel 5
Badge +15

Hi @Sar203.

Thanks for reaching out and welcome to the community!

I appreciate your detailed post outlining your concern, let me help and try to figure this out.

What subscription level do you have on YouTube Music?

Kindly reproduce the issue, then submit a diagnostic report through the Sonos app, and reply with the confirmation number. I'd start by reviewing your system as well as the status of the devices, it will help in identifying what's possibly causing the issue.

For reference, you can check our support article about YouTube Music and Sonos.

 

I’m looking forward to assisting you further from here.

If you have any other questions or run into any issues,  please do not hesitate to reach out,  we are always here to help.

I also have the same issue.

Userlevel 5
Badge +15

Hi @tobcha.

Thanks for reaching out, let me assist you with this.

May I know what subscription level you signed up for YouTube Music?

You may check this article about YouTube Music and Sonos for more information.

To better understand what’s happening, kindly submit a diagnostic report through the Sonos app when the issue occurs, and reply with the confirmation number so I can review your system to see if there’s anything that might cause this problem.

 

Let me know how it goes.

I have Premium

Article was no help.

You wish my confirmation number?

Userlevel 5
Badge +15

Hi @tobcha.

Thanks for your responses and my apologies for the delayed response time.

If you are still experiencing issues, please submit a diagnostic report while the issue occurs, and reply with the confirmation number. This will provide us a snapshot of your system so we can help identify what is possibly causing your issue.

 

Looking forward to hearing from you soon.

The issue is constant. It has never worked. I have already submitted diagnostic reports.

Without listing the numbers here, it’s going to be challenging for Annazel  S to look them up. 

1761613336

679601110

Userlevel 5
Badge +15

Hi there @tobcha.

Thanks for your response and for sending the diagnostics.

Upon checking the diagnostic report, a possible IP address conflict on ‘Lounge R” was detected by the system, but now, based on the recent report, there’s NO more issue or error found on your system.

It’s possible that a reboot was done on the router that resolves the conflict, but if not, you may need to reserve an unused IP address for the Sonos player. Make sure you choose an IP address that is within the router's DHCP scope and does not already show up as assigned to another device. You will need to reboot the Sonos player so that it will receive its new IP address. 

If the issue still persists, please submit a new diagnostic report and reply with the confirmation number so I can check further and see if there’s anything else causing this issue.

 

Let me know how that goes.

Hello,
I am still unable to stream using YouTube Music on Sonos. It will only show the playlist that I have associated with and created, I cannot search for a song. If I update the playlist, it will show the updated song there but even if there are updated songs. but they will not play, they are all grey. if I click it says access denied.
I have authorized my accounts, reinstalled the software/app, and checked my management settings for the account.
I have a premium account.

Please help

Userlevel 5
Badge +15

Hi @DasClay.

Thanks for reaching out, we’d be glad to help.

As of the moment, checking on the music service status page, it shows that there’s no ongoing issue with Youtube Music and it must be fully operational.

To check some data from your system, please send in a diagnostic report through the Sonos app while the issue is happening and reply with the confirmation number. I'd start by reviewing your system and see if there’s anything causing this issue.

 

Looking forward to hearing from you soon.

Badge

I have had this problem for months.

I keep reading that there are no known issues with YouTube, but hundreds of users are getting access denied.

HEY SONOS, Guess what, if hundreds of users have this issue there is a problem.

Sonos was a good product at one time but no more.

@Annazel S I have the same issue. Only "playlists" is shown in YouTube Music, there are liked songs but they are all grey and could not be played: Acces is denied.

Service code is: 527369934

Userlevel 5
Badge +15

Hi @Rockpea.

Thanks for reaching out and sorry to hear about the trouble, let me check it for you. 

When did you start to experience the issue? Is it also happening on other music services?

May I know the subscription level you have on Youtube Music?

NOTE:  You will need a subscription to YouTube Music or YouTube Premium to use YouTube Music on Sonos. 

To check some data from your system, please submit a diagnostic report through the Sonos app and reply with the confirmation number. I'd start by reviewing your system and see if there’s anything causing this issue.

 

Looking forward to hearing from you soon.

Userlevel 5
Badge +15

Hi @Acajkovic.​​​​​​

Thanks for reaching out, we’d be glad to help.

Upon checking on the diagnostic report, the Android controller is not connected to the same network as Sonos and it shows that the SSID is ‘unknown’. The system shows the transport error due to access was denied for the service.

May I know the subscription level you have with Youtube Music?

I suggest checking the WiFi connection on the controller/device and ensure that it is connected to the right network.

Test it to see if that resolves the issue, but if not, please submit a new diagnostic report so I can check the system further and see if there’s anything else causing this issue.

 

If you have any questions,  feel free to reach out.

Badge

Hello, I have the free subscription level on YTM. YTM has never worked with my Sonos System . The list is there but will not play, always Access Denied.  All other services work as they should. I submitted a diagnosis report.  The number is 142068201.

Userlevel 5
Badge +15

 

Hello, I have the free subscription level on YTM. YTM has never worked with my Sonos System . The list is there but will not play, always Access Denied.  All other services work as they should. I submitted a diagnosis report.  The number is 142068201.

 

Hi there @Rockpea.

Thanks for your response and my apologies for the delayed response time.

You will need a subscription to YouTube Music or YouTube Premium to use YouTube Music on Sonos

 

If you have any questions,  feel free to reach out.

Badge

I do have a subscription . Sorry I thought I was clear about this issue. Everything on my end is the way it should be YTM just won't work and there are many end users with the same problem but no answers 

The world would like to.know

Userlevel 5
Badge +15

Hi @Rockpea.

Thanks for your response. We appreciate the time and effort working through this, but at this point, it would be best to reach out to Sonos Support so we can take a closer look at this in real-time and expedite the process. I suggest our phone team for they have more resources available on their system for advanced troubleshooting, and the tools our agents can use would be very useful in this case, there can be an advantage if they need to remote into the controller to see what's going on.

 

​If you have any questions, please feel free to let us know.

Userlevel 7
Badge +21

I keep reading that there are no known issues with YouTube

Wherever did you see this claim? YTM on Sonos is a bug farm, with Google uninterested in fixing a single thing. This forum is full of threads describing basic bugs and limitations for the YTM-Sonos integration, and Google really do not care. They have your money. Many folks have been much happier after switching to iBroadcast.

@Annazel S

Disclaimer: I know its not your fault Annazel S. But I'm so fed up, that i just need a place to vent my frustrations.

Hi, I've spent several hours trying to get youtube music to work on my sonos system. I've talked to customer support on the phone and they couldn't help either. Yes, i have a premium subscription. Yes, i have tried everything you have asked already. Even with the help of customer support nothing has changed.

First of all your devices aren't cheap. Second of all the app is absolute hot smoldering garbage. Third of all, who's going to compensate me for the hours I've lost trying to get this blasted thing to work, even though i shouldnt be spending !ANY! [I REPEAT] AAAANYYY time on this issue. I payed for a functioning system and it clearly doesn't work as intended or advertised.

I know you guys wont compensate the time I've spent trying to get this to work so I'm hoping i can at least get a freaking refund!

My sonos system has turned into the most overpriced alarm clock I've ever owned.

I must say though, customer support is top notch. Very friendly and try to help to the best of theri ability. AKA the best thing about this company But i didn't pay 250 bucks for customer support, now did I?

Sorry for the rant, I'm just so sick of sonos' $#/+. I've heard it's a youtube problem and not sonos directly but if sonos really care, this issue would've been resolved a loooong time ago.

Reply