Answered

Weird song skipping issue w/ Amazon Music


Userlevel 2
Badge +1
I’ve been having a weird issue with my sonos ones and amazon music. Playing any music and when a song ends, the next song starts...then stops...then beginning of the song that just finished starts, then stops, then another song starts and plays thru. If I skip songs...no problem, works fine. Apple Music on them works perfectly. I have echos etc all over the house, not a network issue. Only happening on sonos.

Just started today, been working fine previously.
icon

Best answer by Keith N 8 March 2019, 19:00

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

41 replies

Exactly the same thing for me too. Just started today.
Userlevel 2
Badge +1
Well I’m glad to hear I’m not alone. Sonos support is always prompt, but, sadly rarely useful. Change your router channel..is there wifi interference? Etc.
That's the most frequent problem. I'd guess over 98 percent of people who report this issue are dealing with problems with wifi interference. Lots of people argue, saying that they haven't changed anything in their local network environment, without realizing that there are lots of external sources of issues, that have nothing to do with what they did. Could be a neighbor who set up a new network that's just started to interfere, or a device that's just started to leak RF (like my microwave did, a few years ago)

But there's other possibilities, too. Could be a simple issue with duplicate IP addresses. You'll see me post about it frequently, as it does happen, especially around the time that Sonos releases a new bit of software, since that has a high potential to expose the problem with your router. And, it could also be an issue with Amazon. It's always hard to tell, especially if you choose not to submit a system diagnostic so that Sonos can look at some data on your system, and determine exactly what the issue is with your system.

And the simple truth is that with the two of you, it can be two completely different issues, that only look the same from the experience side.
Userlevel 2
Badge +1
The wifi interference is BS. No offence. Every other device on wifi in the house is flawless. Other speakers, Apple TV Streaming HD...
I get it, it on their tech support flowchart, but it won’t cause an issue like this.

I had an issue last oct...wifi interference they told me. Turns out it was an amazon issue that was causing it. So...yeh.
Sure, I get that you think that you know what the issue is. I don't, so I can't make anything other than suggestions. But you're not really going to get much in the way of help without submitting a system diagnostic and posting a diagnostic here, or contacting them via their 24/7 Twitter support.

But what you're doing is calling in to the mechanic at the dealership and saying "my car doesn't work" and hanging up. The mechanic just needs a bit more information as to what the specific issue is, and some access to the car. And that's the data that's in the diagnostic that Sonos can read.

But if you prefer not to get any help with this issue, that's up to you. I'll go away.
Userlevel 2
Badge +1
Get off your high horse dude. The first thing I did was contact sonos tech and give them a few diagnostics.
Having the same issues over here as well. Songs stop all of a sudden and then goes to the next song.
I am having the same issue. Amazon music. Just started today
Userlevel 1
Badge +3
Same issue for me over the past couple of days, but with Alexa playing Deezer to my Sonos.
Userlevel 2
Badge +1
Clearly this is an issue on the “other end” somewhere. Tried a pile of things with tech support to no avail.
I have a co worker who is also experiencing this as well.

Last issue I had back in Oct was happening on sonos and my echos as well. Turned out to be an amazon music problem. I’m not having any issues with any amazon speakers this time , played music on all of them and it’s perfect. I’m stumped. Think I’ll have a beer.
Same here with Pandora. I fixed it.
Userlevel 2
Badge +1
Uh...ok. Care to elaborate?


Same here with Pandora. I fixed it.
🙂 I changed the WiFi channel from 6 to 11. Never had a problem until yesterday.
Same issue started a couple of days ago here too with Amazon music. Also, it seems that every morning my Sonos One has grouped itself with one of my Sonos Play 1s in another room too which never used to happen.
Badge +1
Exactly same issue with Amazon music ,started two days ago .I tried to restart router,beam,echo ...changed wifi shannel but problem still persist.
Userlevel 7
@Everyone

All music services appear to be operation as of 03/08/2019 @ 7:35 CST. Click the link:https://status.sonos.com/?language=en_US

That said...and I know you probably won't like this....but you're experiencing a network issue of some type. My steps would be as follows:

They assume your network has not under gone any changes what so ever. Please follow in the order given:

1. Delete the Amazon music service or whichever service you're having issue with
2. Delete the Sonos App
3. Unplug your Sonos products
4. Unplug any other Wi-Fi and/or Ethernet clients
5. Check your routers admin page for firmware updates
6. Reboot your router
7. Check your iOS or Android device for updates
8. Re-install the Sonos App
9. Re-install the Amazon music service or whichever service you're having issue with
10. Plug in your Sonos products one by one. If wired (boost mode) start with that speaker or dedicated Boost module first.
11. Plug in your other Wi-Fi and Ethernet clients
12. Test your streaming service

Cheers!
Userlevel 2
Badge +1
Did all that, no. It’s not a network issue. Apple Music thru sonos is perfect. No issues. Every other device in my house is working perfectly.
I can stream radio on sonos perfectly.


Last time amazon had an issue their status also said all was well, but was not as one of their techs told me they just became aware of server issues.
Userlevel 7
Did all that, no. It’s not a network issue. Apple Music thru sonos is perfect. No issues. Every other device in my house is working perfectly.
I can stream radio on sonos perfectly.


Last time amazon had an issue their status also said all was well, but was not as one of their techs told me they just became aware of server issues.


OK...problem solved as it relates to Sonos and your network. You'll have to beat up on Amazon ;)

Cheers!
Userlevel 2
Badge +1
Well I’m not sure if that’s entirely the case, this behavior only is present only on my sonos speakers. My echos, spot, and dot in the house play with no problems at all.
And everything else thru alexa on sonos is fine..radio, just general responsiveness..all fine. But very specific skipping.
If I skip songs myself, they always play thru perfectly. But if I let them play on their own, the pattern is always the same

1) Song plays and ends normally
2) Next song plays for 2 seconds or so and stops
3) The song that played thru restarts and plays for a couple of seconds
4) Then another song starts and plays through

And this all started a couple of days ago.
YES. Exactly the same as @caseyfinn for me as well.

Every other streaming music service I've tried does not have this issue.
Amazon Music does not have this issue when playing directly via Sonos App.
Amazon Music does not have this issue when playing through Alexa on an Ecobee, Dot, or Echo.

It only happens when playing Amazon Music on a Sonos One using Alexa. And only started a few days ago. I've tried unlinking, relinking, turning it off and on, rebooting router, etc. but none of these solve the issue.
Userlevel 2
Badge
Hi, i've exactly the same problem since few day. This happens only when i ask to play music from Alexa. If i use local songs on NAS or Apple Music, everything works fine.
I've tried to unactive/active Sonos skill, and reboot all mys Sonos speakers (4) and echo devices (3).

I've created a case on support team and try to join it by phone. But impossible for now. (i'm in France).

Sorry, but i'm happy not to be alone :8 Hope Sonos will help us to resolve this issue.
Badge
Same exact issue here (https://en.community.sonos.com/troubleshooting-228999/amazon-music-skips-entire-tracks-when-advancing-to-next-song-6821502/index1.html#post16318131). It's NOT a WiFi issue. I'd love to punch the next person that blindly says that right in the face. This has NEVER been an issue before and it started just a few days ago and pretty much happens all the time now. Others are experiencing this "new behavior" at about the same time (starting a few days ago). You only need a few functioning brain cells to realize that SOMETHING HAS CHANGED. This is probably where Amazon and Sonos just point the finger at each other for the next 6-12 months until this finally gets fixed.

EDIT: Just got off the phone with Sonos for the 2nd day in a row. After lots of discussion I did get them to flat out say that this is not a WiFi issue. They are escalating the case and they are going to call me back.
Userlevel 2
Badge +1
Well that’s good to hear. I’m done wasting hours unplugging speakers, connecting to routers, deleting and reinstalling... all for nothing.
After playing fine all day yesterday after I changed WiFi channel, it's back today. So yeah, not a Wifi issue.
Userlevel 7
Badge +19
Moderator Note: This issue should now be resolved. If you're having any issues with audio skipping, please see this troubleshooting guide. If any issues continue, feel free to start a new thread.

Hello everyone. The team is aware of the skipping behavior on Amazon Music and is taking a closer look at the issue. That said, I will be sure to update this thread when more information becomes available. Thanks for your patience.