using Amazon Music on Sonos with 4G Router

  • 22 February 2020
  • 34 replies
  • 323 views

Badge

I have set up my Sonos system, 2 paired play 1s and 1 Sonos One,  with a 4 G Router.  Everything works as it used to on the telephone wire router except Amazon Music.

 

I have deleted and re-installed Amazon Music but the result is the same.

 

e.g. I can search for an artist, display albums etc. But can’t display the contents or play individual songs.   Other music providers like TuneIn are working.

 

how do I get Amazon music to set up and play on a 4g router


34 replies

Badge

That solution still works.
 

  I did start to get a problem where on of the stereo pairs could not be identified.  E.g. it showed as (L + ?)    It looks like although it was part of the network for some reason it re attached itself to the old WiFi which was still switched on.    One or the other of the stereo pair play 1,s keeps dong this but if I turn of the old WiFIi everything seems to stay stable.   Bizarrely it’s not always the same one e.g. it showed as (?+R). 
I am also never quite sure if I am in a WiFi network or a stand alone Apple Play network.   But for now I am happy that it works. 

 

Leopard,

Perhaps try this…

Goto your Huawei router settings and set the 2.4ghx WiFi to ‘fixed' channel 6 instead of auto. Then wire a single Sonos device to one of the  routers Ethernet ports… this will switch All your Sonos devices to communicate via a SonosNet signal.

Then do these two things…

  1. Remove/reset the WiFi credentials in the Sonos App “SettingsSystem/Network/Wireless Setup”. These are not needed when running the devices solely on SonosNet. (If you do ever decide to un-cable the Sonos device from the router, remember to put the 2.4ghz WiFi credentials back here in the Sonos App).
  2. Goto “Settings/System/Network” and set the SonosNet channel to either channel 1 or 11.

See if that improves things for you. I’m assuming you will have switched off your other wired home router when doing the above as you don’t want it’s WiFi channels conflicting with any of the above… if you do want that router switched on aswell then set it to use the non-overlapping channel 1 or 11 that you leave unused when setting the SonosNet channel on your Huawei device.

I hope that all makes sense to you.. it will be interesting to see if the above also improves, or fixes, the issue with the Amazon Music searches. Unfortunately I can’t test this here, as my MiFi device does not have an Ethernet port.   

im having the exact same problem, but all i have is more mystery.

 

i had a similar setup with a 4g router, sonos and amazon music was working fine but when i got a new contract they sent a new sim card.  When i use this new sim card in the router i cannot browse amazon music either.  

 

three says its not them

amazon says its not them

sonos i cant get through to?

 

grrrr

 

im having the exact same problem, but all i have is more mystery.

 

i had a similar setup with a 4g router, sonos and amazon music was working fine but when i got a new contract they sent a new sim card.  When i use this new sim card in the router i cannot browse amazon music either.  

 

three says its not them

amazon says its not them

sonos i cant get through to?

 

grrrr

 

One would not have expected this to make a difference.  Is this a change of mobile internet provider?

Have you tried the universal IT solution - turn it off and on again.  The router and Sonos, I mean.

Can you play internet radio?

It may be worth changing DNS servers to Google Public DNS.

same provider three, just new contract and new sim card

still got the old sim as the contracts are overlapping until the end of the month and when i put that in the router it works perfectly.

 

new sim unable to browse music on amazon, and it loks like heart radio too

same provider three, just new contract and new sim card

still got the old sim as the contracts are overlapping until the end of the month and when i put that in the router it works perfectly.

 

new sim unable to browse music on amazon, and it loks like heart radio too

The only thing I can think of (and with little confidence) is that the new sim is having problems connecting to certain servers.  Hence the suggestion to change ISP DNS to Google Public.  A bit of a shot in the dark - i have not seen this issue before.

Although it makes no logical sense, you might also try uninstalling Amazon music from Sonos, reboot router with new sim, then re-add Amazon Music.

Another random thought, make sure the router is continuing to use a 2.4Ghz channel with the new sim? Hard to imagine that they’d change the software on the router by tagging the SIM card in it, but it’s another random possibility to at least look at. 

And I’m with John, this doesn’t make any sense.

Precisely same problem here too. Amazon music HD works fine on phone, iPad, computers etc with Huawei 4G router via 3. Unable to browse music via Sonos. Tune in works, 7 Digital works, Spotify works. 

Have checked at partners place via wired broadband connection - Sonos works perfectly with Amazon HD on same Sonos account. 

Currently using Amazon Music to to stream to Sonos system rather than native Sonos streaming. 

Will try DNS fix but tricky to access that on Huawei Routers.

Reply