Unable to access music from QNAP NAS

  • 17 September 2016
  • 15 replies
  • 3243 views

Every time I try and access my QNAP NAS from SONOS I cannot. It can see the music, all the albums are there, but when I select an album, when it opens all the tracks are greyed out and if I trt the play track option I get a message to the effect that the track cannot be added to the queue.
Tha NAS isn;t locked because mt streamer can access it no problem,

Any ideas please?

Thanks

Lee

15 replies

I should add that it plays all the music stored in my computer and all the music in my Amazon account, just not the NAS. 🙂
Userlevel 7
Badge +20
I should add that it plays all the music stored in my computer and all the music in my Amazon account, just not the NAS. :)

Hi Lee,

Please try removing the music share in Sonos then add it back and see if that works. By doing so, you'll set the sharing permissions again. If that doesn't work, please submit a diagnostic report and reply with the confirmation number.
Hello,
I've had the same problem playing music from QNAP NAS TS-251. After mapping NAS to the Sonos 5 all files/folders are accessible, can browse
all information but Wen try play music get a message 'unable to add song to the queue'.
I found that everything can be played from "Music Library ".
Good Luck!
Todor
Did anybody get a solution to this problem ? Recently happened to me, can play music which is loaded on my device, but not from remote ( such as QNAP ) ? Sonos, listen to us !
Userlevel 6
Badge +3
Did anybody get a solution to this problem ? Recently happened to me, can play music which is loaded on my device, but not from remote ( such as QNAP ) ? Sonos, listen to us !

Hi Paul, sorry for the late reply.
We'd like more information about your Sonos. Can you send us a diagnostic and reply with the confirmation number? Here's an article explaining how: How to Submit Diagnostic
I have used a QNAP NAS and a shared music folder for 3 years and just had this issue. To be fair both the QNAP CTS and the Sonos have received updates, but never the less I need help to resolve this. I have a large music library and invested a lot of money in Sonos. I have removed the music library from Sonos and now it will not let me add it back says access denied check file path and password
mxs571,

Did you perchance submit the diagnostic as requested by the Sonos employee in the post before yours? If so, I would recommend posting the number here, so that they can more easily pull up the data.
Yes, Diagnostic Confirmation Number is 7686960
I have a QNAP TS-251A NAS. I can see the server under my list of services available in my SONOS app and can access it. I can see the sample songs that ship with the QNAP in the media folder, but when I click on them using the SONOS app I get a "no music" message at the bottom. However, the single song that I transferred from my music library on another NAS (which the SONOS plays fine from) and placed in the Multimedia folder on the QNAP looks greyed out/inaccessible through my sonos app, but it does play through the media viewer app on the QNAP.
Hello mxs571 and mclaymannn; many thanks for reaching out, and welcome.

mxs571, it looks like Sonos is having trouble finding the NAS. The players are querying the router for the IP address of the NAS but the router doesn't respond with that information. You might wish to consider adding a reserved ip entry into the Netgear settings so the NAS always receives the same address.

mclaymannn, would you mind checking the file type and extension on the greyed out music track? Also, would you mind submitting a diagnostic from your Sonos system and replying back with your confirmation number?
Have the same with my qnap TS-253B. Actually bought to not have to play my music from my laptop. When I try to add the music drive on my nas via the nas button, it does not appear as a library that I can add. The nas does not appear when I click to open the list of drives on my network, only those I share via my laptop with the rest of my network.
I had this same problem for ages and could not get any help from this site. However, I persisted and found the following way to manage my music on the QNAP via my MacBook Pro to my QNAP NAS TS 212 worked. In SONOS on your MacBook Pro, click on the MANAGE tab, then click on Music Library, then click on the (+) button an add the path for your Music on the QNAP NAS. This will look something like this:- //(name of your QNAPNAS)/Multimedia/iTunes , then get the system to search for your music on the NAS. I found that this was difficult, so you have to ensure you get the path right, drilling down to the music on your NAS correctly. When you are asked to login and give a password, its not the login or password to your QNAP NAS, but the Login and Password to your MacBook Pro. No longer a PC User, I assume it will be your login for your PC. I hope this helps.
This has hit me recently also, it was working fine up to about 3 months ago. I've spend a ton of time trying to sort this out and frustratingly it's simply not working and I'm unsure where the issue lies...

1. Plex server Version 1.13.8.5395
2. Sonos 9.2 build 46357250
3. QNAP TS-253B Version 4.3.5.0722

Double NAT doesn't seem to be an issue.
Plex fully accessible outside of network using port forwarding (wasn't required before for Plex to work with Sonos). I can access Plex via mobile outside of network.

Diagnostic number: 222809831
I am getting exactly the same problem
Plex Server Version 1.13.8.5395
Drobo 5N NAS
Sonos 9.2 Build 46357271
I had what seems like the same problem, and I recently fixed it. I wanted to share my success in case anyone finds it helpful.
I started getting a "cannot add tracks to queue" error from Sonos after updating my QNAP software a while back, and since then I saw this error whenever I tried to play music from the QNAP on Sonos (although the track names and everything were still visible).
I did some research and found that Sonos likes to connect using SMB v1, and QNAP now defaults to using SMB v2 (for those who are confused, SMB is the "samba" filesharing protocol generally associated with Windows machines; it is one of several filesharing protocols supported by QNAP and the only one used by Sonos). I was able to fix the problem easily by changing the version of SMB that QNAP was using. In the QNAP control panel, I went to Network & File Services -> Win/Mac/NFS -> Microsoft Networking -> Advanced Options -> Highest SMB Version and changed that setting to 1. Applying this change fixed the problem for me immediately.

Reply